Error on begin_repeat

Dear all,
I am getting a continuous server error on a begin_repeat within a repeat. See attached xls form. I tried everything but the form remains bugging on row 9 when I try to upload it to the Aggregate server. I get the message: HTTP Status 400 - Problem with JavaRosa Parsing Form: org.opendatakit.aggregate.exception.ODKIncompleteSubmissionData: Javarosa failed to construct a FormDef. Is this an XForm definition?

If I remove the ${tree_distribution_calculate} in row 9, there is no problem and I can uopload it. I tried on 2 different ODK Aggregate servers but with no result. I also tried older forms that worked fine in the past with the same solution, but they are also bugging on both servers. As you see I also tried jr:count, but didn't work neither... Any suggestions what could be the problem? Thanks for the help.ODK_Forum_.xlsx (17.1 KB)

What versions of ODK Aggregate are you using? Also what did you use to do the form conversion?

Version 1.4.7 and as the convertor. It may be a corrupt excel file since I wrote an entirely new version with the same repeat function and that seem to work while I still have problems with older versions. Strange things going on...:slight_smile:

There seems to be a problem with repeat and the versions of ODK Aggregate and converters. Strange things happen with my field forms. Things that worked fine in the past now do not seem to work anymore while I can't figure out what is the problem. I worked with an older version of Aggregate and an offline XLS converter that always worked fine. From one moment, they did not work anymore. While older xml forms still were accepted by aggregate, my newer forms were not, although I worked with an older offline xls converter. Despite I was doing, nothing worked, neither the online xls converter. With an update of aggregate, it now worked, also with the offline xls converter, which seems strange to me. So, this problem is solved, although I haven't found out what was the problem.... However, now I have the next problem: labels in a repeat with count-selected and jr:choice are not shown anymore inside the repeat. With the older offline converter, it works fine on an older form. Also with the online xls converter on the same older form. Also when I use an extracted version of my new form (using only the repeat) it works. But when I try the entire new form, it does not work, neither with the offline as the online xls converter. The form converted with xls offline is then no accepted by aggregate while the form converted with xls online is accepted, but does not show the labels.... I am confused. I will continue figure out, its too complex to answer, but maybe others experience the same inconsistency problems lately(?).