Error: Required parameter form ID xml attribute missing

1. What is the issue? Please be detailed.

when i try to submitted a new form to my odk servers the server send me the next message

"Required parameter form ID xml attribute missing"

WhatsApp Image 2023-07-05 at 10.59.07

2. What steps can we take to reproduce this issue?

3. What have you tried to fix the issue?

i try to fix, change my form, change the version create a new proyect, but the error dosen't fix


client (v2022.3.0)
server (v2022.3.1)

Can you upload the XLSForm file here?
If you try and test the form on what happens?

hello, and thanks for tehe response.

my form it,s in XML Format and i created in ODKBuild

form.xml (80.3 KB)

thanks in advanced.

Under the file menu, there should be an "Export to XLSForm" option. Can you please use that and share the file?

Also, the .xml file you attached works for me with Central version:

302b58237ac0b0c8d8c5aa49c682b919052f0aad (v2023.2.1)
 d4c964826031477962b05b6d08dfa8fecec98db2 client (v2023.2.0)
 05ebccdea1736240ceafa929399d25920c7bdb2f server (v2023.2.0)

It may help if you upgrade your Central instance.


but after do that the aplicacion send me de next message:

Something went wrong while exporting. Please try again later.

i need to program a backup in the next days to do an upgrade for my server, but at the moment that is no posible...

Can you please post the FOO.odkbuild of the original ODK Build saved file that is causing the problem; that may help narrow down where the issue lies. Thanks


this are the file from ODKBuild. (3.5 KB)

Thanks in advanced.

I saw a similar error in a form, and found it somewhat hard to diagnose.

eventually it became clear that the use of the word ‘model’ as a variable name is the root of the problem.

This seems to be independent of the question type. I tried it with both select_one and text type questions and whenever I used ‘model’ as the name, I got the same error.

Screenshot 2023-10-03 at 11.23.41

Screenshot 2023-10-03 at 11.23.14

I’m guessing that some internal code uses model as a variable and this breaks it.

Looking back through the code from the above post, you can see that @diego_villanueva used ‘model’ as a variable in their form.


You don’t have to look far for this in the xform code, so I think the answer is not to use ‘model’ as a variable name


We will add validation, sorry you ran into that and thanks so much for following up!