Errors with ODK Central 1.5.3 with external postgresql database

1. What is the issue? Please be detailed.
I'm looking to configure ODK Central with an external postgresql database using postgresql version 10. My database is running on the same host that the ODK containers are running on - but it's running directly on the host, not inside a container.

When starting ODK Central via docker compose up the logs for the central service report that it can connect to the database but then report a permission denied error accessing one of the files inside the container:

central-service-1   | waiting 15 seconds for host.docker.internal:5432
central-service-1   | host.docker.internal:5432 is available after 0 seconds
central-service-1   | generating local service configuration..
central-service-1   | running migrations..
central-service-1   | (node:21) UnhandledPromiseRejectionWarning: error: could not open relation mapping file "global/": Permission denied
central-service-1   |     at Parser.parseErrorMessage (/usr/odk/node_modules/pg-protocol/dist/parser.js:278:15)
central-service-1   |     at Parser.handlePacket (/usr/odk/node_modules/pg-protocol/dist/parser.js:126:29)
central-service-1   |     at Parser.parse (/usr/odk/node_modules/pg-protocol/dist/parser.js:39:38)
central-service-1   |     at Socket.<anonymous> (/usr/odk/node_modules/pg-protocol/dist/index.js:10:42)
central-service-1   |     at Socket.emit (events.js:400:28)
central-service-1   |     at Socket.emit (domain.js:475:12)
central-service-1   |     at addChunk (internal/streams/readable.js:293:12)
central-service-1   |     at readableAddChunk (internal/streams/readable.js:267:9)
central-service-1   |     at Socket.Readable.push (internal/streams/readable.js:206:10)
central-service-1   |     at TCP.onStreamRead (internal/stream_base_commons.js:188:23)
central-service-1   | (Use `node --trace-warnings ...` to show where the warning was created)

I do not see the same error if I use the default database configuration (i.e. use the included postgres container).

Many thanks for any suggestions to diagnose or fix this issue.

2. What steps can we take to reproduce this issue?
Configure central to use an external postgresql database at version 10.

3. What have you tried to fix the issue?
The included postgres database using postgres version 9. I see the same error above using either postgres version 15 or postgres version 10. I haven't yet tried it with postgres version 9.

4. Upload any test forms or screenshots below.

Hi @Geoffrey_Ferrari ,

I faced same issues here in India.
Please follow this post.

This will help you. Server migration took nearby 4 hours on my server. Might be it will take less or more time on your server.

I hope this will fix your issue.