Executing the mysql.exe commandline client

1. What is the problem? Be very detailed.
When executing the command mysql.exe --user root --password it returns the following message :mysql.exe is not recognized as an internal or external command...
2. What app or server are you using and on what device and operating system? Include version numbers.
i am using ODK aggregate V2.0.3, tomcat 8.5.41 and MySQL on Windows 8.1.
3. What you have you tried to fix the problem?
I tried to install MySQL 5.5. the mysql.exe was recognised and the commandline was executed. but when i tried to access ODK aggregate it returned the 404 error. i checked the catalina.exe and it was mentionned "problem with MySQL".
4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

This isn't the problem you are having, but please note that we don't test or support anything but MySQL 5.7.

As to the issue, it sounds like you don't have mysql.exe in your PATH. A simple solution is to make sure you are in the bin folder (it looks like you are in system32) before running mysql.exe.

Thanks Alot for the reply ! i solved the problem thanks to your help. Unfortunatelly when i'm trying to acces the it returns The 404 error-not found.
The tomcat8-stderr.log says that: "Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '(6) NOT NULL , _LAST_UPDATE_URI_USER VARCHAR(80) CHARACTER SET utf8 NULL , `_L' at line 1"
It seems to be a problem of syntax but i've changed database name and password many times but still not working .
As you suggested, i'm actually trying to install MySQL 5.7. and see if it will work.