Export now to csv the form name is not available

Souirji
I am trying to pull data using Aggregate Briefcase but I have an issue,. I can pull it successfully but when I try to export now to csv the form name is not available, any help?

Hi @Cherukip,

How did you exactly pull the data? is it from a mounted Android SD Card, or from a directory in your pc or from an Aggregate server?

Then did you check if there are indeed forms in the pulled instances folder?

Hi Souirji
Thanks for your reply. My data is in Aggregate server.
It can pull successfully but is not visible in push instances.
Thanks

hi@cherukip,

Sorry for not being able to help; I'm not at all familiar with Aggregate server as I don't use it in my workflow.

Best regards

I'd love to help, but your post does not contain enough information for me to answer your question. In general, the best way to get help is to fill out the questions in the pre-filled template that you get when you create a support post. So, with that in mind, can you answer these questions?

  1. What ODK tool and version are you using?
  2. What you have you tried to fix the problem?

Dear Yonakwa
Thanks for your reply.
Its like this, My collected data resides in Aggregate server.
When I try to download my data using ODK Briefcase, It can pull successfully, but when I go to export' section I cant find the pulled form. I have several forms though, but its only one which is of interest to me which fails to show up.
The one written final (Circled red) is successfully pulled, but when I go to export i find it missing.

!
Thanks

This is most likely a bug, but it'll be hard to debug remotely.

Is it possible for you to zip up and send me your ODK Briefcase Storage folder? I have sent you a personal message with a link for you to send me the files.

Thanks. Kindly give me your gmail account so that can share with you.

My account is yanokwa@nafundi.com

@Cherukip, this took a long time to figure out, but I've finally figured it out!

Your form has a title with a period. This is fine.
<h:title>My Form.</h:title>

And the form file that Briefcase downloads also has a period which results in a double period. This is also fine.
My Form..xml

But the folder name from that holds that form file does not have a period, which is unexpected.
My Form

This is problematic because Briefcase looks for the form definition using
ODK Briefcase Storage/Form title/Form title.xml.

So in this case, it's looking for:
ODK Briefcase Storage/My Form./My Form..xml

But the data you sent me has
ODK Briefcase Storage/My Form/My Form..xml

If you are looking for the fastest fix, just add periods to the folder names. So like this

ODK Briefcase Storage/Final KIWASH Households WASH AgriNutrition Mapping Questionnaire./Final KIWASH Households WASH AgriNutrition Mapping Questionnaire..xml
ODK Briefcase Storage/ODK Briefcase Storage/KIWASH Households WASH AgriNutrition Mapping Questionnaire./KIWASH Households WASH AgriNutrition Mapping Questionnaire..xml

Then quit and re-open Briefcase, and it should show the forms and let you export.

But if you are willing to help us fix this, then I'd love your help because I can't reproduce this with my test form with period in the title! Briefcase 1.8 does the right thing. And so does Briefcase 1.6.

So maybe you used a different version of Aggregate/Briefcase to download the data? Or maybe you pulled it from an SD card first? Or maybe you manually changed the title in that folder manually? Or maybe it's on a file system that doesn't allow periods at the end of folders? Any ideas as to why the title on the filesystem changed?

Hmm. Anytime unsanitized 'user' submitted input (eg a form title name) is used to auto-generate filenames - which from your investigation here appears to be the case - it can potentially open up security issues. eg imagine I upload a form which I have deviously titled "../../../etc/password". Might be worth doubling-checking where it used, and possibly adding some sanitize code.

auto-generated filenames from user input always raises a red flag with me... :worried:

1 Like

Agreed. I want to track down the core issue first, then we have a contributor standing by to fix it more broadly (Hi @nribeka!)

@yanokwa,

I looked at this last night and I think this is Windows issue. I think briefcase tried to create the folder with period at the end of the folder name, but Windows will strip that last period. Period in the middle will be fine as folder name. Thanks Bill!

So Period Bug. will become Period Bug, but Period.Bug is fine. I think this is why briefcase reported success but you can't do anything with it afterwards :smile:

1 Like

Apparently it is in their documentation:

https://msdn.microsoft.com/en-us/library/aa365247(VS.85).aspx

Do not end a file or directory name with a space or a period. Although the underlying file system may support such names, the Windows shell and user interface does not. However, it is acceptable to specify a period as the first character of a name. For example, ".temp".

Great detective work, Win! Can you file an issue at https://github.com/opendatakit/briefcase and send in a PR, please?

Will be tracked here: https://github.com/opendatakit/briefcase/issues/223. Will put out PR shortly.

@yanokwa
Thanks for this. I really appreciate your support.
I have decided to change the form title though, while retaining the contents- for future use and its working.
Thanks

1 Like