Fatal error, can't open config file '/usr/local/etc/redis/redis.conf'

1. What is the issue? Please be detailed.
After building the application, when i do docker-compose up -d, and then docker compose ps, i see all the container's up and running except for: central_enketo_redis_cache_1 ,central_enketo_redis_main_1 , they keep getting restarting state.

When i check the logs i am getting the following error in both conatiners - # Fatal error, can't open config file '/usr/local/etc/redis/redis.conf': Permission denied

2. What steps can we take to reproduce this issue?

3. What have you tried to fix the issue?
i have checked my user permission's from which i am making the build, tried re-installing docker & docker-compose

4. Upload any forms or screenshots you can share publicly below.
Also i tried using only docker-compose up then i could also see this following error in logs :
enketo_1 | Error: connect ECONNREFUSED
enketo_1 | at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1159:16) {
enketo_1 | errno: -111,
enketo_1 | code: 'ECONNREFUSED',
enketo_1 | syscall: 'connect',
enketo_1 | address: '',
enketo_1 | port: 6380
enketo_1 | }

Please do share any solution or idea you might have to try or anyone with a solution that fixed this issue.

  • Is this a fresh installation or an upgrade?
  • Are you doing anything different from the installation instructions?
  • Are you doing any of the advanced configuration options?
  • What are you installing on?
  • Is anything else running on the same server?

Hi @danbjoseph ,

  1. it's a fresh installation
  2. no i am following the instruction's provided
  3. No, i am just setting up basic odk application as per the instructions
  4. it's an azure linux vm centos 8
  5. No

one thing that i found is when i do ls -la in my dev server it is showing me 13 hardlinks to the docker directory.

However, on my other server it is showing 12. Do you know anything about this?