First time log in to ODKAggregate giving OpenID auth error

Dear fellows,

With the help of ODK community I have deployed ODKAggregat 1.4.3 on tomcat with mysql.

On first time log in, when i try to access through my superUser which is @gmail.com, it gives error mentioning OpenID auth request contains unregistered domain.

Please see the error page attached. Kindly guide how to proceed.

Thanks

Check your logs. You absolutely sure your superUser is a gmail
account? You can also open the jar at
/WEB-INF/lib/ODKAggregate-settings.jar and see what is says in
security.properties

Also, any chance you are changing any of the HTTP headers?

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Tue, May 20, 2014 at 12:23 AM, plannerqadeer@gmail.com wrote:

Dear fellows,

With the help of ODK community I have deployed ODKAggregat 1.4.3 on tomcat with mysql.

On first time log in, when i try to access through my superUser which is @gmail.com, it gives error mentioning OpenID auth request contains unregistered domain.

Please see the error page attached. Kindly guide how to proceed.

Thanks

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Log in using the Aggregate password using superuser that you typed during the installation and use password aggregate. You can change this password "aggregate" once you log in.

I am seeing the same issue. I think the reason is caused by Google's deprecation of the OpenID 2.0 API.

According to the Migration timetable (https://developers.google.com/+/api/auth-migration#timetable). In May 2014, Google has closed registration to new clients of OpenID 2.0. As such, you're not able to log into any newly setup Aggregate server after May 2014.

If anyone found a workaround, please let me know. I just need a way to log into the server with an Admin account, after that, I can set up some ODK users account and log in afterward with that. Thanks

Aaron

··· On Tuesday, May 20, 2014 9:42:37 AM UTC-4, Yaw Anokwa wrote: > Check your logs. You absolutely sure your superUser is a gmail > > account? You can also open the jar at > > /WEB-INF/lib/ODKAggregate-settings.jar and see what is says in > > security.properties > > > > Also, any chance you are changing any of the HTTP headers? > > > > Yaw > > -- > > Need ODK services? http://nafundi.com provides form design, server > > setup, professional support, and software development for ODK. > > > > On Tue, May 20, 2014 at 12:23 AM, wrote: > > > Dear fellows, > > > > > > With the help of ODK community I have deployed ODKAggregat 1.4.3 on tomcat with mysql. > > > > > > On first time log in, when i try to access through my superUser which is @gmail.com, it gives error mentioning OpenID auth request contains unregistered domain. > > > > > > Please see the error page attached. Kindly guide how to proceed. > > > > > > Thanks > > > > > > -- > > > -- > > > Post: opendatakit@googlegroups.com > > > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > > > --- > > > You received this message because you are subscribed to the Google Groups "ODK Community" group. > > > To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit+unsubscribe@googlegroups.com. > > > For more options, visit https://groups.google.com/d/optout.

I have confirmed that this is the case. This will impact the ODK
Aggregate VM and all ODK Aggregate installs not using AppEngine.

The work-around steps are rather tedious:

(1) place the ODKAggregate.war file in the Tomcat webapps directory
(2) start Tomcat so that the war file is exploded in the directory tree.
(3) stop Tomcat
(4) move the ODKAggregate.war file out of the webapps directory for safe
keeping -- leave the ODKAggregate directory in place (we don't want Tomcat
to ever re-explode the war).
(5) navigate into the ODKAggregate\WEB-INF\lib directory
(6) copy the ODKAggregate-settings.jar to another location
(7) rename the ODKAggregate-settings.jar to ODKAggregate-settings.zip
(8) right-click, choose "Extract all..." to explode this into a directory
tree.
(9) navigate into ODKAggregate-settings
(10) use Notepad to open the "security.properties" file (DO NOT USE Word)
(11) find the line:
security.server.superUserUsername=
(12) add a username at the end of the line. This will be the ODK Aggregate
username for the superuser.
(13) save the file.
(14) navigate back up to the directory containing the ODKAggregate-settings
directory
(15) right-click on the ODKAggregate-settings directory, choose "Send
to..." and select "Compressed (zipped) folder"
(16) rename that file to ODKAggregate-settings.jar
(17) copy that file back into the Tomcat webapps\ODKAggregate\WEB-INF\lib
directory (overwriting the original file)
(18) start Tomcat
(19) Choose to Log in using the ODK Aggregate username
(20) enter the username you gave in step 12.
(21) enter "aggregate" for the password

...and please change the password to something other than "aggregate"

Mitch

··· On Tue, May 20, 2014 at 7:38 AM, wrote:

I am seeing the same issue. I think the reason is caused by Google's
deprecation of the OpenID 2.0 API.

According to the Migration timetable (
https://developers.google.com/+/api/auth-migration#timetable). In May
2014, Google has closed registration to new clients of OpenID 2.0. As
such, you're not able to log into any newly setup Aggregate server after
May 2014.

If anyone found a workaround, please let me know. I just need a way to
log into the server with an Admin account, after that, I can set up some
ODK users account and log in afterward with that. Thanks

Aaron

On Tuesday, May 20, 2014 9:42:37 AM UTC-4, Yaw Anokwa wrote:

Check your logs. You absolutely sure your superUser is a gmail

account? You can also open the jar at

/WEB-INF/lib/ODKAggregate-settings.jar and see what is says in

security.properties

Also, any chance you are changing any of the HTTP headers?

Yaw

--

Need ODK services? http://nafundi.com provides form design, server

setup, professional support, and software development for ODK.

On Tue, May 20, 2014 at 12:23 AM, plannerqadeer@gmail.com wrote:

Dear fellows,

With the help of ODK community I have deployed ODKAggregat 1.4.3 on
tomcat with mysql.

On first time log in, when i try to access through my superUser which
is @gmail.com, it gives error mentioning OpenID auth request contains
unregistered domain.

Please see the error page attached. Kindly guide how to proceed.

Thanks

--

--

Post: opendatakit@googlegroups.com

Unsubscribe: opendatakit+unsubscribe@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Mitch,

I don't think this affects the VM. As part of the VM build, I strip
out the superUserUsername and default it to aggregate, and re-bundle
the WAR. This is one of the reasons why the VM isn't meant for
production environments...

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Tue, May 20, 2014 at 10:49 AM, Mitch Sundt mitchellsundt@gmail.com wrote:

I have confirmed that this is the case. This will impact the ODK Aggregate
VM and all ODK Aggregate installs not using AppEngine.

The work-around steps are rather tedious:

(1) place the ODKAggregate.war file in the Tomcat webapps directory
(2) start Tomcat so that the war file is exploded in the directory tree.
(3) stop Tomcat
(4) move the ODKAggregate.war file out of the webapps directory for safe
keeping -- leave the ODKAggregate directory in place (we don't want Tomcat
to ever re-explode the war).
(5) navigate into the ODKAggregate\WEB-INF\lib directory
(6) copy the ODKAggregate-settings.jar to another location
(7) rename the ODKAggregate-settings.jar to ODKAggregate-settings.zip
(8) right-click, choose "Extract all..." to explode this into a directory
tree.
(9) navigate into ODKAggregate-settings
(10) use Notepad to open the "security.properties" file (DO NOT USE Word)
(11) find the line:
security.server.superUserUsername=
(12) add a username at the end of the line. This will be the ODK Aggregate
username for the superuser.
(13) save the file.
(14) navigate back up to the directory containing the ODKAggregate-settings
directory
(15) right-click on the ODKAggregate-settings directory, choose "Send to..."
and select "Compressed (zipped) folder"
(16) rename that file to ODKAggregate-settings.jar
(17) copy that file back into the Tomcat webapps\ODKAggregate\WEB-INF\lib
directory (overwriting the original file)
(18) start Tomcat
(19) Choose to Log in using the ODK Aggregate username
(20) enter the username you gave in step 12.
(21) enter "aggregate" for the password

...and please change the password to something other than "aggregate"

Mitch

On Tue, May 20, 2014 at 7:38 AM, wvearo@gmail.com wrote:

I am seeing the same issue. I think the reason is caused by Google's
deprecation of the OpenID 2.0 API.

According to the Migration timetable
(https://developers.google.com/+/api/auth-migration#timetable). In May
2014, Google has closed registration to new clients of OpenID 2.0. As such,
you're not able to log into any newly setup Aggregate server after May 2014.

If anyone found a workaround, please let me know. I just need a way to
log into the server with an Admin account, after that, I can set up some ODK
users account and log in afterward with that. Thanks

Aaron

On Tuesday, May 20, 2014 9:42:37 AM UTC-4, Yaw Anokwa wrote:

Check your logs. You absolutely sure your superUser is a gmail

account? You can also open the jar at

/WEB-INF/lib/ODKAggregate-settings.jar and see what is says in

security.properties

Also, any chance you are changing any of the HTTP headers?

Yaw

--

Need ODK services? http://nafundi.com provides form design, server

setup, professional support, and software development for ODK.

On Tue, May 20, 2014 at 12:23 AM, plannerqadeer@gmail.com wrote:

Dear fellows,

With the help of ODK community I have deployed ODKAggregat 1.4.3 on
tomcat with mysql.

On first time log in, when i try to access through my superUser which
is @gmail.com, it gives error mentioning OpenID auth request contains
unregistered domain.

Please see the error page attached. Kindly guide how to proceed.

Thanks

--

--

Post: opendatakit@googlegroups.com

Unsubscribe: opendatakit+unsubscribe@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I just tried this on Linux and it worked. However to compress again the files to .jar I had to follow this :

  1. Go to inside the directory where you have all extracted files
  2. jar cf ODKAggregate-settings.jar *

PS: compress as zip and then rename to .jar seems to not work in Linux. When you do this using this way the ODKAggreagator will not load.

Thanks.

··· On Tuesday, May 20, 2014 7:49:33 PM UTC+2, Mitch Sundt wrote: > I have confirmed that this is the case. This will impact the ODK Aggregate VM and all ODK Aggregate installs not using AppEngine. > > > The work-around steps are rather tedious: > > (1) place the ODKAggregate.war file in the Tomcat webapps directory > (2) start Tomcat so that the war file is exploded in the directory tree. > (3) stop Tomcat > > (4) move the ODKAggregate.war file out of the webapps directory for safe keeping -- leave the ODKAggregate directory in place (we don't want Tomcat to ever re-explode the war). > (5) navigate into the ODKAggregate\WEB-INF\lib directory > > (6) copy the ODKAggregate-settings.jar to another location > (7) rename the ODKAggregate-settings.jar to ODKAggregate-settings.zip > (8) right-click, choose "Extract all..." to explode this into a directory tree. > > (9) navigate into ODKAggregate-settings > (10) use Notepad to open the "security.properties" file (DO NOT USE Word) > (11) find the line: > > > > > > > > > > > > security.server.superUserUsername= > > (12) add a username at the end of the line. This will be the ODK Aggregate username for the superuser. > > (13) save the file. > > (14) navigate back up to the directory containing the ODKAggregate-settings directory > > > (15) right-click on the ODKAggregate-settings directory, choose "Send to..." and select "Compressed (zipped) folder" > > (16) rename that file to ODKAggregate-settings.jar > > > (17) copy that file back into the Tomcat webapps\ODKAggregate\WEB-INF\lib directory (overwriting the original file) > > (18) start Tomcat > > (19) Choose to Log in using the ODK Aggregate username > > > (20) enter the username you gave in step 12. > > (21) enter "aggregate" for the password > > > ...and please change the password to something other than "aggregate" > > > > > Mitch > > > > > > > > > > > > > > On Tue, May 20, 2014 at 7:38 AM, wrote: > > I am seeing the same issue. I think the reason is caused by Google's deprecation of the OpenID 2.0 API. > > > > According to the Migration timetable (https://developers.google.com/+/api/auth-migration#timetable). In May 2014, Google has closed registration to new clients of OpenID 2.0. As such, you're not able to log into any newly setup Aggregate server after May 2014. > > > > > If anyone found a workaround, please let me know. I just need a way to log into the server with an Admin account, after that, I can set up some ODK users account and log in afterward with that. Thanks > > > > Aaron > > > > > > > > On Tuesday, May 20, 2014 9:42:37 AM UTC-4, Yaw Anokwa wrote: > > > Check your logs. You absolutely sure your superUser is a gmail > > > > > > account? You can also open the jar at > > > > > > /WEB-INF/lib/ODKAggregate-settings.jar and see what is says in > > > > > > security.properties > > > > > > > > > > > > Also, any chance you are changing any of the HTTP headers? > > > > > > > > > > > > Yaw > > > > > > -- > > > > > > Need ODK services? http://nafundi.com provides form design, server > > > > > > setup, professional support, and software development for ODK. > > > > > > > > > > > > On Tue, May 20, 2014 at 12:23 AM, wrote: > > > > > > > Dear fellows, > > > > > > > > > > > > > > With the help of ODK community I have deployed ODKAggregat 1.4.3 on tomcat with mysql. > > > > > > > > > > > > > > On first time log in, when i try to access through my superUser which is @gmail.com, it gives error mentioning OpenID auth request contains unregistered domain. > > > > > > > > > > > > > > > Please see the error page attached. Kindly guide how to proceed. > > > > > > > > > > > > > > Thanks > > > > > > > > > > > > > > -- > > > > > > > -- > > > > > > > Post: opend...@googlegroups.com > > > > > > > Unsubscribe: opendatakit...@googlegroups.com > > > > > > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > > > > > > > > > > > --- > > > > > > > You received this message because you are subscribed to the Google Groups "ODK Community" group. > > > > > > > To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com. > > > > > > > For more options, visit https://groups.google.com/d/optout. > > > > -- > > -- > > Post: opend...@googlegroups.com > > Unsubscribe: opendatakit...@googlegroups.com > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > --- > > You received this message because you are subscribed to the Google Groups "ODK Community" group. > > To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com. > > For more options, visit https://groups.google.com/d/optout. > > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com

Dear mitch,

     Thank you for providing detailed step by step description. I 

followed the guidelines. But when I try to log in with Aggregate username
(specified in jar) and password 'aggregate', it does not
accept it keep on asking the same.

Thank you

Hello mitch.

I've the exact same issue, so I followed the steps you described.
Indeed at step 11 12 the line
security.server.superUserUsername=
is empty (no superuser username) so I write one with notepad, save, compile and rename the jar.

But as soon as my new jar is in the WEB-INF/lib/ , then when i start the tomcat service, it doesnt work and I have a HTTP404 error when trying to reach my ODKAggregate website.

Attached is the log of tomcat when restarting, and it shows an error, which seems to tell that he cant find the odksettings.xml files that is supposed to be in the jar.
If i put back the .jar not modified, stop/start tomcat, it works again (but i cant login because there's no superuser username)

Any help?
Thank you very much!

catalina.2014-10-22.log (12.7 KB)

localhost.2014-10-22.log (7.36 KB)

tomcat6-stderr.2014-10-22.log (12.8 KB)

Ah, OK. It already is using the superUserUsername for the initial log-in.

Further clarification: this breaks Google sign-in functionality of all
users on all new deployments of ODK Aggregate. I.e., google e-mails cannot
be used for authenticating website visitors.

··· On Tue, May 20, 2014 at 11:14 AM, Yaw Anokwa wrote:

Mitch,

I don't think this affects the VM. As part of the VM build, I strip
out the superUserUsername and default it to aggregate, and re-bundle
the WAR. This is one of the reasons why the VM isn't meant for
production environments...

Yaw

Need ODK services? http://nafundi.com provides form design, server
setup, professional support, and software development for ODK.

On Tue, May 20, 2014 at 10:49 AM, Mitch Sundt mitchellsundt@gmail.com wrote:

I have confirmed that this is the case. This will impact the ODK
Aggregate
VM and all ODK Aggregate installs not using AppEngine.

The work-around steps are rather tedious:

(1) place the ODKAggregate.war file in the Tomcat webapps directory
(2) start Tomcat so that the war file is exploded in the directory tree.
(3) stop Tomcat
(4) move the ODKAggregate.war file out of the webapps directory for safe
keeping -- leave the ODKAggregate directory in place (we don't want
Tomcat
to ever re-explode the war).
(5) navigate into the ODKAggregate\WEB-INF\lib directory
(6) copy the ODKAggregate-settings.jar to another location
(7) rename the ODKAggregate-settings.jar to ODKAggregate-settings.zip
(8) right-click, choose "Extract all..." to explode this into a directory
tree.
(9) navigate into ODKAggregate-settings
(10) use Notepad to open the "security.properties" file (DO NOT USE
Word)
(11) find the line:
security.server.superUserUsername=
(12) add a username at the end of the line. This will be the ODK
Aggregate
username for the superuser.
(13) save the file.
(14) navigate back up to the directory containing the
ODKAggregate-settings
directory
(15) right-click on the ODKAggregate-settings directory, choose "Send
to..."
and select "Compressed (zipped) folder"
(16) rename that file to ODKAggregate-settings.jar
(17) copy that file back into the Tomcat webapps\ODKAggregate\WEB-INF\lib
directory (overwriting the original file)
(18) start Tomcat
(19) Choose to Log in using the ODK Aggregate username
(20) enter the username you gave in step 12.
(21) enter "aggregate" for the password

...and please change the password to something other than "aggregate"

Mitch

On Tue, May 20, 2014 at 7:38 AM, wvearo@gmail.com wrote:

I am seeing the same issue. I think the reason is caused by Google's
deprecation of the OpenID 2.0 API.

According to the Migration timetable
(https://developers.google.com/+/api/auth-migration#timetable). In May
2014, Google has closed registration to new clients of OpenID 2.0. As
such,

you're not able to log into any newly setup Aggregate server after May

If anyone found a workaround, please let me know. I just need a way to
log into the server with an Admin account, after that, I can set up
some ODK

users account and log in afterward with that. Thanks

Aaron

On Tuesday, May 20, 2014 9:42:37 AM UTC-4, Yaw Anokwa wrote:

Check your logs. You absolutely sure your superUser is a gmail

account? You can also open the jar at

/WEB-INF/lib/ODKAggregate-settings.jar and see what is says in

security.properties

Also, any chance you are changing any of the HTTP headers?

Yaw

--

Need ODK services? http://nafundi.com provides form design, server

setup, professional support, and software development for ODK.

On Tue, May 20, 2014 at 12:23 AM, plannerqadeer@gmail.com wrote:

Dear fellows,

With the help of ODK community I have deployed ODKAggregat 1.4.3 on
tomcat with mysql.

On first time log in, when i try to access through my superUser
which

is @gmail.com, it gives error mentioning OpenID auth request
contains

unregistered domain.

Please see the error page attached. Kindly guide how to proceed.

Thanks

--

--

Post: opendatakit@googlegroups.com

Unsubscribe: opendatakit+unsubscribe@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it,
send

an email to opendatakit+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups

"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an

email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

I had the same issue on Windows Server 2012. Marc's suggestion of using the
jar tool fixed it for me. (Requires downloading the jdk rather than just
the jre).

··· On Friday, July 4, 2014 1:26:30 AM UTC-7, marc....@gmail.com wrote: > > I just tried this on Linux and it worked. However to compress again the > files to .jar I had to follow this : > 1. Go to inside the directory where you have all extracted files > 2. jar cf ODKAggregate-settings.jar * > > PS: compress as zip and then rename to .jar seems to not work in Linux. > When you do this using this way the ODKAggreagator will not load. > > Thanks. > > On Tuesday, May 20, 2014 7:49:33 PM UTC+2, Mitch Sundt wrote: > > I have confirmed that this is the case. This will impact the ODK > Aggregate VM and all ODK Aggregate installs not using AppEngine. > > > > > > The work-around steps are rather tedious: > > > > (1) place the ODKAggregate.war file in the Tomcat webapps directory > > (2) start Tomcat so that the war file is exploded in the directory tree. > > (3) stop Tomcat > > > > (4) move the ODKAggregate.war file out of the webapps directory for safe > keeping -- leave the ODKAggregate directory in place (we don't want Tomcat > to ever re-explode the war). > > (5) navigate into the ODKAggregate\WEB-INF\lib directory > > > > (6) copy the ODKAggregate-settings.jar to another location > > (7) rename the ODKAggregate-settings.jar to ODKAggregate-settings.zip > > (8) right-click, choose "Extract all..." to explode this into a > directory tree. > > > > (9) navigate into ODKAggregate-settings > > (10) use Notepad to open the "security.properties" file (DO NOT USE > Word) > > (11) find the line: > > > > > > > > > > > > > > > > > > > > > > > > security.server.superUserUsername= > > > > (12) add a username at the end of the line. This will be the ODK > Aggregate username for the superuser. > > > > (13) save the file. > > > > (14) navigate back up to the directory containing the > ODKAggregate-settings directory > > > > > > (15) right-click on the ODKAggregate-settings directory, choose "Send > to..." and select "Compressed (zipped) folder" > > > > (16) rename that file to ODKAggregate-settings.jar > > > > > > (17) copy that file back into the Tomcat > webapps\ODKAggregate\WEB-INF\lib directory (overwriting the original file) > > > > (18) start Tomcat > > > > (19) Choose to Log in using the ODK Aggregate username > > > > > > (20) enter the username you gave in step 12. > > > > (21) enter "aggregate" for the password > > > > > > ...and please change the password to something other than "aggregate" > > > > > > > > > > Mitch > > > > > > > > > > > > > > > > > > > > > > > > > > > > On Tue, May 20, 2014 at 7:38 AM, wrote: > > > > I am seeing the same issue. I think the reason is caused by Google's > deprecation of the OpenID 2.0 API. > > > > > > > > According to the Migration timetable ( > https://developers.google.com/+/api/auth-migration#timetable). In May > 2014, Google has closed registration to new clients of OpenID 2.0. As > such, you're not able to log into any newly setup Aggregate server after > May 2014. > > > > > > > > > > If anyone found a workaround, please let me know. I just need a way to > log into the server with an Admin account, after that, I can set up some > ODK users account and log in afterward with that. Thanks > > > > > > > > Aaron > > > > > > > > > > > > > > > > On Tuesday, May 20, 2014 9:42:37 AM UTC-4, Yaw Anokwa wrote: > > > > > Check your logs. You absolutely sure your superUser is a gmail > > > > > > > > > > account? You can also open the jar at > > > > > > > > > > /WEB-INF/lib/ODKAggregate-settings.jar and see what is says in > > > > > > > > > > security.properties > > > > > > > > > > > > > > > > > > > > Also, any chance you are changing any of the HTTP headers? > > > > > > > > > > > > > > > > > > > > Yaw > > > > > > > > > > -- > > > > > > > > > > Need ODK services? http://nafundi.com provides form design, server > > > > > > > > > > setup, professional support, and software development for ODK. > > > > > > > > > > > > > > > > > > > > On Tue, May 20, 2014 at 12:23 AM, wrote: > > > > > > > > > > > Dear fellows, > > > > > > > > > > > > > > > > > > > > > > With the help of ODK community I have deployed ODKAggregat 1.4.3 on > tomcat with mysql. > > > > > > > > > > > > > > > > > > > > > > On first time log in, when i try to access through my superUser > which is @gmail.com, it gives error mentioning OpenID auth request > contains unregistered domain. > > > > > > > > > > > > > > > > > > > > > > > > Please see the error page attached. Kindly guide how to proceed. > > > > > > > > > > > > > > > > > > > > > > Thanks > > > > > > > > > > > > > > > > > > > > > > -- > > > > > > > > > > > -- > > > > > > > > > > > Post: opend...@googlegroups.com > > > > > > > > > > > Unsubscribe: opendatakit...@googlegroups.com > > > > > > > > > > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > > > > > > > > > > > > > > > > > > > --- > > > > > > > > > > > You received this message because you are subscribed to the Google > Groups "ODK Community" group. > > > > > > > > > > > To unsubscribe from this group and stop receiving emails from it, > send an email to opendatakit...@googlegroups.com. > > > > > > > > > > > For more options, visit https://groups.google.com/d/optout. > > > > > > > > -- > > > > -- > > > > Post: opend...@googlegroups.com > > > > Unsubscribe: opendatakit...@googlegroups.com > > > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > > > > > --- > > > > You received this message because you are subscribed to the Google > Groups "ODK Community" group. > > > > To unsubscribe from this group and stop receiving emails from it, send > an email to opendatakit...@googlegroups.com. > > > > For more options, visit https://groups.google.com/d/optout. > > > > > > > > > > -- > > Mitch Sundt > > Software Engineer > > University of Washington > > mitche...@gmail.com >

Just to double-check -- are you using the 1.4.4 installer? (available on
our downloads page).

Re-run the 1.4.4 installer, specify a new username (just simple
alphanumeric characters -- no accents or non-latin characters), and
re-deploy.

By specifying a different username, it will set that new username to have a
password of 'aggregate'.

Once you log in, you can then delete the earlier username, or reset its
password.

··· On Sun, Sep 14, 2014 at 10:48 PM, wrote:

Dear mitch,

     Thank you for providing detailed step by step description. I

followed the guidelines. But when I try to log in with Aggregate username
(specified in jar) and password 'aggregate', it does not
accept it keep on asking the same.

Thank you

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Download the new ODK Aggregate 1.4.4 installer

This now prompts for a username, so you don't need to go through the manual
steps.

http://code.google.com/p/opendatakit/wiki/AggregateReleaseNotes

··· On Wed, Oct 22, 2014 at 10:41 AM, wrote:

Hello mitch.

I've the exact same issue, so I followed the steps you described.
Indeed at step 11 12 the line
security.server.superUserUsername=
is empty (no superuser username) so I write one with notepad, save,
compile and rename the jar.

But as soon as my new jar is in the WEB-INF/lib/ , then when i start the
tomcat service, it doesnt work and I have a HTTP404 error when trying to
reach my ODKAggregate website.

Attached is the log of tomcat when restarting, and it shows an error,
which seems to tell that he cant find the odksettings.xml files that is
supposed to be in the jar.
If i put back the .jar not modified, stop/start tomcat, it works again
(but i cant login because there's no superuser username)

Any help?
Thank you very much!

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Dear Mitch,

Thank you for providing detailed step by step description. I followed the guidelines. But when I try to log in with Aggregate username (specified in jar) and password 'aggregate', it does not accept it keep on asking the same.

Kindly help.

··· On Tuesday, May 20, 2014 11:54:14 PM UTC+5, Mitch Sundt wrote: > Ah, OK. It already is using the superUserUsername for the initial log-in. > > Further clarification: this breaks Google sign-in functionality of all users on all new deployments of ODK Aggregate. I.e., google e-mails cannot be used for authenticating website visitors. > > > > > > > On Tue, May 20, 2014 at 11:14 AM, Yaw Anokwa wrote: > > Mitch, > > > > I don't think this affects the VM. As part of the VM build, I strip > > out the superUserUsername and default it to aggregate, and re-bundle > > the WAR. This is one of the reasons why the VM isn't meant for > > production environments... > > > > > Yaw > > -- > > Need ODK services? http://nafundi.com provides form design, server > > setup, professional support, and software development for ODK. > > > > > > On Tue, May 20, 2014 at 10:49 AM, Mitch Sundt wrote: > > > I have confirmed that this is the case. This will impact the ODK Aggregate > > > VM and all ODK Aggregate installs not using AppEngine. > > > > > > The work-around steps are rather tedious: > > > > > > (1) place the ODKAggregate.war file in the Tomcat webapps directory > > > (2) start Tomcat so that the war file is exploded in the directory tree. > > > (3) stop Tomcat > > > (4) move the ODKAggregate.war file out of the webapps directory for safe > > > keeping -- leave the ODKAggregate directory in place (we don't want Tomcat > > > to ever re-explode the war). > > > (5) navigate into the ODKAggregate\WEB-INF\lib directory > > > (6) copy the ODKAggregate-settings.jar to another location > > > (7) rename the ODKAggregate-settings.jar to ODKAggregate-settings.zip > > > (8) right-click, choose "Extract all..." to explode this into a directory > > > tree. > > > (9) navigate into ODKAggregate-settings > > > (10) use Notepad to open the "security.properties" file (DO NOT USE Word) > > > (11) find the line: > > > security.server.superUserUsername= > > > (12) add a username at the end of the line. This will be the ODK Aggregate > > > username for the superuser. > > > (13) save the file. > > > (14) navigate back up to the directory containing the ODKAggregate-settings > > > directory > > > (15) right-click on the ODKAggregate-settings directory, choose "Send to..." > > > and select "Compressed (zipped) folder" > > > (16) rename that file to ODKAggregate-settings.jar > > > (17) copy that file back into the Tomcat webapps\ODKAggregate\WEB-INF\lib > > > directory (overwriting the original file) > > > (18) start Tomcat > > > (19) Choose to Log in using the ODK Aggregate username > > > (20) enter the username you gave in step 12. > > > (21) enter "aggregate" for the password > > > > > > ...and please change the password to something other than "aggregate" > > > > > > Mitch > > > > > > > > > > > > On Tue, May 20, 2014 at 7:38 AM, wrote: > > >> > > >> I am seeing the same issue. I think the reason is caused by Google's > > >> deprecation of the OpenID 2.0 API. > > >> > > >> According to the Migration timetable > > >> (https://developers.google.com/+/api/auth-migration#timetable). In May > > >> 2014, Google has closed registration to new clients of OpenID 2.0. As such, > > >> you're not able to log into any newly setup Aggregate server after May 2014. > > >> > > >> If anyone found a workaround, please let me know. I just need a way to > > >> log into the server with an Admin account, after that, I can set up some ODK > > >> users account and log in afterward with that. Thanks > > >> > > >> Aaron > > >> > > >> > > >> On Tuesday, May 20, 2014 9:42:37 AM UTC-4, Yaw Anokwa wrote: > > >> > Check your logs. You absolutely sure your superUser is a gmail > > >> > > > >> > account? You can also open the jar at > > >> > > > >> > /WEB-INF/lib/ODKAggregate-settings.jar and see what is says in > > >> > > > >> > security.properties > > >> > > > >> > > > >> > > > >> > Also, any chance you are changing any of the HTTP headers? > > >> > > > >> > > > >> > > > >> > Yaw > > >> > > > >> > -- > > >> > > > >> > Need ODK services? http://nafundi.com provides form design, server > > >> > > > >> > setup, professional support, and software development for ODK. > > >> > > > >> > > > >> > > > >> > On Tue, May 20, 2014 at 12:23 AM, wrote: > > >> > > > >> > > Dear fellows, > > >> > > > >> > > > > >> > > > >> > > With the help of ODK community I have deployed ODKAggregat 1.4.3 on > > >> > > tomcat with mysql. > > >> > > > >> > > > > >> > > > >> > > On first time log in, when i try to access through my superUser which > > >> > > is @gmail.com, it gives error mentioning OpenID auth request contains > > >> > > unregistered domain. > > >> > > > >> > > > > >> > > > >> > > Please see the error page attached. Kindly guide how to proceed. > > >> > > > >> > > > > >> > > > >> > > Thanks > > >> > > > >> > > > > >> > > > >> > > -- > > >> > > > >> > > -- > > >> > > > >> > > Post: opend...@googlegroups.com > > >> > > > >> > > Unsubscribe: opendatakit...@googlegroups.com > > >> > > > >> > > Options: http://groups.google.com/group/opendatakit?hl=en > > >> > > > >> > > > > >> > > > >> > > --- > > >> > > > >> > > You received this message because you are subscribed to the Google > > >> > > Groups "ODK Community" group. > > >> > > > >> > > To unsubscribe from this group and stop receiving emails from it, send > > >> > > an email to opendatakit...@googlegroups.com. > > >> > > > >> > > For more options, visit https://groups.google.com/d/optout. > > >> > > >> -- > > >> -- > > >> Post: opend...@googlegroups.com > > >> Unsubscribe: opendatakit...@googlegroups.com > > >> Options: http://groups.google.com/group/opendatakit?hl=en > > >> > > >> --- > > >> You received this message because you are subscribed to the Google Groups > > >> "ODK Community" group. > > >> To unsubscribe from this group and stop receiving emails from it, send an > > >> email to opendatakit...@googlegroups.com. > > >> For more options, visit https://groups.google.com/d/optout. > > > > > > > > > > > > > > > -- > > > Mitch Sundt > > > Software Engineer > > > University of Washington > > > mitche...@gmail.com > > > > > > -- > > > -- > > > Post: opend...@googlegroups.com > > > Unsubscribe: opendatakit...@googlegroups.com > > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > > > --- > > > You received this message because you are subscribed to the Google Groups > > > "ODK Community" group. > > > To unsubscribe from this group and stop receiving emails from it, send an > > > email to opendatakit...@googlegroups.com. > > > For more options, visit https://groups.google.com/d/optout. > > > > -- > > -- > > Post: opend...@googlegroups.com > > Unsubscribe: opendatakit...@googlegroups.com > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > --- > > You received this message because you are subscribed to the Google Groups "ODK Community" group. > > To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com. > > For more options, visit https://groups.google.com/d/optout. > > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com

Dear mitch,

    I reinstall the installer 1.4.4 but same error occurred. So what 

can i do next.

    Sincerely 
          Arun Bam

Ok thanks, worked out perfectly.
I could log in with my superuser.

But since I launched the new .war, I can only connect my ODKAggregate
website via Internet explorer or google chrome, but it doesn't work with
mozilla firefox anymore, where it loops at loading the page.
Am I the only one with compatibility issues?
I'm using Apache Tomcat/6.0.41 ; JVM version 1.7.0_67-b01 on Windows Server
2008 R2

··· 2014-10-22 19:05 GMT+00:00 Mitch Sundt :

Download the new ODK Aggregate 1.4.4 installer

https://opendatakit.org/downloads/download-category/aggregate/

This now prompts for a username, so you don't need to go through the
manual steps.

http://code.google.com/p/opendatakit/wiki/AggregateReleaseNotes

On Wed, Oct 22, 2014 at 10:41 AM, yannick.vesters@gmail.com wrote:

Hello mitch.

I've the exact same issue, so I followed the steps you described.
Indeed at step 11 12 the line
security.server.superUserUsername=
is empty (no superuser username) so I write one with notepad, save,
compile and rename the jar.

But as soon as my new jar is in the WEB-INF/lib/ , then when i start the
tomcat service, it doesnt work and I have a HTTP404 error when trying to
reach my ODKAggregate website.

Attached is the log of tomcat when restarting, and it shows an error,
which seems to tell that he cant find the odksettings.xml files that is
supposed to be in the jar.
If i put back the .jar not modified, stop/start tomcat, it works again
(but i cant login because there's no superuser username)

Any help?
Thank you very much!

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/WzaM8F6yDZQ/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hello Mitch,

First of all thanks for your support, it's very helpfull. I also follow all the steps above and I get a 404 error too. I'm using the 1.3.4 installer because the last one doesn't works in my tomcat (We used 1.3.1 for the rest of the instances and the 1.3.4 is the one that works). ¿Do you know if these instructions doesn't work in previous versions?

I also tried to export/import _registered_users table from a working instance to this new one, but doesn't work, I imagine the login system is more complex than just that :wink:

I will apreciate any information you can give me about this.

Best regards,

Fernando

You clicked the "Sign in with Aggregate password" button?

Send me the ODKAggregate-settings.jar and I will verify that the change was
correct.

··· On Tue, May 20, 2014 at 11:58 AM, wrote:

Dear Mitch,

Thank you for providing detailed step by step description. I followed the
guidelines. But when I try to log in with Aggregate username (specified in
jar) and password 'aggregate', it does not accept it keep on asking the
same.

Kindly help.

On Tuesday, May 20, 2014 11:54:14 PM UTC+5, Mitch Sundt wrote:

Ah, OK. It already is using the superUserUsername for the initial log-in.

Further clarification: this breaks Google sign-in functionality of all
users on all new deployments of ODK Aggregate. I.e., google e-mails cannot
be used for authenticating website visitors.

On Tue, May 20, 2014 at 11:14 AM, Yaw Anokwa yan...@nafundi.com wrote:

Mitch,

I don't think this affects the VM. As part of the VM build, I strip

out the superUserUsername and default it to aggregate, and re-bundle

the WAR. This is one of the reasons why the VM isn't meant for

production environments...

Yaw

--

Need ODK services? http://nafundi.com provides form design, server

setup, professional support, and software development for ODK.

On Tue, May 20, 2014 at 10:49 AM, Mitch Sundt mitche...@gmail.com wrote:

I have confirmed that this is the case. This will impact the ODK
Aggregate

VM and all ODK Aggregate installs not using AppEngine.

The work-around steps are rather tedious:

(1) place the ODKAggregate.war file in the Tomcat webapps directory

(2) start Tomcat so that the war file is exploded in the directory
tree.

(3) stop Tomcat

(4) move the ODKAggregate.war file out of the webapps directory for
safe

keeping -- leave the ODKAggregate directory in place (we don't want
Tomcat

to ever re-explode the war).

(5) navigate into the ODKAggregate\WEB-INF\lib directory

(6) copy the ODKAggregate-settings.jar to another location

(7) rename the ODKAggregate-settings.jar to ODKAggregate-settings.zip

(8) right-click, choose "Extract all..." to explode this into a
directory

tree.

(9) navigate into ODKAggregate-settings

(10) use Notepad to open the "security.properties" file (DO NOT USE
Word)

(11) find the line:

security.server.superUserUsername=

(12) add a username at the end of the line. This will be the ODK
Aggregate

username for the superuser.

(13) save the file.

(14) navigate back up to the directory containing the
ODKAggregate-settings

directory

(15) right-click on the ODKAggregate-settings directory, choose "Send
to..."

and select "Compressed (zipped) folder"

(16) rename that file to ODKAggregate-settings.jar

(17) copy that file back into the Tomcat
webapps\ODKAggregate\WEB-INF\lib

directory (overwriting the original file)

(18) start Tomcat

(19) Choose to Log in using the ODK Aggregate username

(20) enter the username you gave in step 12.

(21) enter "aggregate" for the password

...and please change the password to something other than "aggregate"

Mitch

On Tue, May 20, 2014 at 7:38 AM, wve...@gmail.com wrote:

I am seeing the same issue. I think the reason is caused by Google's

deprecation of the OpenID 2.0 API.

According to the Migration timetable

(https://developers.google.com/+/api/auth-migration#timetable). In
May

2014, Google has closed registration to new clients of OpenID 2.0.
As such,

you're not able to log into any newly setup Aggregate server after
May 2014.

If anyone found a workaround, please let me know. I just need a way
to

log into the server with an Admin account, after that, I can set up
some ODK

users account and log in afterward with that. Thanks

Aaron

On Tuesday, May 20, 2014 9:42:37 AM UTC-4, Yaw Anokwa wrote:

Check your logs. You absolutely sure your superUser is a gmail

account? You can also open the jar at

/WEB-INF/lib/ODKAggregate-settings.jar and see what is says in

security.properties

Also, any chance you are changing any of the HTTP headers?

Yaw

--

Need ODK services? http://nafundi.com provides form design, server

setup, professional support, and software development for ODK.

On Tue, May 20, 2014 at 12:23 AM, planne...@gmail.com wrote:

Dear fellows,

With the help of ODK community I have deployed ODKAggregat 1.4.3
on

tomcat with mysql.

On first time log in, when i try to access through my superUser
which

is @gmail.com, it gives error mentioning OpenID auth request
contains

unregistered domain.

Please see the error page attached. Kindly guide how to proceed.

Thanks

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google

Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it,
send

an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups

"ODK Community" group.

To unsubscribe from this group and stop receiving emails from it,
send an

email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

Mitch Sundt

Software Engineer

University of Washington

mitche...@gmail.com

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups

"ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an

email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Arun,

Strange.

Re-download the 1.4.4 installer from the website. It's possible that
you have a slightly older version that might have a bug.

If you are on App Engine, try creating a new app id, and installing
1.4.4 there. Make sure the installer puts its files in a new location
(e.g., not in the same folder as the 1.4.3 files), and as Mitch
stated, pick a simple alphanumeric characters -- no accents or
non-latin characters.

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Tue, Sep 16, 2014 at 2:25 AM, arun.b@ptas.com.np wrote:

Dear mitch,

    I reinstall the installer 1.4.4 but same error occurred. So what can

i do next.

    Sincerely
          Arun Bam

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Open a Firefox Private Window, and see if you can log in. That should work.

Since you have changed the password or reset it, you must close and quit
firefox ENTIRELY before you'll be able to log in with the normal window.

Mitch

··· On Thu, Oct 23, 2014 at 8:09 AM, Yannick Vesters wrote:

Ok thanks, worked out perfectly.
I could log in with my superuser.

But since I launched the new .war, I can only connect my ODKAggregate
website via Internet explorer or google chrome, but it doesn't work with
mozilla firefox anymore, where it loops at loading the page.
Am I the only one with compatibility issues?
I'm using Apache Tomcat/6.0.41 ; JVM version 1.7.0_67-b01 on Windows
Server 2008 R2

2014-10-22 19:05 GMT+00:00 Mitch Sundt mitchellsundt@gmail.com:

Download the new ODK Aggregate 1.4.4 installer

https://opendatakit.org/downloads/download-category/aggregate/

This now prompts for a username, so you don't need to go through the
manual steps.

http://code.google.com/p/opendatakit/wiki/AggregateReleaseNotes

On Wed, Oct 22, 2014 at 10:41 AM, yannick.vesters@gmail.com wrote:

Hello mitch.

I've the exact same issue, so I followed the steps you described.
Indeed at step 11 12 the line
security.server.superUserUsername=
is empty (no superuser username) so I write one with notepad, save,
compile and rename the jar.

But as soon as my new jar is in the WEB-INF/lib/ , then when i start the
tomcat service, it doesnt work and I have a HTTP404 error when trying to
reach my ODKAggregate website.

Attached is the log of tomcat when restarting, and it shows an error,
which seems to tell that he cant find the odksettings.xml files that is
supposed to be in the jar.
If i put back the .jar not modified, stop/start tomcat, it works again
(but i cant login because there's no superuser username)

Any help?
Thank you very much!

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/WzaM8F6yDZQ/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com