Form Definition Error

I have an issue with a particular form in my aggregate server ,the form keeps displaying error: Form definition incomplete or missing,note the form has data and I dont want to lose this data by deleting and re-uploading the form.
I need a work around, I have tried using the backup of the sql file by creating another instance of aggregate stil same issue.

Please kindly advise way forward.


Please if anyone has solution to the subject issue,kindly share I need this urgently,thanks

Have you searched this forum for that error message and tried those solutions? If so, what happened when you tried those solutions?

Those solution were not similar to my issue at all, mine is a working form
that accepts submission before now,but suddenly stops, note the form has
data, am afraid if i delete the form and I upload a new form I would lose
all the data already in the form, just need a guidance if its possible to
upload a new form and populate it with data from the backend database
mysql, thats the soultion I am thinking now.


Dear Jamorv,

I would really like to know what you did for the similar problem, all of a sudden i am in the same boat now, form was working just fine and was accepting submissions, but now it is unchecked for Download and Accept submissions in the aggregate, and for some reason whenever I try to check it, it says "Form definition incomplete or missing".

Any work around would be highly appreciated. I don't want to re-upload the form and then import all the data back.

Thank you,

What version of ODK Aggregate are you using? Are you running on App Engine or on a Tomcat server? Have you read through your logs to see if there are hints as to what is going wrong?

Sorry am yet to solve the problem but if u can re-run ur aggregate with the
same database it may solve it.


I solved it, the survey tables had crashed (don't know why that happened), generating lots of 400 errors in the Tomcat, which ultimately caused GC out of memory errors and ultimately the whole server went almost unresponsive.

After table repairs, luckily everything was working and back to normal.

Thanks !


1 Like

If you have a form definition error in your ODK or probably you want to uninstall mysql without losing all the databases you currently have in mysql,kindly go to C drive look for program data ,its an hidden folder unhide folder in your c drive, then look for the program data folder, click it and look for MYSQL folder,clikck mysql folder and you would find data folder, copy the whole data folder out and back up in a another drive, if you open it , you would see all your database files, this is where they are saved in windows OS.

Uninstall MYSQL, restart the system,Rerun mysql and follow the same direction as above and copy back the data folder you backed up from C - Mysql -data folder, you would see the new installation data folder,kindly rename and copy back your backed up data folder.

Rerun Tomcat , Place back your ODK config back to the webapps folder, and you should be fine .