Form Validation

Good day all,

My form is showing the following message after validation,

Xform parsing completed! See above for any warnings.
Xform is valid! See above for any warnings.

But its failing to load.

msg when loading to Aggregate

Error: Problem with JavaRosa Parsing Form: org.opendatakit.aggregate.exception.ODKIncompleteSubmissionData: Javarosa failed to construct a FormDef. Is this an XForm definition?

It's difficult to tell you what's wrong without the form. Could you attach it?

are you able to help, am just stuck with loading

Hi Tebo,

Which validating tool are you using? I have tried using validating your form and it works.

Tool used:

Exactly the same version as shown above. It validates but does not load in aggregate

Are you replace an existing form or you are uploading for the first time?

I have tried my side and it works.
HH.xml (205.0 KB)

@tebok What version of Aggregate are you using? Does it work on

1 Like

The form uploaded after I logged off and logged in back to the server. I can't really say what was wrong.

This one now comes when I try to upload the Itemsets.csv how do i tackle it

Error: Problem with JavaRosa Parsing Form: org.opendatakit.aggregate.exception.ODKIncompleteSubmissionData: java.lang.RuntimeException: Document has no root element!

Are you sure you are uploading the csv the right way? it should be added as media file.

You did not answer my previous questions.

Yes i was replacing an existing form .

I uploaded via Optional Media Files and it is sending me that error.
The xml uploaded successfully

Why are you replacing? Have you tried uploading the form and the attachment in the link provided by Yaw? What are you getting? Can you provide a screenshot?

This is the message I get in Yaw's server

Oky, there is something that you are not doing the right way, if possible, makeup a csv similar to what you have then share it here.

Also checkout this Uploading csv support file, getting error "Document has no root element"

external_file.xlsx (12.3 KB)
this is just a snapshot of a thousand rows I have created.

I have been through that link many times...still can't figure out the error

Why is it does it have .xlsx extension? It should be a csv file

itemsets (17).csv (3.0 KB)
oh Ok this is it

Oky, i think you are not uploading the xml file, you are uploading xlsx instead.
I got the error after uploading the .xlsx file you shared instead of the xml.

Can you try this file HH.xml (205.0 KB)
With the csv you shared in the link above.

Loaded Pls explain why my main csv is failing

Hi @tebok,

That I cant tell maybe if you are willing to share the complete form with its attachment.

Hi Tebo,

Have you tried the attached files in the link provided? I have tested by uploading the shared files and it works, no errors produced.