Geoshape not allowing manual location recording

Z<!--- Answer the five questions below to get support --->

**1. I am not able to use the Google source, satellite map style (under Geoshape) on Partner mobile e15 model. Android ™ 8.1 (go edition).

**2. Odk collect v1.27.1 / server: the Google satellite manual location recording is mandatory for as an enumirator at the national agricultural surveys in Nigeria organized by Federal ministry of agriculture and rural development.
**3. I have uninstalled and reinstalled the app but the issue still remain the same.

**4. Help me check if the device I'm using is compactable with the odk collect app.

**5. My phone is newly acquired.

Thank you for your detailed description with screenshot.

One possibility I can think of is that your device may not have a recent version of Google Play Services installed. That seems strange but it could be possible. Could you please try the troubleshooting steps at and see if that helps?

Alternately, the OpenStreetMaps or Mapbox basemaps use slightly different ways to get location and those might work better for you. You can try that by tapping on the three dots on the main screen, tapping General Settings, tapping Maps and then selecting an option other than Google as the source.

Please let us know what you find out so that we can see if there’s a problem we can fix or something we can better document.

Dear Hélène,

All effort proved abortive and at this point, I really don't know what next to do.

The mapbox is working well but we are not allowed to use that. They mandated us to use Google map, with satellite as map style. I hope you get the explanation well?

I'm sorry you're still having trouble with this, @Xola. To be clear, you have verified that Play Services is running and up to date, is that right?

Have you tried waiting a little bit before tapping the add button? Collect does need to confirm that it can get your location before it lets you select one of the options that require location information. At the top of the map, you'll see a status bar that says "Searching for GPS location, please wait." How long did you wait to see whether you could get location lock? Did you try doing this outdoors with a clear view of the sky? Can the Google Maps app get your location?

There could also be something wrong with your Android location settings. You can try some of the steps at

Thanks, I was able to resolve mine with the steps giving above. All I did was wait for the GPS to complete it searching, after which it got a lock on my location and I was able to switch to the "Manual location recording". Oh, I had to go outside the building I was to get the GPS lock.


1 Like

That's great, thanks for sharing your experience, @Jidestroud! I hope you've gotten it to work as well, @Xola. Please do update us.

@LN Thank you so much for your unwaivering support. The issue has been succefully resolved. I went outdoors and it worked instantly. @Jidestroud Thanks a lot bro. Now I'm ready for the task ahead.