Getting stuck at "Redirecting to forms page"

What is the problem? Please be detailed.
Hi everyone,

I hope I have gone thoroughly through all the topics and that i'm not reposting an old post.

I have been able to install ODK Aggregate, but when I type "http://localhost:8080/ODKAggregate/" in the browser I get stuck at the page "Redirecting to forms page". See below.
I am not an expert, but I would like to think that my tomcat server is not interpreting the java code in the index.html.
I have downloaded "Firefox ESR" and am able to browse the internet with it, but wouldn't know how to get Java to work on it. In the regular Firefox version java is reported to be working properly (Although it seems that support for java on this regular version has been terminated?)

What ODK tool and version are you using? And on what device and operating system version?
ODK version = i cant seem to get the info from the file, but i recently downloaded (march 2018) it from the website.
Fedora 27
Firefox Version 59.0.2 (64-bit)
Firefor ESR
Java version 9

What steps can we take to reproduce the problem?
I honestly wouldnt know how to answers this question, because I just followed the regular install steps, everything seems to have gone ok.

What you have you tried to fix the problem?
After I read about the suspended support for java, i downloaded installed the Firefox ESR. Internet Explorer would also be a Browser option it seems, but i'm running Fedora so I cant use that option.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
Please take into account:
I recently started to use Linux and
I'm actually not sure if this is indeed a Javascript problem
I'm totally new to ODK, came across it last March while searching for digital data collection options

see below how the index.html appears in the browser

Hi @Rudeness. Thank you for a polite post :smile:

I can't find anything obviously wrong with your install. Here's what I'd try...

  1. If http://locahost:8080 shows you the Tomcat page, then it isn't Java problem.
  2. Try Chrome and see if that works better. If it doesn't work, then it's not a Javascript issue.
  3. Check your Tomcat logs and see if there is anything strange there.

Hello Yanokwa,

I appreciate your reply. I have tried it with Chrome and obtained a screen displaying the text below.
I will look into your suggestion, to check the Tomcat logs (dont know how to yet, but will google and see how to).

If you have some feedback on the below text it will be very much appreciated.


HTTP Status 404 - /ODKAggregate/Aggregate.html
type Status report

message /ODKAggregate/Aggregate.html

description The requested resource is not available.

Apache Tomcat/8.0.50