Handshake Error When Uploading Filled Form

1. What is the issue? Please be detailed.
I am no longer able to upload filled forms from the odk app on my tablets to the ona server. When I try to upload a form, I am get this error:

Error: Handshake failed.

2. What steps can we take to reproduce this issue?
Select a form in the "Ready to send" folder in the odk app on a tablet and click on "Send selected"

3. What have you tried to fix the issue?
I have updated the odk app on my tablets. I have also checked that the setting information of the odk app was not tempered with. But I am still getting the same errors.

4. Upload any forms or screenshots you can share publicly below.

Since you are using Ona, your best bet is to ask Ona at https://help.ona.io.

My guess is that either the Ona service is having problems, or you are using a very old version of Android, or your device time is incorrect.

Thank you, Yanokwa. I have tried uploading the forms from other devices, but they are still not uploading. I will reach out Ona. Thank you for your help.