Help! Unable to view/reach Aggregate

What is the problem? Please be detailed.

Had a call from my field team informing me that an error was stopping them from submitting forms.
The error received on each submission attempt was:

Error: Not Found (404) at

Tried logging in to and received the following error on the page:

[ Home - Page of API's (V1.1.14) ]

Tried logging in to and received the following error on the page:

Cannot GET /Aggregate.html

What ODK tool and version are you using? And on what device and operating system version?

I'm unable to trace my exact version of Aggregate now, but from memory, it is v1.4.13, deployed early April 2017. I've had no issues with it since it was deployed.

The Aggregate server was deployed on Google App Engine, in a paid billing account on Google Cloud Platform. The service has been active+charged monthly for the last year, and it is not a payment issue.

What steps can we take to reproduce the problem?

I'm really not sure how to reproduce the problem, or what the problem actually is.

What you have you tried to fix the problem?

I'm not sure why this occurred in the first place, and have no idea where to begin to find + fix the issue - - -

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Any help regarding this issue and how to fix it would be extremely helpful. We have active projects in the field that are dependent on this ODK deployment, and data on the Aggregate server that has not been downloaded yet!

Hi @Vanubhav, the error message of Home - Page of API's you are showing doesn't really make sense. Can you upload a screenshot?

Hello, I've attached 2 screenshots, with the error messages based on the URLs

Hi, @Vanubhav!

It's looking like Aggregate is no longer being deployed at that Google Cloud project. Since you were running an older version of Aggregate, I'm wondering if this could have anything to do with AppEngine removing support for Java7 apps. Newer Aggregate releases use Java8, which is the current standard for that platform.


I wondered about

that too. I've temporarily white listed the app for Java 7. But it has not turned up yet.

I'm spitballing here, but you you're weary of upgrading to a more recent version, you could try to reinstall the same version you're running.

I'm not weary of upgrading the version, but I'm not sure if it will affect the data already on the server. Reinstalling the same ODK version is an option too, but I'm hesitant as I'm worried about the data.


Installing Aggregate won't affect data, but common sense rules apply: backup your data, pull all your forms using Briefcase, etc.

The safest install you can do right now is to install the same version you were running, but maybe we can play out other less invasive options:

Thank you for these suggestions! I'm going to go over the list and get back to you, but I really do appreciate the help!

1 Like

I have two default versions, one which was started on the day we originally launched the server (back in 2017), and another on the day we could no longer reach Aggregate.

The old version has no traffic allocated. Wondering if this could be a possible issue. Have attached a screenshot.

Based on the previous issue of having two instances, I Split Traffic back to the original version. I think the other JS8 instance was auto generated by GCP/GAE as a default upgrade.

After the switch, I'm able to see the ODK Aggregate server, and login. My POA is to download everything I can immediately to a local drive, and update Aggregate to the next highest version.

Thank you @yanokwa, and especially @ggalmazor for your insights.

The next challenge is to upgrade my ODK Aggregate (now at v1.7.1) to work on Java8