How can I download ODK aggregate VM to set my ODK server?

1. What is the problem? Be very detailed.

Issue to download ODK aggregate VM to set a server

2. What app or server are you using and on what device and operating system? Include version numbers.
I don't have any server. I'm using my computer SAMSUNG NC10 with WINDOWS 8
3. What you have you tried to fix the problem?
I installed "VirtualBox-5.2.30-130521-Win" and I'm not seeing ODK aggregate VM to download.
4. What steps can we take to reproduce the problem?
Help me to get ODK aggregate VM or propose else simple way to set ODK sever
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

After you setup virtualbox, you need to install an OS first, Both Windows or Linux are ok. Then you can try to use any WAMP or LAMP software to setup an tonmcat server. For Windows, I recommend you use XAMPP, Upgrade the tomcat server to 8.X and then install ODK aggreagte.

@Scsaintey You can find the instructions for the VM at The second step of the instructions links to the location of the download (

Thank you so much dear @yanokwa.
I tried this instruction "" when Idownloaded "".

but while installing, I don't see the OVA file. It also asks "tomcat server" which I don't have. Or should I download ""? I didn't try this because I using windows.
It maybe also easy I can get a video explanning the thing.

Thank you Dear @ewezer.
Please what is OS first? some links will be very helpful for OS first and for "WAMP or LAMP software to setup an tonmcat server" .

Dear @yanokwa, should I try ""?
I'm using windows8

Yes, download the and unzip it.

ok I'm going to try it and after I'll tell the result
thank you so much

Dear @yanokwa I did it. But i'm blocked at this level. I think it's because I have a 32 bits.

How am I oing to proceed now?
Please help me

@Scsaintey I just looked up your computer and it's pretty old (more than 10 years), so I don't think the VM will work. You could try a local Tomcat install (, but I can't guarantee that'll work either.

Do you have a newer computer with a 64-bit processor you can try?

Thank you so much dear @yanokwa.
You are right! But Unfortunately, I don't have any else new computer. I'm going to try your last suggestion and after I'll tell you the result.


Hello Dear @yanokwa!
I borrowed someone elese computer and did it. but while login, it doesn't allow me to hit the password and after it displays "login incorrect"


1 Like

Please take the time to read the docs at In particular, describes how to log into the VM to secure it.