Increasing aggregate field length

Hi community. i have a problem while uploading a form. i want to increse the database field
IncreaseSize.xlsx (10.3 KB)

i get this error

Your form looks OK, passes XLSForm Online validation check, and I was able to load the resulting XML form definition into my ODK Aggregate instance with any error. Perhaps you are using an especially old version of Aggregate?

yes now i can upload without error. i want to know, is that supposed to increase the size in mysql field ?


varchar(255) : doesn't change.

thanks for your help has the documentation on this. If you aren't seeing a change in the database size, my guess is that the change only happens with new forms, not updated forms.

As an aside, it looks like you are using utf8_general_ci. Your MySQL DB should probably use utf8_unicode_ci because utf8_general_ci sorting is broken.

1 Like

can you give me a solution, i want to increase the size so that i can collect more than 255 caracter. with geoshape or videos. my mysql creates utf8_general_ci by default i tried to change but no changes


Its working. Vielen Dank

So others can benefit from your experience, can you share what you did to get things working?

I ve just followed your instruction .the first problem i had was about to convert the form, so i used online converter (XLSForm Online )
the second was that my mysql database had (utf8_general_ci) so i changed it to (utf8_unicode_ci). then it worked

1 Like