Initial login fails

1. What is the problem? Be very detailed.
Site is correct, https is confirmed and everything else seems to be working but when I type in my super-user name and use the default password (aggregate) for the first initial log-in it fails and will not enter.

2. What app or server are you using and on what device and operating system? Include version numbers.
AWS with the latest version of ODK (2)

3. What you have you tried to fix the problem?
re-installing ODK collect on my computer, changing the username to something more simple.

4. What steps can we take to reproduce the problem?

Advice on how to solve the issue with the initial login.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Welcome to the ODK forum, @Fuller! We're glad you're here. When you get a chance, please introduce yourself here. I'd also encourage you to add a real picture as your avatar because it helps build community!

We've very recently updated the AWS installation guide and solved some issues with the login process. Could you confirm that you've installed Aggregate v2.0.2 following the current guide at, please?

Also, could you describe how it fails when you try to log in? Does it reject the password? Does it timeout? Any other effects?

Hi @ggalmazor, thanks for your reply.

I can confirm that I am running Aggregate v2.02 and followed the guide you specified during setup.

When I attempt to login, the login box returns blank and if I click "cancel" it returns this message:

HTTP Status 401 – Unauthorized
Type Status Report

Message Username braden.fuller not found

Description The request has not been applied because it lacks valid authentication credentials for the target resource.

Apache Tomcat/8.5.30 (Ubuntu)

Thank you for any help!

Braden Fuller

@Fuller Are you absolutely sure you are using the latest instructions (e.g., create VPC, create security group, create IAM role) at

I ask because the current instructions don't let you specify a super-username. They install with default username/password (administrator/aggregate). Have you tried those credentials?