Intermittent problems with completed forms (marked as finalized) appearing in "Edit Saved Form" but not "Send Finalized Form"

Hi,

I am having intermittent problems with completed forms (marked as
finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I
can't reproduce this exactly with this minimal example
https://docs.google.com/spreadsheets/d/1QOhHE_6UKvdHbq1meDxIPbYUjW1mVmUrPkbx9lvQ86c/edit?usp=sharing,
but I think the following steps show the problem.

I choose to fill a blank form make selections some selections:

  • 1 for enumerator ID
  • 1002 for HHID
  • check the name that appears

Before ending, hit the return arrow and choose to save the changes. Then go
into Edit Saved Forms and go to the first question. Enumerator ID appears,
but the next question with the button for caregiver name is no longer
checked.

  1. Why is this answer disappearing?

  2. Could this be related to why I some finalized forms are not moving to
    "Send Finalized Form"?

  3. If "no" to #2, could anyone suggest how to troubleshoot the problem?

Thanks
Eric

Choosing to save the form from the pop-up menu does not mark it as
finalized.

If you go to the finalized screen, check the finalized, then move backward,
and exit via the pop-up menu, it is saved as incomplete and the 'finalize'
step, where all constraints and required and relevant conditions are
double-checked, is not done.

Only if you check the 'Mark form as finalized' checkbox and click the 'Save
Form and Exit' on that screen, does the 'finalize' step happen and the form
get saved as Finalized.

If you then Edit Saved Form on a finalized form, any saved changes will
reset the form to the 'saved' (incomplete) status, until you select the
'Save Form and Exit' on the finalize screen of the survey.

··· On Thu, Jul 17, 2014 at 10:28 AM, Eric Green wrote:

Hi,

I am having intermittent problems with completed forms (marked as
finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I
can't reproduce this exactly with this minimal example
https://docs.google.com/spreadsheets/d/1QOhHE_6UKvdHbq1meDxIPbYUjW1mVmUrPkbx9lvQ86c/edit?usp=sharing,
but I think the following steps show the problem.

I choose to fill a blank form make selections some selections:

  • 1 for enumerator ID
  • 1002 for HHID
  • check the name that appears

Before ending, hit the return arrow and choose to save the changes. Then
go into Edit Saved Forms and go to the first question. Enumerator ID
appears, but the next question with the button for caregiver name is no
longer checked.

  1. Why is this answer disappearing?

  2. Could this be related to why I some finalized forms are not moving to
    "Send Finalized Form"?

  3. If "no" to #2, could anyone suggest how to troubleshoot the problem?

Thanks
Eric

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Eric,

No solution to offer, but I recently heard of this happening from one of our staff and couldn't figure it out - so will be watching this with interest!

Good Luck!

Brian

··· On Thursday, 17 July 2014 19:28:30 UTC+2, Eric Green wrote: > Hi, > > > I am having intermittent problems with completed forms (marked as finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I can't reproduce this exactly with this minimal example, but I think the following steps show the problem. > > > I choose to fill a blank form make selections some selections: > 1 for enumerator ID1002 for HHIDcheck the name that appearsBefore ending, hit the return arrow and choose to save the changes. Then go into Edit Saved Forms and go to the first question. Enumerator ID appears, but the next question with the button for caregiver name is no longer checked. > > > > 1. Why is this answer disappearing? > > > 2. Could this be related to why I some finalized forms are not moving to "Send Finalized Form"? > > > 3. If "no" to #2, could anyone suggest how to troubleshoot the problem? > > > Thanks > Eric

Thanks, Michael. What is happening is that they complete and mark as finalized, but the form is not moving to “Send Finalized Forms”. It remains in “Edit Saved Form”. When you open it from saved, you see that some items are missing answers that were selected previously.

The missing answers happen to be the ones in my minimal example, but I could not fully reproduce it. The behavior we’re seeing—disappearing responses to some items—also happens when you exit prematurely and save. When you go back in, the answers to these problem items are also missing.

We have 8 identical tablets in rotation, and the failure to finalize only happened on 2 of them today (2 different enumerators). If we go back into the ones that failed to finalize, we can make the selections again to the couple of problem items and then swipe all the way through to the end, still marking as finalized. It will move to “Send Finalized Form”, but the process is painful because of the long survey.

I just can’t figure out why some times the form will not finalize the first time when marked to finalize. I think it might have something to do with the items with disappearing responses, but this does not explain why it works fine the other 90% of the time.

··· On July 17, 2014 at 1:51:11 PM, Mitch Sundt (mitchellsundt@gmail.com) wrote:

Choosing to save the form from the pop-up menu does not mark it as finalized.

If you go to the finalized screen, check the finalized, then move backward, and exit via the pop-up menu, it is saved as incomplete and the 'finalize' step, where all constraints and required and relevant conditions are double-checked, is not done.

Only if you check the 'Mark form as finalized' checkbox and click the 'Save Form and Exit' on that screen, does the 'finalize' step happen and the form get saved as Finalized.

If you then Edit Saved Form on a finalized form, any saved changes will reset the form to the 'saved' (incomplete) status, until you select the 'Save Form and Exit' on the finalize screen of the survey.

On Thu, Jul 17, 2014 at 10:28 AM, Eric Green epgreen@gmail.com wrote:
Hi,

I am having intermittent problems with completed forms (marked as finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I can't reproduce this exactly with this minimal example, but I think the following steps show the problem.

I choose to fill a blank form make selections some selections:
1 for enumerator ID
1002 for HHID
check the name that appears
Before ending, hit the return arrow and choose to save the changes. Then go into Edit Saved Forms and go to the first question. Enumerator ID appears, but the next question with the button for caregiver name is no longer checked.

  1. Why is this answer disappearing?

  2. Could this be related to why I some finalized forms are not moving to "Send Finalized Form"?

  3. If "no" to #2, could anyone suggest how to troubleshoot the problem?

Thanks
Eric

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks, Brian. Let’s me know I am not crazy.

The only thing I can think of is that the enumerators accidentally unchecked the “mark as finalized” box on the final screen. This leaves the form in the saved folder. When we go back in, some questions (always the same ones), do not have answers.

To move the saved form to “send to finalized” without having to swipe through to the end, I enabled the “go to” prompt. We’ll enter the missing data then skip to the end to finalize.

To prevent accidental unchecking of “mark as finalized”, I’ve removed this function from the final page.

E

Eric,

No solution to offer, but I recently heard of this happening from one of our staff and couldn't figure it out - so will be watching this with interest!

Good Luck!

Brian

··· On July 17, 2014 at 3:18:07 PM, magee.brian@gmail.com (magee.brian@gmail.com) wrote:

On Thursday, 17 July 2014 19:28:30 UTC+2, Eric Green wrote:

Hi,

I am having intermittent problems with completed forms (marked as finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I can't reproduce this exactly with this minimal example, but I think the following steps show the problem.

I choose to fill a blank form make selections some selections:
1 for enumerator ID1002 for HHIDcheck the name that appearsBefore ending, hit the return arrow and choose to save the changes. Then go into Edit Saved Forms and go to the first question. Enumerator ID appears, but the next question with the button for caregiver name is no longer checked.

  1. Why is this answer disappearing?

  2. Could this be related to why I some finalized forms are not moving to "Send Finalized Form"?

  3. If "no" to #2, could anyone suggest how to troubleshoot the problem?

Thanks
Eric

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Sorry, Mitch. I think I had another thread open with a Michael!

··· On Thursday, July 17, 2014 2:00:37 PM UTC-4, Eric Green wrote: > > Thanks, Michael. What is happening is that they complete and mark as > finalized, but the form is not moving to “Send Finalized Forms”. It remains > in “Edit Saved Form”. When you open it from saved, you see that some items > are missing answers that were selected previously. > > The missing answers happen to be the ones in my minimal example, but I > could not fully reproduce it. The behavior we’re seeing—disappearing > responses to some items—also happens when you exit prematurely and save. > When you go back in, the answers to these problem items are also missing. > > We have 8 identical tablets in rotation, and the failure to finalize only > happened on 2 of them today (2 different enumerators). If we go back into > the ones that failed to finalize, we can make the selections again to the > couple of problem items and then swipe all the way through to the end, > still marking as finalized. It will move to “Send Finalized Form”, but the > process is painful because of the long survey. > > I just can’t figure out why some times the form will not finalize the > first time when marked to finalize. I think it might have something to do > with the items with disappearing responses, but this does not explain why > it works fine the other 90% of the time. > > > On July 17, 2014 at 1:51:11 PM, Mitch Sundt wrote: > > Choosing to save the form from the pop-up menu does not mark it as > finalized. > > If you go to the finalized screen, check the finalized, then move > backward, and exit via the pop-up menu, it is saved as incomplete and the > 'finalize' step, where all constraints and required and relevant conditions > are double-checked, is not done. > > Only if you check the 'Mark form as finalized' checkbox and click the > 'Save Form and Exit' on that screen, does the 'finalize' step happen and > the form get saved as Finalized. > > If you then Edit Saved Form on a finalized form, any saved changes will > reset the form to the 'saved' (incomplete) status, until you select the > 'Save Form and Exit' on the finalize screen of the survey. > > > > > > On Thu, Jul 17, 2014 at 10:28 AM, Eric Green wrote: > >> Hi, >> >> I am having intermittent problems with completed forms (marked as >> finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I >> can't reproduce this exactly with this minimal example >> , >> but I think the following steps show the problem. >> >> I choose to fill a blank form make selections some selections: >> >> - 1 for enumerator ID >> - 1002 for HHID >> - check the name that appears >> >> Before ending, hit the return arrow and choose to save the changes. Then >> go into Edit Saved Forms and go to the first question. Enumerator ID >> appears, but the next question with the button for caregiver name is no >> longer checked. >> >> 1. Why is this answer disappearing? >> >> 2. Could this be related to why I some finalized forms are not moving to >> "Send Finalized Form"? >> >> 3. If "no" to #2, could anyone suggest how to troubleshoot the problem? >> >> Thanks >> Eric >> -- >> -- >> Post: opendatakit@googlegroups.com >> Unsubscribe: opendatakit+unsubscribe@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> >> --- >> You received this message because you are subscribed to the Google Groups >> "ODK Community" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to opendatakit+unsubscribe@googlegroups.com. >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitchellsundt@gmail.com > -- > -- > Post: opendatakit@googlegroups.com > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > Options: http://groups.google.com/group/opendatakit?hl=en > > --- > You received this message because you are subscribed to a topic in the > Google Groups "ODK Community" group. > To unsubscribe from this topic, visit > https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe. > To unsubscribe from this group and all its topics, send an email to > opendatakit+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/d/optout. > >

It would be useful to track the type of question (select one, etc.), the
OS version, and the type/model of the device, as well as the OS version and
type/model of the devices that are not having the problem.

I know there were subtle changes in the order in which events were reported
in the software across the 2.x -to- 4.0 transition. This caused some
screens to not render correctly or Force Close.

Something like this may be occurring due to these differences.

Mitch

··· On Thu, Jul 17, 2014 at 12:23 PM, Eric Green wrote:

Thanks, Brian. Let’s me know I am not crazy.

The only thing I can think of is that the enumerators accidentally
unchecked the “mark as finalized” box on the final screen. This leaves the
form in the saved folder. When we go back in, some questions (always the
same ones), do not have answers.

To move the saved form to “send to finalized” without having to swipe
through to the end, I enabled the “go to” prompt. We’ll enter the missing
data then skip to the end to finalize.

To prevent accidental unchecking of “mark as finalized”, I’ve removed this
function from the final page.

E

On July 17, 2014 at 3:18:07 PM, magee.brian@gmail.com ( magee.brian@gmail.com) wrote:

Eric,

No solution to offer, but I recently heard of this happening from one of
our staff and couldn't figure it out - so will be watching this with
interest!

Good Luck!

Brian

On Thursday, 17 July 2014 19:28:30 UTC+2, Eric Green wrote:

Hi,

I am having intermittent problems with completed forms (marked as
finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I
can't reproduce this exactly with this minimal example, but I think the
following steps show the problem.

I choose to fill a blank form make selections some selections:
1 for enumerator ID1002 for HHIDcheck the name that appearsBefore
ending, hit the return arrow and choose to save the changes. Then go into
Edit Saved Forms and go to the first question. Enumerator ID appears, but
the next question with the button for caregiver name is no longer checked.

  1. Why is this answer disappearing?

  2. Could this be related to why I some finalized forms are not moving to
    "Send Finalized Form"?

  3. If "no" to #2, could anyone suggest how to troubleshoot the problem?

Thanks
Eric

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

All the devices are Samsung Galaxy Tab 3 Lite running Android 4.1.2 and ODK Collect 1.4.3. The problem has not occurred on all devices (all are serving the same forms) and does not happen every time. This is what makes me think that the enumerators might have been unchecking “mark as finalized”. That said, we’ve noticed that ODK Collect will sometimes crash, and I don’t know if that happened in these cases. I haven’t been able to reproduce myself.

When we jump back into a saved form, we see missing data on two required select_one questions (caregiver and childPrivate in this sample form). If we re-enter the data, we can jump to the end and finalize.

It would be useful to track the type of question (select one, etc.), the OS version, and the type/model of the device, as well as the OS version and type/model of the devices that are not having the problem.

I know there were subtle changes in the order in which events were reported in the software across the 2.x -to- 4.0 transition. This caused some screens to not render correctly or Force Close.

Something like this may be occurring due to these differences.

Mitch

Thanks, Brian. Let’s me know I am not crazy.

The only thing I can think of is that the enumerators accidentally unchecked the “mark as finalized” box on the final screen. This leaves the form in the saved folder. When we go back in, some questions (always the same ones), do not have answers.

To move the saved form to “send to finalized” without having to swipe through to the end, I enabled the “go to” prompt. We’ll enter the missing data then skip to the end to finalize.

To prevent accidental unchecking of “mark as finalized”, I’ve removed this function from the final page.

E

Eric,

No solution to offer, but I recently heard of this happening from one of our staff and couldn't figure it out - so will be watching this with interest!

Good Luck!

Brian

··· On July 17, 2014 at 3:43:09 PM, Mitch Sundt (mitchellsundt@gmail.com) wrote: On Thu, Jul 17, 2014 at 12:23 PM, Eric Green wrote: On July 17, 2014 at 3:18:07 PM, magee.brian@gmail.com (magee.brian@gmail.com) wrote:

On Thursday, 17 July 2014 19:28:30 UTC+2, Eric Green wrote:

Hi,

I am having intermittent problems with completed forms (marked as finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I can't reproduce this exactly with this minimal example, but I think the following steps show the problem.

I choose to fill a blank form make selections some selections:
1 for enumerator ID1002 for HHIDcheck the name that appearsBefore ending, hit the return arrow and choose to save the changes. Then go into Edit Saved Forms and go to the first question. Enumerator ID appears, but the next question with the button for caregiver name is no longer checked.

  1. Why is this answer disappearing?

  2. Could this be related to why I some finalized forms are not moving to "Send Finalized Form"?

  3. If "no" to #2, could anyone suggest how to troubleshoot the problem?

Thanks
Eric

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I have just pushed a bug fix update for ODK Collect to Google Play that
corrects a Force Close issue that may be affecting this.

When you mark-as-complete a form, there is a slight chance that the order
in which the code executes can lead to a force close during the operation.
I thought this would only affect the counts of saved and of finalized forms
on the main menu, but perhaps it is also affecting the saving of the data.
Upgrading to this version may fix your issue, and would certainly eliminate
this problem as a potential cause.

This problem doesn't occur often, but it does seem to affect the Galaxy
devices the most ( 130 events across 2100+ of the Tab3 devices since May
7th ).

If you are installing from Google Play, just accept the next update.

Otherwise, the APK is available from

··· On Thu, Jul 17, 2014 at 12:54 PM, Eric Green wrote:

All the devices are Samsung Galaxy Tab 3 Lite running Android 4.1.2 and
ODK Collect 1.4.3. The problem has not occurred on all devices (all are
serving the same forms) and does not happen every time. This is what makes
me think that the enumerators might have been unchecking “mark as
finalized”. That said, we’ve noticed that ODK Collect will sometimes crash,
and I don’t know if that happened in these cases. I haven’t been able to
reproduce myself.

When we jump back into a saved form, we see missing data on two required
select_one questions (caregiver and childPrivate in this sample form
https://docs.google.com/spreadsheets/d/1QOhHE_6UKvdHbq1meDxIPbYUjW1mVmUrPkbx9lvQ86c/edit?usp=sharing).
If we re-enter the data, we can jump to the end and finalize.

On July 17, 2014 at 3:43:09 PM, Mitch Sundt (mitchellsundt@gmail.com) wrote:

It would be useful to track the type of question (select one, etc.),
the OS version, and the type/model of the device, as well as the OS version
and type/model of the devices that are not having the problem.

I know there were subtle changes in the order in which events were
reported in the software across the 2.x -to- 4.0 transition. This caused
some screens to not render correctly or Force Close.

Something like this may be occurring due to these differences.

Mitch

On Thu, Jul 17, 2014 at 12:23 PM, Eric Green epgreen@gmail.com wrote:

Thanks, Brian. Let’s me know I am not crazy.

The only thing I can think of is that the enumerators accidentally
unchecked the “mark as finalized” box on the final screen. This leaves the
form in the saved folder. When we go back in, some questions (always the
same ones), do not have answers.

To move the saved form to “send to finalized” without having to swipe
through to the end, I enabled the “go to” prompt. We’ll enter the missing
data then skip to the end to finalize.

To prevent accidental unchecking of “mark as finalized”, I’ve removed
this function from the final page.

E

On July 17, 2014 at 3:18:07 PM, magee.brian@gmail.com ( magee.brian@gmail.com) wrote:

Eric,

No solution to offer, but I recently heard of this happening from one of
our staff and couldn't figure it out - so will be watching this with
interest!

Good Luck!

Brian

On Thursday, 17 July 2014 19:28:30 UTC+2, Eric Green wrote:

Hi,

I am having intermittent problems with completed forms (marked as
finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I
can't reproduce this exactly with this minimal example, but I think the
following steps show the problem.

I choose to fill a blank form make selections some selections:
1 for enumerator ID1002 for HHIDcheck the name that appearsBefore
ending, hit the return arrow and choose to save the changes. Then go into
Edit Saved Forms and go to the first question. Enumerator ID appears, but
the next question with the button for caregiver name is no longer checked.

  1. Why is this answer disappearing?

  2. Could this be related to why I some finalized forms are not moving
    to "Send Finalized Form"?

  3. If "no" to #2, could anyone suggest how to troubleshoot the problem?

Thanks
Eric

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Wow. Thanks for the quick fix, Mitch. When do you typically see it on Google Play. I see that the latest version is 1.4.3 uploaded May 19.

I have just pushed a bug fix update for ODK Collect to Google Play that corrects a Force Close issue that may be affecting this.

When you mark-as-complete a form, there is a slight chance that the order in which the code executes can lead to a force close during the operation. I thought this would only affect the counts of saved and of finalized forms on the main menu, but perhaps it is also affecting the saving of the data. Upgrading to this version may fix your issue, and would certainly eliminate this problem as a potential cause.

This problem doesn't occur often, but it does seem to affect the Galaxy devices the most ( 130 events across 2100+ of the Tab3 devices since May 7th ).

If you are installing from Google Play, just accept the next update.

Otherwise, the APK is available from http://opendatakit.org/downloads/download-info/odk-collect-apk/

All the devices are Samsung Galaxy Tab 3 Lite running Android 4.1.2 and ODK Collect 1.4.3. The problem has not occurred on all devices (all are serving the same forms) and does not happen every time. This is what makes me think that the enumerators might have been unchecking “mark as finalized”. That said, we’ve noticed that ODK Collect will sometimes crash, and I don’t know if that happened in these cases. I haven’t been able to reproduce myself.

When we jump back into a saved form, we see missing data on two required select_one questions (caregiver and childPrivate in this sample form). If we re-enter the data, we can jump to the end and finalize.

It would be useful to track the type of question (select one, etc.), the OS version, and the type/model of the device, as well as the OS version and type/model of the devices that are not having the problem.

I know there were subtle changes in the order in which events were reported in the software across the 2.x -to- 4.0 transition. This caused some screens to not render correctly or Force Close.

Something like this may be occurring due to these differences.

Mitch

Thanks, Brian. Let’s me know I am not crazy.

The only thing I can think of is that the enumerators accidentally unchecked the “mark as finalized” box on the final screen. This leaves the form in the saved folder. When we go back in, some questions (always the same ones), do not have answers.

To move the saved form to “send to finalized” without having to swipe through to the end, I enabled the “go to” prompt. We’ll enter the missing data then skip to the end to finalize.

To prevent accidental unchecking of “mark as finalized”, I’ve removed this function from the final page.

E

Eric,

No solution to offer, but I recently heard of this happening from one of our staff and couldn't figure it out - so will be watching this with interest!

Good Luck!

Brian

··· On July 17, 2014 at 5:50:52 PM, Mitch Sundt (mitchellsundt@gmail.com) wrote: On Thu, Jul 17, 2014 at 12:54 PM, Eric Green wrote: On July 17, 2014 at 3:43:09 PM, Mitch Sundt (mitchellsundt@gmail.com) wrote: On Thu, Jul 17, 2014 at 12:23 PM, Eric Green wrote: On July 17, 2014 at 3:18:07 PM, magee.brian@gmail.com (magee.brian@gmail.com) wrote:

On Thursday, 17 July 2014 19:28:30 UTC+2, Eric Green wrote:

Hi,

I am having intermittent problems with completed forms (marked as finalized) appearing in "Edit Saved Form" but not "Send Finalized Form". I can't reproduce this exactly with this minimal example, but I think the following steps show the problem.

I choose to fill a blank form make selections some selections:
1 for enumerator ID1002 for HHIDcheck the name that appearsBefore ending, hit the return arrow and choose to save the changes. Then go into Edit Saved Forms and go to the first question. Enumerator ID appears, but the next question with the button for caregiver name is no longer checked.

  1. Why is this answer disappearing?

  2. Could this be related to why I some finalized forms are not moving to "Send Finalized Form"?

  3. If "no" to #2, could anyone suggest how to troubleshoot the problem?

Thanks
Eric

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/p6MrC25vbiw/unsubscribe.
To unsubscribe from this group and all its topics, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com