Internal Server error 500 when uploading images

Hi. I am currently running Aggregate 1.2 and Collect 1.2 rev 1013.
This is a very strange error. When I upload my form without images, Collect
successfully sends the form to my MySQL/Tomcat/Aggregate server.

When I upload the same form with an image, my submission is rejected, and
Collect says Error:Internal Server Error (500) at [app server name]

The form when I upload with images in Collect 1.1.7 and Aggregate 1.0.8
works fine.

Any ideas? Thanks in advance.

The form is below.

Chien-Li Chung

··· ---------------------------------------------- <?xml version="1.0"?>

<h:html xmlns="http://www.w3.org/2002/xforms" xmlns:ev="http://www.w3.org/2001/xml-events" xmlns:h="http://www.w3.org/1999/xhtml" xmlns:jr="http://openrosa.org/javarosa" xmlns:orx="http://openrosa.org/xforms/" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<h:head>
<h:title>SSC Demo Form1</h:title>


<ssc_odk_form1 id="demo_aug2012">
<schooldetails_group>
<survey_date/>
<schoolcode_integer/>
<schoolname_text/>
<town_text/>
<postaladdress_text/>
<phone_integer/>
<fax_integer/>
<schoolhead_text/>
<sex_select/>
<FoundingAgency_select/>
<location_select/>
<DistanceToDistrictOffice_integer/>
</schooldetails_group>
<school_geopoint/>
<school_image/>
<SchoolHead_image/>
<enrollment_group>
<table_list_G1M/>
<table_list_G1F/>
<table_list_G2M/>
<table_list_G2F/>
<table_list_G3M/>
<table_list_G3F/>
<table_list_G4M/>
<table_list_G4F/>
<table_list_G5M/>
<table_list_G5F/>
<table_list_G6M/>
<table_list_G6F/>
<table_list_G7M/>
<table_list_G7F/>
<table_list_G8M/>
<table_list_G8F/>
<table_list_G9M/>
<table_list_G9F/>
<table_list_G10M/>
<table_list_G10F/>
<table_list_G11M/>
<table_list_G11F/>
<table_list_G12M/>
<table_list_G12F/>
</enrollment_group>
<attendance_group>
<reserved_name_for_field_list_labels_46/>
<term_text/>
<TermDays_integer/>
<NumTeachers_integer/>
<NumExcusedTeacherAbscenceDays_integer/>
<NumUnexcusedTeacherAbscenceDays_integer/>
<NumMaleStudents_integer/>
<NumMaleStudentsAbscenceDays_integer/>
<NumFemaleStudents_integer/>
<NumFemaleStudentsAbscenceDays_integer/>
</attendance_group>
<performance_group>
<NumInstructionalHoursPerDay_integer/>
<NumInstructionalDaysPerWeek_integer/>
</performance_group>



</ssc_odk_form1>






















































</h:head>
<h:body>

Section 1. School Details

Date:


School code:
What is the school code?


School name:
What is the school name?


Name of Village/Town:
What is the name of the village/town?


Postal address:
What is the postal address?


Phone:
What is the school's phone number?


Fax:
What is the school's fax number?


School head name:
What is the school head's name?


School head sex:
What is the school head's sex?

Male
male


Female
female



Founding Agency:
What is the school's founding agency?

Government
government


Community
community


Church
church


Private
private



Location:
Is the school in an urban or rural area?

Urban
urban


Rural
rural



Distance to district office (km)?
What is the distance to the district office in km?



Record school's GPS location.
GPS coordinates can only be collected when outside.


Take a picture of the main school building.


Take a picture of the school head.


Section 2. Student Enrollment

Grade 1 Boys


Grade 1 Girls


Grade 2 Boys


Grade 2 Girls


Grade 3 Boys


Grade 3 Girls


Grade 4 Boys


Grade 4 Girls


Grade 5 Boys


Grade 5 Girls


Grade 6 Boys


Grade 6 Girls


Grade 7 Boys


Grade 7 Girls


Grade 8 Boys


Grade 8 Girls


Grade 9 Boys


Grade 9 Girls


Grade 10 Boys


Grade 10 Girls


Grade 11 Boys


Grade 11 Girls


Grade 12 Boys


Grade 12 Girls



Section 3. Attendance

    </label>
    <item>
      <label>Term 1</label>
      <value>term1</value>
    </item>
    <item>
      <label>Term 2</label>
      <value>term2</value>
    </item>
    <item>
      <label>Term 3</label>
      <value>term3</value>
    </item>
    <item>
      <label>Term 4</label>
      <value>term4</value>
    </item>
  </select1>
  <select1 appearance="list-nolabel" ref="/ssc_odk_form1/attendance_group/term_text">
    <label>Term:</label>
    <item>
      <label>Term 1</label>
      <value>term1</value>
    </item>
    <item>
      <label>Term 2</label>
      <value>term2</value>
    </item>
    <item>
      <label>Term 3</label>
      <value>term3</value>
    </item>
    <item>
      <label>Term 4</label>
      <value>term4</value>
    </item>
  </select1>
  <input ref="/ssc_odk_form1/attendance_group/TermDays_integer">
    <label>Number of days in term:</label>
  </input>
  <input ref="/ssc_odk_form1/attendance_group/NumTeachers_integer">
    <label>Number of teachers:</label>
  </input>
  <input ref="/ssc_odk_form1/attendance_group/NumExcusedTeacherAbscenceDays_integer">
    <label>Number of excused teacher absences in days:</label>
  </input>
  <input ref="/ssc_odk_form1/attendance_group/NumUnexcusedTeacherAbscenceDays_integer">
    <label>Number of unexcused teacher absences in days:</label>
  </input>
  <input ref="/ssc_odk_form1/attendance_group/NumMaleStudents_integer">
    <label>Number of male students:</label>
  </input>
  <input ref="/ssc_odk_form1/attendance_group/NumMaleStudentsAbscenceDays_integer">
    <label>Number of male students absences in days:</label>
  </input>
  <input ref="/ssc_odk_form1/attendance_group/NumFemaleStudents_integer">
    <label>Number of female students:</label>
  </input>
  <input ref="/ssc_odk_form1/attendance_group/NumFemaleStudentsAbscenceDays_integer">
    <label>Number of female students absences in days:</label>
  </input>
</group>
<group appearance="field-list" ref="/ssc_odk_form1/performance_group">
  <label>Section 4. Performance</label>
  <input ref="/ssc_odk_form1/performance_group/NumInstructionalHoursPerDay_integer">
    <label>Number of instructional hours per day:</label>
  </input>
  <input ref="/ssc_odk_form1/performance_group/NumInstructionalDaysPerWeek_integer">
    <label>Number of instructional days per week:</label>
  </input>
</group>

</h:body>
</h:html>

To help narrow this down it's helpful to figure out if Aggregate or
Collect is having issues. To test this I like to manually upload the
submission to Aggregate. To do this go to Form Management Tab ->
Submission Admin SubTab -> "Manually Upload Submission Data". If the
submission can be done manually then the issue is with collect then,
if not then issue is either with Aggregate or the form itself.

Waylon

··· On Mon, Aug 13, 2012 at 7:42 PM, Chien-Li Chung wrote: > Hi. I am currently running Aggregate 1.2 and Collect 1.2 rev 1013. > This is a very strange error. When I upload my form without images, Collect > successfully sends the form to my MySQL/Tomcat/Aggregate server. > > When I upload the same form with an image, my submission is rejected, and > Collect says Error:Internal Server Error (500) at [app server name] > > The form when I upload with images in Collect 1.1.7 and Aggregate 1.0.8 > works fine. > > Any ideas? Thanks in advance. > > The form is below. > > Chien-Li Chung > > ---------------------------------------------- > > <?xml version="1.0"?> > xmlns:ev="http://www.w3.org/2001/xml-events" > xmlns:h="http://www.w3.org/1999/xhtml" > xmlns:jr="http://openrosa.org/javarosa" > xmlns:orx="http://openrosa.org/xforms/" > xmlns:xsd="http://www.w3.org/2001/XMLSchema"> > > SSC Demo Form1 > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > > type="date"/> > type="int"/> > type="string"/> > type="string"/> > type="string"/> > type="int"/> > type="int"/> > type="string"/> > type="select1"/> > nodeset="/ssc_odk_form1/schooldetails_group/FoundingAgency_select" > type="select1"/> > type="select1"/> > nodeset="/ssc_odk_form1/schooldetails_group/DistanceToDistrictOffice_integer" > type="int"/> > > > > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > type="int"/> > nodeset="/ssc_odk_form1/attendance_group/reserved_name_for_field_list_labels_46" > type="select1"/> > type="select1"/> > type="int"/> > type="int"/> > nodeset="/ssc_odk_form1/attendance_group/NumExcusedTeacherAbscenceDays_integer" > type="decimal"/> > nodeset="/ssc_odk_form1/attendance_group/NumUnexcusedTeacherAbscenceDays_integer" > type="decimal"/> > nodeset="/ssc_odk_form1/attendance_group/NumMaleStudents_integer" > type="int"/> > nodeset="/ssc_odk_form1/attendance_group/NumMaleStudentsAbscenceDays_integer" > type="decimal"/> > nodeset="/ssc_odk_form1/attendance_group/NumFemaleStudents_integer" > type="int"/> > nodeset="/ssc_odk_form1/attendance_group/NumFemaleStudentsAbscenceDays_integer" > type="decimal"/> > nodeset="/ssc_odk_form1/performance_group/NumInstructionalHoursPerDay_integer" > type="decimal"/> > nodeset="/ssc_odk_form1/performance_group/NumInstructionalDaysPerWeek_integer" > type="int"/> > nodeset="/ssc_odk_form1/meta/instanceID" readonly="true()" type="string"/> > > > > > Section 1. School Details > > Date: > > > School code: > What is the school code? > > > School name: > What is the school name? > > > Name of Village/Town: > What is the name of the village/town? > > > Postal address: > What is the postal address? > > > Phone: > What is the school's phone number? > > > Fax: > What is the school's fax number? > > > School head name: > What is the school head's name? > > > School head sex: > What is the school head's sex? > > Male > male > > > Female > female > > > ref="/ssc_odk_form1/schooldetails_group/FoundingAgency_select"> > Founding Agency: > What is the school's founding agency? > > Government > government > > > Community > community > > > Church > church > > > Private > private > > > > Location: > Is the school in an urban or rural area? > > Urban > urban > > > Rural > rural > > > ref="/ssc_odk_form1/schooldetails_group/DistanceToDistrictOffice_integer"> > Distance to district office (km)? > What is the distance to the district office in km? > > > > Record school's GPS location. > GPS coordinates can only be collected when outside. > > > Take a picture of the main school building. > > > Take a picture of the school head. > > > Section 2. Student Enrollment > > Grade 1 Boys > > > Grade 1 Girls > > > Grade 2 Boys > > > Grade 2 Girls > > > Grade 3 Boys > > > Grade 3 Girls > > > Grade 4 Boys > > > Grade 4 Girls > > > Grade 5 Boys > > > Grade 5 Girls > > > Grade 6 Boys > > > Grade 6 Girls > > > Grade 7 Boys > > > Grade 7 Girls > > > Grade 8 Boys > > > Grade 8 Girls > > > Grade 9 Boys > > > Grade 9 Girls > > > Grade 10 Boys > > > Grade 10 Girls > > > Grade 11 Boys > > > Grade 11 Girls > > > Grade 12 Boys > > > Grade 12 Girls > > > > Section 3. Attendance > ref="/ssc_odk_form1/attendance_group/reserved_name_for_field_list_labels_46"> > > > > > Term 1 > term1 > > > Term 2 > term2 > > > Term 3 > term3 > > > Term 4 > term4 > > > ref="/ssc_odk_form1/attendance_group/term_text"> > Term: > > Term 1 > term1 > > > Term 2 > term2 > > > Term 3 > term3 > > > Term 4 > term4 > > > > Number of days in term: > > > Number of teachers: > > ref="/ssc_odk_form1/attendance_group/NumExcusedTeacherAbscenceDays_integer"> > Number of excused teacher absences in days: > > ref="/ssc_odk_form1/attendance_group/NumUnexcusedTeacherAbscenceDays_integer"> > Number of unexcused teacher absences in days: > > > Number of male students: > > ref="/ssc_odk_form1/attendance_group/NumMaleStudentsAbscenceDays_integer"> > Number of male students absences in days: > > ref="/ssc_odk_form1/attendance_group/NumFemaleStudents_integer"> > Number of female students: > > ref="/ssc_odk_form1/attendance_group/NumFemaleStudentsAbscenceDays_integer"> > Number of female students absences in days: > > > > Section 4. Performance > ref="/ssc_odk_form1/performance_group/NumInstructionalHoursPerDay_integer"> > Number of instructional hours per day: > > ref="/ssc_odk_form1/performance_group/NumInstructionalDaysPerWeek_integer"> > Number of instructional days per week: > > > > > > > -- > Post: opendatakit@googlegroups.com > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > Options: http://groups.google.com/group/opendatakit?hl=en

Thanks Waylon for the info on the Manual Submission thru Aggregate. I
didn't know of the feature.

I uploaded the submission from my phone ODK/instances folder. Aggregate
accepted the xml submission and the jpeg without any
errors but I did not see the image in the "Submissions Tab"

The column that contains the image is empty. The other columns that hold
the data and the metadata are filled in.
The record that contains the manual submission exists. The only thing
missing is the image.

/Chien-Li

Under ...\Tomcat 6.0\logs, see if there are any errors in:

catalina....log

If you are getting a 500, there should be a stack trace in that file.
If not, see if anything is appearing in:

tomcat6-stderr...log
tomcat6-stdout...log files.

Mitch

··· On Tue, Aug 14, 2012 at 8:17 AM, Chien-Li Chung wrote:

Thanks Waylon for the info on the Manual Submission thru Aggregate. I
didn't know of the feature.

I uploaded the submission from my phone ODK/instances folder. Aggregate
accepted the xml submission and the jpeg without any
errors but I did not see the image in the "Submissions Tab"

The column that contains the image is empty. The other columns that hold
the data and the metadata are filled in.
The record that contains the manual submission exists. The only thing
missing is the image.

/Chien-Li

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Hi Mitch.

I saw this error message in my tomcat6-stdout log file.

Caused by: org.springframework.dao.TransientDataAccessResourceException:
PreparedStatementCallback; SQL [INSERT INTO
odk_prod.DEMO_AUG2012_SCHOOL_IMAGE_BLB ( _URI, _CREATOR_URI_USER,
_CREATION_DATE, _LAST_UPDATE_URI_USER, _LAST_UPDATE_DATE,
_TOP_LEVEL_AURI, VALUE ) VALUES ( ?, ?, ?, ?, ?, ?, ? ) ]; Packet for
query is too large (2686969 > 1048576). You can change this value on the
server by setting the max_allowed_packet' variable.; nested exception is
com.mysql.jdbc.PacketTooBigException: Packet for query is too large
(2686969 > 1048576). You can change this value on the server by setting the
max_allowed_packet' variable.

Does this mean I just a smaller image size or change the max_allowed_packet
to 4MB?

Thanks.

/Chien-Li

You should change the server setting to increase the max_allowed_packet.

With ODK Aggregate 1.2, the MySQL datastore code was changed so that it
stored data in LONGBLOB chunks (2^32 bytes). As opposed to BLOB previously.

Apparently, this requires a change to the MySQL installation to increase
the "max_allowed_packet" size.

From the MySQL manual:

The maximum size of a BLOB or TEXT object is determined by its type, but
the largest value you actually can transmit between the client and server
is determined by the amount of available memory and the size of the
communications buffers. You can change the message buffer size by changing
the value of the
max_allowed_packethttps://dev.mysql.com/doc/refman/5.6/en/server-system-variables.html#sysvar_max_allowed_packetvariable,
but you must do so for both the server and your client program.
For example, both
mysqlhttps://dev.mysql.com/doc/refman/5.6/en/mysql.htmland
mysqldump https://dev.mysql.com/doc/refman/5.6/en/mysqldump.html enable
you to change the client-side
max_allowed_packethttps://dev.mysql.com/doc/refman/5.6/en/server-system-variables.html#sysvar_max_allowed_packetvalue.
See Section 8.11.2,
“Tuning Server Parameters”https://dev.mysql.com/doc/refman/5.6/en/server-parameters.html,
Section 4.5.1, “mysql — The MySQL Command-Line
Tool”https://dev.mysql.com/doc/refman/5.6/en/mysql.html,
and Section 4.5.4, “mysqldump — A Database Backup
Program”https://dev.mysql.com/doc/refman/5.6/en/mysqldump.html.
You may also want to compare the packet sizes and the size of the data
objects you are storing with the storage requirements, see Section 11.6,
“Data Type Storage
Requirements”https://dev.mysql.com/doc/refman/5.6/en/storage-requirements.html

You must increase this value if you are using large
BLOBhttp://docs.oracle.com/cd/E17952_01/refman-5.0-en/blob.htmlcolumns
or long strings. It should be as big as the largest
BLOB http://docs.oracle.com/cd/E17952_01/refman-5.0-en/blob.html you want
to use. The protocol limit for
max_allowed_packethttp://docs.oracle.com/cd/E17952_01/refman-5.0-en/server-system-variables.html#sysvar_max_allowed_packetis
1GB. The value should be a multiple of 1024; nonmultiples are rounded
down to the nearest multiple.

When you change the message buffer size by changing the value of the
max_allowed_packethttp://docs.oracle.com/cd/E17952_01/refman-5.0-en/server-system-variables.html#sysvar_max_allowed_packetvariable,
you should also change the buffer size on the client side if your
client program permits it. On the client side,
max_allowed_packethttp://docs.oracle.com/cd/E17952_01/refman-5.0-en/server-system-variables.html#sysvar_max_allowed_packethas
a default of 1GB. Some programs such as
mysql http://docs.oracle.com/cd/E17952_01/refman-5.0-en/mysql.html and *
mysqldump*http://docs.oracle.com/cd/E17952_01/refman-5.0-en/mysqldump.htmlenable
you to change the client-side value by setting
max_allowed_packethttp://docs.oracle.com/cd/E17952_01/refman-5.0-en/server-system-variables.html#sysvar_max_allowed_packeton
the command line or in an option file.

··· --------------- Irksome. Makes me hate MySQL.

Mitch

On Tue, Aug 14, 2012 at 6:26 PM, Chien-Li Chung cchung@camelthorn.comwrote:

Hi Mitch.

I saw this error message in my tomcat6-stdout log file.

Caused by: org.springframework.dao.TransientDataAccessResourceException:
PreparedStatementCallback; SQL [INSERT INTO
odk_prod.DEMO_AUG2012_SCHOOL_IMAGE_BLB ( _URI, _CREATOR_URI_USER,
_CREATION_DATE, _LAST_UPDATE_URI_USER, _LAST_UPDATE_DATE,
_TOP_LEVEL_AURI, VALUE ) VALUES ( ?, ?, ?, ?, ?, ?, ? ) ]; Packet for
query is too large (2686969 > 1048576). You can change this value on the
server by setting the max_allowed_packet' variable.; nested exception is
com.mysql.jdbc.PacketTooBigException: Packet for query is too large
(2686969 > 1048576). You can change this value on the server by setting the
max_allowed_packet' variable.

Does this mean I just a smaller image size or change the
max_allowed_packet to 4MB?

Thanks.

/Chien-Li

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thanks Mitch. I changed max_allowed_packet to 8M, and images started
loading into MySQL.

/Chien-Li

Thanks Mitch. I changed max_allowed_packet to 8M, and images started
loading into MySQL.

/Chien-Li
Hello Cheng,

Am in the middle of critical data collection, I have got the same problem
as yours, when I upload files without photos they submit well, however when
I upload files with big size photos I get the error: internal server error
(500)
from your posts I see I have to increase the size in MYSQL however am a
novice user of mysql
could you please provide me with a step by step guide on how you increse
the max size to allow big files
Thanx

··· On Thursday, 16 August 2012 00:29:32 UTC+3, Chien-Li Chung wrote:

If you are running ODK Aggregate 1.4.x or later, this isn't the issue.

However, it is likely that either:

(1) the transmission speed of your connections is too slow to support
uploading images

or

(2) the Tomcat server is running out of memory

Look at your Tomcat logs to see if there are any OutOfMemory errors.

If you are not seeing OutOfMemory errors, then it will be caused by (1).

Otherwise, to increase the Tomcat memory, search for "Tomcat JVM size"
together with your operating system.

If you are unfamiliar with Java, you can search for "Java JVM options" to
read up on what they mean:

And this gives some further explanation, but is probably overkill:

··· On Mon, Aug 10, 2015 at 9:36 AM, Ayoub Kakande wrote:

On Thursday, 16 August 2012 00:29:32 UTC+3, Chien-Li Chung wrote:

Thanks Mitch. I changed max_allowed_packet to 8M, and images started
loading into MySQL.

/Chien-Li
Hello Cheng,

Am in the middle of critical data collection, I have got the same problem
as yours, when I upload files without photos they submit well, however when
I upload files with big size photos I get the error: internal server error
(500)
from your posts I see I have to increase the size in MYSQL however am a
novice user of mysql
could you please provide me with a step by step guide on how you increse
the max size to allow big files
Thanx

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thanx Mitch
from the log files am not seeing anything like out of memory ,yet with the
speeds am on wifi, I have also tried from other wifi connections and they
are failing, (I have attached the latest catalina file just in case am
missing something)
Any other heads up as am beaten

catalina.2015-08-10.log (5.09 KB)

··· On 10 August 2015 at 20:02, Mitch Sundt wrote:

If you are running ODK Aggregate 1.4.x or later, this isn't the issue.

However, it is likely that either:

(1) the transmission speed of your connections is too slow to support
uploading images

or

(2) the Tomcat server is running out of memory

Look at your Tomcat logs to see if there are any OutOfMemory errors.

If you are not seeing OutOfMemory errors, then it will be caused by (1).

Otherwise, to increase the Tomcat memory, search for "Tomcat JVM size"
together with your operating system.

If you are unfamiliar with Java, you can search for "Java JVM options" to
read up on what they mean:

http://stackoverflow.com/questions/19864293/which-arguments-stand-for-what-in-jvm-memory-options

And this gives some further explanation, but is probably overkill:
http://blog.sokolenko.me/2014/11/javavm-options-production.html

On Mon, Aug 10, 2015 at 9:36 AM, Ayoub Kakande akakande@gmail.com wrote:

On Thursday, 16 August 2012 00:29:32 UTC+3, Chien-Li Chung wrote:

Thanks Mitch. I changed max_allowed_packet to 8M, and images started
loading into MySQL.

/Chien-Li
Hello Cheng,

Am in the middle of critical data collection, I have got the same problem
as yours, when I upload files without photos they submit well, however when
I upload files with big size photos I get the error: internal server error
(500)
from your posts I see I have to increase the size in MYSQL however am a
novice user of mysql
could you please provide me with a step by step guide on how you increse
the max size to allow big files
Thanx

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living and
medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

Look in the other log files in that directory -- most of the logging seems
to go into a tomcat...stdout...log file.

··· On Mon, Aug 10, 2015 at 11:07 PM, Ayoub Kakande wrote:

Thanx Mitch
from the log files am not seeing anything like out of memory ,yet with the
speeds am on wifi, I have also tried from other wifi connections and they
are failing, (I have attached the latest catalina file just in case am
missing something)
Any other heads up as am beaten

On 10 August 2015 at 20:02, Mitch Sundt mitchellsundt@gmail.com wrote:

If you are running ODK Aggregate 1.4.x or later, this isn't the issue.

However, it is likely that either:

(1) the transmission speed of your connections is too slow to support
uploading images

or

(2) the Tomcat server is running out of memory

Look at your Tomcat logs to see if there are any OutOfMemory errors.

If you are not seeing OutOfMemory errors, then it will be caused by (1).

Otherwise, to increase the Tomcat memory, search for "Tomcat JVM size"
together with your operating system.

If you are unfamiliar with Java, you can search for "Java JVM options" to
read up on what they mean:

http://stackoverflow.com/questions/19864293/which-arguments-stand-for-what-in-jvm-memory-options

And this gives some further explanation, but is probably overkill:
http://blog.sokolenko.me/2014/11/javavm-options-production.html

On Mon, Aug 10, 2015 at 9:36 AM, Ayoub Kakande akakande@gmail.com wrote:

On Thursday, 16 August 2012 00:29:32 UTC+3, Chien-Li Chung wrote:

Thanks Mitch. I changed max_allowed_packet to 8M, and images started
loading into MySQL.

/Chien-Li
Hello Cheng,

Am in the middle of critical data collection, I have got the same
problem as yours, when I upload files without photos they submit well,
however when I upload files with big size photos I get the error: internal
server error (500)
from your posts I see I have to increase the size in MYSQL however am a
novice user of mysql
could you please provide me with a step by step guide on how you increse
the max size to allow big files
Thanx

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living and
medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Hi Mitch
am still beaten
The last log file I see are of 14 aug 2015 yet data submission is on a
daily basis

··· On 11 August 2015 at 19:31, Mitch Sundt wrote:

Look in the other log files in that directory -- most of the logging seems
to go into a tomcat...stdout...log file.

On Mon, Aug 10, 2015 at 11:07 PM, Ayoub Kakande akakande@gmail.com wrote:

Thanx Mitch
from the log files am not seeing anything like out of memory ,yet with
the speeds am on wifi, I have also tried from other wifi connections and
they are failing, (I have attached the latest catalina file just in case am
missing something)
Any other heads up as am beaten

On 10 August 2015 at 20:02, Mitch Sundt mitchellsundt@gmail.com wrote:

If you are running ODK Aggregate 1.4.x or later, this isn't the issue.

However, it is likely that either:

(1) the transmission speed of your connections is too slow to support
uploading images

or

(2) the Tomcat server is running out of memory

Look at your Tomcat logs to see if there are any OutOfMemory errors.

If you are not seeing OutOfMemory errors, then it will be caused by (1).

Otherwise, to increase the Tomcat memory, search for "Tomcat JVM size"
together with your operating system.

If you are unfamiliar with Java, you can search for "Java JVM options"
to read up on what they mean:

http://stackoverflow.com/questions/19864293/which-arguments-stand-for-what-in-jvm-memory-options

And this gives some further explanation, but is probably overkill:
http://blog.sokolenko.me/2014/11/javavm-options-production.html

On Mon, Aug 10, 2015 at 9:36 AM, Ayoub Kakande akakande@gmail.com wrote:

On Thursday, 16 August 2012 00:29:32 UTC+3, Chien-Li Chung wrote:

Thanks Mitch. I changed max_allowed_packet to 8M, and images started
loading into MySQL.

/Chien-Li
Hello Cheng,

Am in the middle of critical data collection, I have got the same
problem as yours, when I upload files without photos they submit well,
however when I upload files with big size photos I get the error: internal
server error (500)
from your posts I see I have to increase the size in MYSQL however am a
novice user of mysql
could you please provide me with a step by step guide on how you
increse the max size to allow big files
Thanx

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living
and medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living and
medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

Hi
am still beaten
The last log file I see are of 14 aug 2015 yet data submission is on a
daily basis, the current error is of 16 aug 2015
All other files without photos are submitted successfully it's only
particular
forms with photos that are bring the error ( - Error: internal server error
(500) at https://mail2.mujhu.org:8080:8443/ODKAggregate/submission?deviceid=imei%3A58...)

Thanx any urgent help will be much appreciated

··· On 11 August 2015 at 19:31, Mitch Sundt wrote:

Look in the other log files in that directory -- most of the logging seems
to go into a tomcat...stdout...log file.

On Mon, Aug 10, 2015 at 11:07 PM, Ayoub Kakande akakande@gmail.com wrote:

Thanx Mitch
from the log files am not seeing anything like out of memory ,yet with
the speeds am on wifi, I have also tried from other wifi connections and
they are failing, (I have attached the latest catalina file just in case am
missing something)
Any other heads up as am beaten

On 10 August 2015 at 20:02, Mitch Sundt mitchellsundt@gmail.com wrote:

If you are running ODK Aggregate 1.4.x or later, this isn't the issue.

However, it is likely that either:

(1) the transmission speed of your connections is too slow to support
uploading images

or

(2) the Tomcat server is running out of memory

Look at your Tomcat logs to see if there are any OutOfMemory errors.

If you are not seeing OutOfMemory errors, then it will be caused by (1).

Otherwise, to increase the Tomcat memory, search for "Tomcat JVM size"
together with your operating system.

If you are unfamiliar with Java, you can search for "Java JVM options"
to read up on what they mean:

http://stackoverflow.com/questions/19864293/which-arguments-stand-for-what-in-jvm-memory-options

And this gives some further explanation, but is probably overkill:
http://blog.sokolenko.me/2014/11/javavm-options-production.html

On Mon, Aug 10, 2015 at 9:36 AM, Ayoub Kakande akakande@gmail.com wrote:

On Thursday, 16 August 2012 00:29:32 UTC+3, Chien-Li Chung wrote:

Thanks Mitch. I changed max_allowed_packet to 8M, and images started
loading into MySQL.

/Chien-Li
Hello Cheng,

Am in the middle of critical data collection, I have got the same
problem as yours, when I upload files without photos they submit well,
however when I upload files with big size photos I get the error: internal
server error (500)
from your posts I see I have to increase the size in MYSQL however am a
novice user of mysql
could you please provide me with a step by step guide on how you
increse the max size to allow big files
Thanx

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living
and medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living and
medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

Without log files, there isn't much that can be done to diagnose this.
Perhaps your configuration is writing all the data to the Aug 14 file (the
most recent log entries will be at the bottom of that file)?

You can try increasing the Tomcat JVM size. It is likely that this will
either eliminate or lessen the frequency of this problem occurring.

I would also recommend setting up a test system with a Tomcat server and
figuring out how to get the log files to be generated on that system. On a
simple Tomcat 6 install, the logs are being produced. You might have
modified something? Once you get logs to be produced on that test system,
transfer the changes to your production system. Then we'll be more informed
about what is going on in that system.

··· On Mon, Aug 17, 2015 at 2:07 AM, Ayoub Kakande wrote:

Hi
am still beaten
The last log file I see are of 14 aug 2015 yet data submission is on a
daily basis, the current error is of 16 aug 2015
All other files without photos are submitted successfully it's only
particular
forms with photos that are bring the error ( - Error: internal server
error (500) at https://mail2.mujhu.org:8080:8443/ODKAggregate/submission?deviceid=imei%3A58...)

Thanx any urgent help will be much appreciated

On 11 August 2015 at 19:31, Mitch Sundt mitchellsundt@gmail.com wrote:

Look in the other log files in that directory -- most of the logging
seems to go into a tomcat...stdout...log file.

On Mon, Aug 10, 2015 at 11:07 PM, Ayoub Kakande akakande@gmail.com wrote:

Thanx Mitch
from the log files am not seeing anything like out of memory ,yet with
the speeds am on wifi, I have also tried from other wifi connections and
they are failing, (I have attached the latest catalina file just in case am
missing something)
Any other heads up as am beaten

On 10 August 2015 at 20:02, Mitch Sundt mitchellsundt@gmail.com wrote:

If you are running ODK Aggregate 1.4.x or later, this isn't the issue.

However, it is likely that either:

(1) the transmission speed of your connections is too slow to support
uploading images

or

(2) the Tomcat server is running out of memory

Look at your Tomcat logs to see if there are any OutOfMemory errors.

If you are not seeing OutOfMemory errors, then it will be caused by
(1).

Otherwise, to increase the Tomcat memory, search for "Tomcat JVM size"
together with your operating system.

If you are unfamiliar with Java, you can search for "Java JVM options"
to read up on what they mean:

http://stackoverflow.com/questions/19864293/which-arguments-stand-for-what-in-jvm-memory-options

And this gives some further explanation, but is probably overkill:
http://blog.sokolenko.me/2014/11/javavm-options-production.html

On Mon, Aug 10, 2015 at 9:36 AM, Ayoub Kakande akakande@gmail.com wrote:

On Thursday, 16 August 2012 00:29:32 UTC+3, Chien-Li Chung wrote:

Thanks Mitch. I changed max_allowed_packet to 8M, and images started
loading into MySQL.

/Chien-Li
Hello Cheng,

Am in the middle of critical data collection, I have got the same
problem as yours, when I upload files without photos they submit well,
however when I upload files with big size photos I get the error: internal
server error (500)
from your posts I see I have to increase the size in MYSQL however am
a novice user of mysql
could you please provide me with a step by step guide on how you
increse the max size to allow big files
Thanx

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living
and medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living and
medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Bigups Mitch Photos are now coming in
It was a Tomcat JVM size issues, once increase as u suggested everything is
fine now
Thanx Boss

··· On 17 August 2015 at 19:47, Mitch Sundt wrote:

Without log files, there isn't much that can be done to diagnose this.
Perhaps your configuration is writing all the data to the Aug 14 file (the
most recent log entries will be at the bottom of that file)?

You can try increasing the Tomcat JVM size. It is likely that this will
either eliminate or lessen the frequency of this problem occurring.

I would also recommend setting up a test system with a Tomcat server and
figuring out how to get the log files to be generated on that system. On a
simple Tomcat 6 install, the logs are being produced. You might have
modified something? Once you get logs to be produced on that test system,
transfer the changes to your production system. Then we'll be more informed
about what is going on in that system.

On Mon, Aug 17, 2015 at 2:07 AM, Ayoub Kakande akakande@gmail.com wrote:

Hi
am still beaten
The last log file I see are of 14 aug 2015 yet data submission is on a
daily basis, the current error is of 16 aug 2015
All other files without photos are submitted successfully it's only
particular
forms with photos that are bring the error ( - Error: internal server
error (500) at https://mail2.mujhu.org:8080:8443/ODKAggregate/submission?deviceid=imei%3A58...)

Thanx any urgent help will be much appreciated

On 11 August 2015 at 19:31, Mitch Sundt mitchellsundt@gmail.com wrote:

Look in the other log files in that directory -- most of the logging
seems to go into a tomcat...stdout...log file.

On Mon, Aug 10, 2015 at 11:07 PM, Ayoub Kakande akakande@gmail.com wrote:

Thanx Mitch
from the log files am not seeing anything like out of memory ,yet with
the speeds am on wifi, I have also tried from other wifi connections and
they are failing, (I have attached the latest catalina file just in case am
missing something)
Any other heads up as am beaten

On 10 August 2015 at 20:02, Mitch Sundt mitchellsundt@gmail.com wrote:

If you are running ODK Aggregate 1.4.x or later, this isn't the issue.

However, it is likely that either:

(1) the transmission speed of your connections is too slow to support
uploading images

or

(2) the Tomcat server is running out of memory

Look at your Tomcat logs to see if there are any OutOfMemory errors.

If you are not seeing OutOfMemory errors, then it will be caused by
(1).

Otherwise, to increase the Tomcat memory, search for "Tomcat JVM size"
together with your operating system.

If you are unfamiliar with Java, you can search for "Java JVM options"
to read up on what they mean:

http://stackoverflow.com/questions/19864293/which-arguments-stand-for-what-in-jvm-memory-options

And this gives some further explanation, but is probably overkill:
http://blog.sokolenko.me/2014/11/javavm-options-production.html

On Mon, Aug 10, 2015 at 9:36 AM, Ayoub Kakande akakande@gmail.com wrote:

On Thursday, 16 August 2012 00:29:32 UTC+3, Chien-Li Chung wrote:

Thanks Mitch. I changed max_allowed_packet to 8M, and images started
loading into MySQL.

/Chien-Li
Hello Cheng,

Am in the middle of critical data collection, I have got the same
problem as yours, when I upload files without photos they submit well,
however when I upload files with big size photos I get the error: internal
server error (500)
from your posts I see I have to increase the size in MYSQL however am
a novice user of mysql
could you please provide me with a step by step guide on how you
increse the max size to allow big files
Thanx

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living
and medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living
and medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
**In sun set years education is not associated with standard of living and
medical care access; it is the the financial myosin and actin!!!

**** Don't give me fish, teach me how to fish

Kayoub K
0772656158 / 0703516660
PMTCT Data Manager
Mujhu Research Collaboration
Mulago Hosp

Lecturer
Kumi University

hi there please help us we are in trouble;

Error (500) cant upload image, sound and video?

192.168.1.1 - - [10/Jul/2017:14:31:50 +0200] "HEAD /submission?deviceID=imei%3A867420020626224 HTTP/1.1" 204 -
192.168.1.1 - - [10/Jul/2017:14:31:51 +0200] "POST /submission HTTP/1.1" 500 1057

Victor,
More information is needed to help solve your problem. What server are you trying to upload to? Where is this server running? How did you configure the server?

1 Like