Issue displaying summary table using field-list appearance and read_only on ODK Collect

1. What is the problem? Be very detailed.

For the past years, we have been using an xls form with the following structure: repeat group for HH members (name/age/gender) followed by a table with field-list appearance and read_only summarizing the information from the repeat group.
The summary table worked well and displayed correctly the results until ODK Collect v1.29.4 where results are not displayed anymore on the app. Are there any issues with read_only setting on ODK v1.29.4?

2. What app or server are you using and on what device and operating system? Include version numbers.

App: ODK Collect v1.29.4
Server: Kobo Toolbox

3. What you have you tried to fix the problem?
We have managed to solve the issue by suppressing read_only.

4. What steps can we take to reproduce the problem?

  1. Deploy initial XLS form on server.
  2. Test form on ODK Collect v1.29.4, summary table will not display results
  3. Modify XLS form by suppressing read-only yes
  4. Re-deploy form on server
  5. It will now display the results correctly on ODK Collect

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Demography form.xlsx (154.3 KB)

Hi @claudia.grigore
We're glad you're here. When you get a chance, please introduce yourself on this forum thread. I'd also encourage you to add a real picture as your avatar because it helps build community!

Some time ago we thought that it would be good to introduce some consistency when using the read_only option in widgets. We decided that the body of every widget should not be displayed if a question is read_only and there is no answer. That's why in your case you can't see those values. Those values are not answers but just labels.

We could add select questions with label appearance as an exception but what's the point of having those questions read_only? Those are just labels so it doesn't change anything right?