Issue Uploading New Form on ODK Aggregate

Hello all,

I am trying to upload a new survey form onto my ODK Aggregate server and am receiving the following error code:

"Error: Problem with JavaRosa Parsing Form: org.opendatakit.aggregate.exception.ODKIncompleteSubmissionData: Javarosa failed to construct a FormDef. Is this an XForm definition?"

I converted my server to XML format using ODK XLSForm Offline v1.9.0 with no errors. I tested the XML file using ODK Validate v1.11.0 with no errors. Similar issues on help forums are caused by issues like improper formats or errors with variables in group designations, but neither of these apply to my survey.

My survey is quite long so I was thinking it may be caused by that? My next idea is to reduce the length of my survey and try again, but I wanted to see if anyone had ideas of things to try prior to reducing the size of the survey.

Thanks in advance for your help!

Welcome to the ODK forum, @maxeber ! We're glad you're here. When you get a chance, please introduce yourself here. I'd also encourage you to add a real picture as your avatar because it helps build community!

What version of Aggregate are you using?

Hi Guillermo -- thanks for your reply. I had already added a picture as my avatar, but maybe it wasn't showing up for you? I have now also introduced myself as you suggested.

I believe the Aggregate I'm using is version v1.4.14.

The picture is fine :slight_smile:

So, that version of Aggregate is pretty old and might lack features that you're using in your form. One way to verify this would be to try to upload your form to the sandbox Aggregate server, which is running the latest Aggregate version. If it works in the sandbox, you should consider updating your server.

I tried uploading it on the sandbox Aggregate server as you suggested and I get the following error message:

502 Bad Gateway
nginx/1.10.3 (Ubuntu)

@maxeber My guess is that we are running into nginx's timeout limits because the form might be really big. Can you post the XLS copy of your form publicly? If not, email it to me at and I can take a quick look.

Hi Yaw,

Thank you for your reply -- I have just emailed the XLS form to you.

Thanks in advance for your help!

The core problem is that the form is really big. Let's see if the community can help reduce the size of the form and we can go from there.

As a note to my future self, I tried this:

  • XLSForm Online v1.4.1 failed conversion with a recursion depth error.
  • pyxform v0.13.1 on the command line converted successfully.
  • Collect v1.21 loaded form, but very slow on Moto G5 and a few ANRs.
  • Aggregate v2.0.2 failed with Nginx reporting bad gateway and increasing timeouts on nginx config didn't help.