Issues deploying the WHO 2016 verbal autopsy form on aggregate

I'm trying to deploy the WHO 2016 verbal autopsy form. I've been at it for over 4hrs and it's still creating tables at the back-end. Around 2350 tables created and still counting.

I'm Using aggregate on a windows server 2008
I have tried increasing memory space on tomcat to no avail.
You can do exactly what I've done by generating the .xml file from the VA form which is available via WHO site, host aggregate on a tomcat server and try deploying the xml file.

@aurdipas Can you help here since you are our resident VA expert! Did you have very powerful servers?

Hi @Benny,

could you be more specific on the version of Aggregate, Tomcat etc.
Which database do you have installed?

It looks strange to me that amount of tables.
The most complex setting I have with a WHO VA questionnaire + more than 100 extra question added results in 60 tables in MySQL.

Would it be interesting as well to add the tomcat log, could you provide it?

not at all. Very normal servers :slight_smile: I did test it as well on my digital ocean instance (minimal configuration suggested in the docs for DO installation)


@aurdipas @yanokwa Thanks for the responses... I'll send screenshots to further explain my situation.
Meanwhile configuration settings are
Tomcat 6.0
Aggregate v1.0
Windows server 2008 R2 on a 4GHZ RAM & 2.26GHZ (2) processors
4397 tables created as at the time of this shot... Still counting though, just curious to see if/where it ends.

Hi @Benny,

I see that you don't use the standard WHO VA questionnaire (I see the name change in the table).
Did you modify it?
Did you add questions?

Which version of MySql do you use? Can you try to change the max_allowed_packet and innodb_log_file_size in my.ini increasing them?

Thanks again for the response @aurdipas
The name of the form was just modified to reflect internal modifications but it's still the same file. It was just grammatical edits to aid understanding.
The SQL version is 5.0

did you check the configuration parameters on the my.ini?

Then I'd ask to @yanokwa if there's a difference on the way Aggregate 1.0 create the tables respect to the latest version of Aggregate?

I don't think there has been any changes. @Benny can you post the XLS form so we can try to verify this behavior?

Yes I have and tried increasing it but no effects on improvement yet @aurdipas

@yanokwa I'll post the xls form as soon as I can.

I'll try to virtualize an environment with a different configuration, probably using an updated aggregate server. Will keep you informed on hopefully progresses recorded.

Many apologies all, I have been out in the field and couldn't access the internet.
Here's the xml form like I promised.
@aurdipas @yanokwa
hdss_va_2016_11_03_v1.xml (1.1 MB)

On another note, my virtual tomcat 7 server where I intended to deploy the new aggregate server has been giving me the failure message "Application at context path /*** could not be started"
Has anyone resolved such with aggregate 2.x recently?

Original document before edit
08_1_WHOVA2016_v1_5_1_XLS_form_for_ODK.xlsx (78.7 KB)

Dear @Benny,

starting version 1.4.13 of Aggregate only tomcat 8 is supported.

You can install earlier versions of Aggregate on Tomcat 7, but you must edit context.xml (under Tomcat 7's conf directory) to have the attribute useHttpOnly set to false: .

I'll check the form in the next few days and I'll get back to you.


Dear @Benny,

did you find a solution to your problem?
The form itself it is not an issue.
I deployed on my Tomcat8 with Aggregate 2.0,3 and Mysql 5.7 and all is fine.

I think the issues are on your configuration.

Could you try a most recent version of Aggregate on Tomcat8?

Best regards,

1 Like

Got a temporary solution to that problem. I'll try your recommendation as soon as I can.
Many thanks.