Issues with email deliverability using the stock email server

I am having a similar issue - just installed Central on a DigitalOcean droplet and everything was working fine but I was having issues with email deliverability using the stock email server (couldn't send users signup emails - mail-tester.com wasn't even recieving anything). Followed the directions for setting up a custom mailserver with mailgun and now when I try to log in on the web it throws this error:

Have already tried changing the ports around, secure and not secure, deleting the secure flag altogether - nothing seems to work. currently my config.json.template file looks like this:

What can I do to resolve this issue? TXT and MX records are already verified with mailgun so that shouldn't be the issue either. the issue has to be something with this file but I cannot figure out what it is for the life of me.

EDIT: changed the port to 25 and then I was able to log in, but when I tried to send a test email it just times out (504 error).

Is this a DNS issue? Still stumped.

Try port 587 and setting secure to false as shown at https://docs.getodk.org/central-install-digital-ocean/#using-a-custom-mail-server.

You can also try looking at your docker logs with docker-compose logs service and docker-compose logs mail to see if there are any hints as to what is wrong.

This is the log it sends when I try to test the stock email server with mail-tester.com - it just times out and mail-tester doesn't even receive anything.