Limit in xform file size?

Good afternoon,

I am implementing a Xform manually typing it (I have tried ODK Build
before, but I've got the same problem). I am using ODK Collect 1.1.4
in Android 1.5.

I am pretty sure that the syntax is OK, all the fields have lables and
etc. It passes without errors neither warnings in ODK Validator and
JavaRosa Validator.

When the file has about 800 lines it takes a while to load (when I
start a new interview) but goes ok. The problem is one the file gets
900 lines, when I try to load the file, ODK Collect takes a couple of
seconds loading it and display me a message saying that the
application has suddenly stopped.

If I remove the last 6 variables (and their nodes and their input
declarations), eveything works well.

The file is uploaded here: http://dl.dropbox.com/u/10570347/blocoF.xml

Any ideas?

Thanks!

upgrade to the newly released odk 1.1.5. i tried it and works just great.

··· On Wed, Nov 3, 2010 at 12:27, Thales wrote: > Good afternoon, > > I am implementing a Xform manually typing it (I have tried ODK Build > before, but I've got the same problem). I am using ODK Collect 1.1.4 > in Android 1.5. > > I am pretty sure that the syntax is OK, all the fields have lables and > etc. It passes without errors neither warnings in ODK Validator and > JavaRosa Validator. > > When the file has about 800 lines it takes a while to load (when I > start a new interview) but goes ok. The problem is one the file gets > 900 lines, when I try to load the file, ODK Collect takes a couple of > seconds loading it and display me a message saying that the > application has suddenly stopped. > > If I remove the last 6 variables (and their nodes and their input > declarations), eveything works well. > > > The file is uploaded here: http://dl.dropbox.com/u/10570347/blocoF.xml > > Any ideas? > > Thanks!

Is it possible to install 1.1.5 version in Android 1.5? I tried without
success...

Thanks!

··· 2010/11/3 Yaw Anokwa

upgrade to the newly released odk 1.1.5. i tried it and works just great.

On Wed, Nov 3, 2010 at 12:27, Thales thales.web@gmail.com wrote:

Good afternoon,

I am implementing a Xform manually typing it (I have tried ODK Build
before, but I've got the same problem). I am using ODK Collect 1.1.4
in Android 1.5.

I am pretty sure that the syntax is OK, all the fields have lables and
etc. It passes without errors neither warnings in ODK Validator and
JavaRosa Validator.

When the file has about 800 lines it takes a while to load (when I
start a new interview) but goes ok. The problem is one the file gets
900 lines, when I try to load the file, ODK Collect takes a couple of
seconds loading it and display me a message saying that the
application has suddenly stopped.

If I remove the last 6 variables (and their nodes and their input
declarations), eveything works well.

The file is uploaded here: http://dl.dropbox.com/u/10570347/blocoF.xml

Any ideas?

Thanks!

what phone you using?

··· On Wed, Nov 3, 2010 at 12:33, Thales Santos wrote: > Is it possible to install 1.1.5 version in Android 1.5? I tried without > success... > > Thanks! > > 2010/11/3 Yaw Anokwa >> >> upgrade to the newly released odk 1.1.5. i tried it and works just great. >> >> On Wed, Nov 3, 2010 at 12:27, Thales wrote: >> > Good afternoon, >> > >> > I am implementing a Xform manually typing it (I have tried ODK Build >> > before, but I've got the same problem). I am using ODK Collect 1.1.4 >> > in Android 1.5. >> > >> > I am pretty sure that the syntax is OK, all the fields have lables and >> > etc. It passes without errors neither warnings in ODK Validator and >> > JavaRosa Validator. >> > >> > When the file has about 800 lines it takes a while to load (when I >> > start a new interview) but goes ok. The problem is one the file gets >> > 900 lines, when I try to load the file, ODK Collect takes a couple of >> > seconds loading it and display me a message saying that the >> > application has suddenly stopped. >> > >> > If I remove the last 6 variables (and their nodes and their input >> > declarations), eveything works well. >> > >> > >> > The file is uploaded here: http://dl.dropbox.com/u/10570347/blocoF.xml >> > >> > Any ideas? >> > >> > Thanks! > >

It is a LG GW620f

··· 2010/11/3 Yaw Anokwa

what phone you using?

On Wed, Nov 3, 2010 at 12:33, Thales Santos thales.web@gmail.com wrote:

Is it possible to install 1.1.5 version in Android 1.5? I tried without
success...

Thanks!

2010/11/3 Yaw Anokwa yanokwa@gmail.com

upgrade to the newly released odk 1.1.5. i tried it and works just
great.

On Wed, Nov 3, 2010 at 12:27, Thales thales.web@gmail.com wrote:

Good afternoon,

I am implementing a Xform manually typing it (I have tried ODK Build
before, but I've got the same problem). I am using ODK Collect 1.1.4
in Android 1.5.

I am pretty sure that the syntax is OK, all the fields have lables and
etc. It passes without errors neither warnings in ODK Validator and
JavaRosa Validator.

When the file has about 800 lines it takes a while to load (when I
start a new interview) but goes ok. The problem is one the file gets
900 lines, when I try to load the file, ODK Collect takes a couple of
seconds loading it and display me a message saying that the
application has suddenly stopped.

If I remove the last 6 variables (and their nodes and their input
declarations), eveything works well.

The file is uploaded here:
http://dl.dropbox.com/u/10570347/blocoF.xml

Any ideas?

Thanks!

speak with your carrier and see if there is a 1.6 upgrade. if not,
maybe consider http://openetna.com/openetna. i'll take a look at this
on 1.1.4 and see what the other options are.

are there other people with 1.5 devices that they can't upgrade?

··· On Wed, Nov 3, 2010 at 12:36, Thales Santos wrote: > It is a LG GW620f > > 2010/11/3 Yaw Anokwa >> >> what phone you using? >> >> On Wed, Nov 3, 2010 at 12:33, Thales Santos wrote: >> > Is it possible to install 1.1.5 version in Android 1.5? I tried without >> > success... >> > >> > Thanks! >> > >> > 2010/11/3 Yaw Anokwa >> >> >> >> upgrade to the newly released odk 1.1.5. i tried it and works just >> >> great. >> >> >> >> On Wed, Nov 3, 2010 at 12:27, Thales wrote: >> >> > Good afternoon, >> >> > >> >> > I am implementing a Xform manually typing it (I have tried ODK Build >> >> > before, but I've got the same problem). I am using ODK Collect 1.1.4 >> >> > in Android 1.5. >> >> > >> >> > I am pretty sure that the syntax is OK, all the fields have lables >> >> > and >> >> > etc. It passes without errors neither warnings in ODK Validator and >> >> > JavaRosa Validator. >> >> > >> >> > When the file has about 800 lines it takes a while to load (when I >> >> > start a new interview) but goes ok. The problem is one the file gets >> >> > 900 lines, when I try to load the file, ODK Collect takes a couple of >> >> > seconds loading it and display me a message saying that the >> >> > application has suddenly stopped. >> >> > >> >> > If I remove the last 6 variables (and their nodes and their input >> >> > declarations), eveything works well. >> >> > >> >> > >> >> > The file is uploaded here: >> >> > http://dl.dropbox.com/u/10570347/blocoF.xml >> >> > >> >> > Any ideas? >> >> > >> >> > Thanks! >> > >> > > >

Thanks for your help... I'll try this openetna.

In Brazil, lots of people cant upgrade from 1.5. Our carriers are not making
any effort in this way.

··· 2010/11/3 Yaw Anokwa

speak with your carrier and see if there is a 1.6 upgrade. if not,
maybe consider http://openetna.com/openetna. i'll take a look at this
on 1.1.4 and see what the other options are.

are there other people with 1.5 devices that they can't upgrade?

On Wed, Nov 3, 2010 at 12:36, Thales Santos thales.web@gmail.com wrote:

It is a LG GW620f

2010/11/3 Yaw Anokwa yanokwa@gmail.com

what phone you using?

On Wed, Nov 3, 2010 at 12:33, Thales Santos thales.web@gmail.com wrote:

Is it possible to install 1.1.5 version in Android 1.5? I tried
without

success...

Thanks!

2010/11/3 Yaw Anokwa yanokwa@gmail.com

upgrade to the newly released odk 1.1.5. i tried it and works just
great.

On Wed, Nov 3, 2010 at 12:27, Thales thales.web@gmail.com wrote:

Good afternoon,

I am implementing a Xform manually typing it (I have tried ODK
Build

before, but I've got the same problem). I am using ODK Collect
1.1.4

in Android 1.5.

I am pretty sure that the syntax is OK, all the fields have lables
and
etc. It passes without errors neither warnings in ODK Validator and
JavaRosa Validator.

When the file has about 800 lines it takes a while to load (when I
start a new interview) but goes ok. The problem is one the file
gets

900 lines, when I try to load the file, ODK Collect takes a couple
of

seconds loading it and display me a message saying that the
application has suddenly stopped.

If I remove the last 6 variables (and their nodes and their input
declarations), eveything works well.

The file is uploaded here:
http://dl.dropbox.com/u/10570347/blocoF.xml

Any ideas?

Thanks!

Originally I thought there were a number of things that required Android
1.6, but on closer inspection there was only 1 line that required 1.6+.
Turns out that line was actually not needed so I just checked in a fix so
that v1.1.5 will work on Android 1.5+.

It should be pushed to market and updated on the downloads page on the
website soon. Yaw will send an email.
-Carl

··· On Wed, Nov 3, 2010 at 8:51 PM, Thales Santos wrote:

Thanks for your help... I'll try this openetna.

In Brazil, lots of people cant upgrade from 1.5. Our carriers are not
making any effort in this way.

2010/11/3 Yaw Anokwa yanokwa@gmail.com

speak with your carrier and see if there is a 1.6 upgrade. if not,
maybe consider http://openetna.com/openetna. i'll take a look at this
on 1.1.4 and see what the other options are.

are there other people with 1.5 devices that they can't upgrade?

On Wed, Nov 3, 2010 at 12:36, Thales Santos thales.web@gmail.com wrote:

It is a LG GW620f

2010/11/3 Yaw Anokwa yanokwa@gmail.com

what phone you using?

On Wed, Nov 3, 2010 at 12:33, Thales Santos thales.web@gmail.com wrote:

Is it possible to install 1.1.5 version in Android 1.5? I tried
without

success...

Thanks!

2010/11/3 Yaw Anokwa yanokwa@gmail.com

upgrade to the newly released odk 1.1.5. i tried it and works just
great.

On Wed, Nov 3, 2010 at 12:27, Thales thales.web@gmail.com wrote:

Good afternoon,

I am implementing a Xform manually typing it (I have tried ODK
Build

before, but I've got the same problem). I am using ODK Collect
1.1.4

in Android 1.5.

I am pretty sure that the syntax is OK, all the fields have lables
and
etc. It passes without errors neither warnings in ODK Validator
and

JavaRosa Validator.

When the file has about 800 lines it takes a while to load (when I
start a new interview) but goes ok. The problem is one the file
gets

900 lines, when I try to load the file, ODK Collect takes a couple
of

seconds loading it and display me a message saying that the
application has suddenly stopped.

If I remove the last 6 variables (and their nodes and their input
declarations), eveything works well.

The file is uploaded here:
http://dl.dropbox.com/u/10570347/blocoF.xml

Any ideas?

Thanks!

Just to give you guys a feedback: I saw at ODK website that ODK Collect had
been updated. I updated and it worked perfectly on Android 1.5!

Thanks!

··· 2010/11/3 Carl Hartung

Originally I thought there were a number of things that required Android
1.6, but on closer inspection there was only 1 line that required 1.6+.
Turns out that line was actually not needed so I just checked in a fix so
that v1.1.5 will work on Android 1.5+.

It should be pushed to market and updated on the downloads page on the
website soon. Yaw will send an email.
-Carl

On Wed, Nov 3, 2010 at 8:51 PM, Thales Santos thales.web@gmail.comwrote:

Thanks for your help... I'll try this openetna.

In Brazil, lots of people cant upgrade from 1.5. Our carriers are not
making any effort in this way.

2010/11/3 Yaw Anokwa yanokwa@gmail.com

speak with your carrier and see if there is a 1.6 upgrade. if not,
maybe consider http://openetna.com/openetna. i'll take a look at this
on 1.1.4 and see what the other options are.

are there other people with 1.5 devices that they can't upgrade?

On Wed, Nov 3, 2010 at 12:36, Thales Santos thales.web@gmail.com wrote:

It is a LG GW620f

2010/11/3 Yaw Anokwa yanokwa@gmail.com

what phone you using?

On Wed, Nov 3, 2010 at 12:33, Thales Santos thales.web@gmail.com wrote:

Is it possible to install 1.1.5 version in Android 1.5? I tried
without

success...

Thanks!

2010/11/3 Yaw Anokwa yanokwa@gmail.com

upgrade to the newly released odk 1.1.5. i tried it and works just
great.

On Wed, Nov 3, 2010 at 12:27, Thales thales.web@gmail.com wrote:

Good afternoon,

I am implementing a Xform manually typing it (I have tried ODK
Build

before, but I've got the same problem). I am using ODK Collect
1.1.4

in Android 1.5.

I am pretty sure that the syntax is OK, all the fields have
lables

and
etc. It passes without errors neither warnings in ODK Validator
and

JavaRosa Validator.

When the file has about 800 lines it takes a while to load (when
I

start a new interview) but goes ok. The problem is one the file
gets

900 lines, when I try to load the file, ODK Collect takes a
couple of

seconds loading it and display me a message saying that the
application has suddenly stopped.

If I remove the last 6 variables (and their nodes and their input
declarations), eveything works well.

The file is uploaded here:
http://dl.dropbox.com/u/10570347/blocoF.xml

Any ideas?

Thanks!