'list' object has no attribute 'startswith'

What is the problem? Please be detailed.
When I try to convert the xls form to xml form it online then it shows the line
'list' object has no attribute 'startswith'
Why this error appears and how could I minimize the error.

What ODK tool and version are you using? And on what device and operating system version?

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Hi @Badrun_Nahar,

Are you able to share your form? Or a subset of the form that contains the error. We will be in a better position to assist if you share the form.

We would like to learn more about yourself, what you do, your interests, projects you are working ... please introduce yourself. Whilst you are it, please add a profile picture.

Hi@Ronald ,

It's nice to see your interest. I have attached my a subset of my form.
I am looking for your reply.

I will update my profile very soon.


Badrun Nahar

PRISM_V01.xlsx (44.1 KB)

Hi @Badrun_Nahar,

Not sure if am missing something in your question, but I tried to convert the attached form and I didn't get any errors. I have attached the XML.


BernardUntitled_20170809123814.xml (179.0 KB)

Hi @Bernard0995677054

Which converter did you use? I am getting an error with the online converter

I am still facing the same problem.Could you please share how you convert the file.I try to convert the xls file to xml in odk website.

looking for your reply.


Hi @Badrun_Nahar and @Ronald_Munjoma,

I used the an offline XLS converter ( https://opendatakit.org/download/4543/ ) and it worked fine. However, i think the issue is on the expressions you have used on the Choice_filter column. I tried to remove the filter expressions on Row 5&6 and the online converter worked, please cross-check if those expressions are correct.



Hi @Bernard0995677054,

I have checked the choice filter column of my xls form.It was fully okay.But why it shows such problem I don't know.Any ways thanks for the file.