Minimal appearance for select_multiple displays unexpected objects

1. What is the issue? Please be detailed.
Enketo form displays comma-separated values beneath the input box and the list displays an option (...) that is not in the list of options.
Tried in both iOS and Android devices.

2. What steps can we take to reproduce this issue?
Create a multi-select question with minimal appearance and preview using Enketo. Btw, we are deploying this particular form in Enketo and not in ODK Collect

3. What have you tried to fix the issue?
Not use minimal appearance. But that's not how we want to implement it.

4. Upload any forms or screenshots you can share publicly below.
Please see attached.

Thank you!

Could you, please, provide a related extract of this choice list or a screenshot, incl. the column headers? Do you use multiple languages?

"With select multiples, make sure that the values you set for name have no spaces in them because selected values are separated by spaces." (ODK labels instead name codes - #6 by LN)

Hi @wroos !

Thank you for your response. No, I don't use multiple languages.


Do you see the problem only in enketo and with minimal appearance?
(And any other case works fine?)

Yes. Only in Enketo and with mininal appearance, and on mobile devices like smartphones and tablets. No problem on a laptop or computer.


It seems indeed a frontend problem on the "mobile" appearance.

I could reproduce it, it appears both for single and multiple select types.
It seems that the "..." replace the "none selected" placeholder in the desktop view.

One workaround would be to switch to the desktop site on mobile, in this case it seems to work.

I also checkee the submission, indeed, the "..." is ignored.

@martijnr have you seen it before?

Hope it helps


Thanks for the report, @Vinia_Marciano, and for troubleshooting, everyone.

I've filed the issue and we will try to take a look when we prepare for the next Enketo release. In the mean time, does making the question required prevent this from being selected?

1 Like

Yes, making the question required seems to solve the problem (at least in my small test) @Vinia_Marciano ?


Thank you for looking into this @alfonso . However making it required doesn’t exactly address the issue. It still displays the codes beneath the input box and … still appears in the list.

Thanks @LN for filing.

1 Like

You are right, sorry.
Did switching to the desktop site work?