Navigating to Central Management website after setting it up loads Welcome to Nginx instead

1. What is the issue? Please be detailed.
After following the instructions to setup ODK Central on my VPS, navigating to the domain name I'm using shows the "Welcome to Nginx" page instead of the Central management website.

2. What steps can we take to reproduce this issue?
Following the instructions initially gave me an "address already in use" error with respect to central_nginx_1 when running docker-compose up -d. I thought this might be due to another container that I'm running on the same VPS but on a different domain name and changed the following lines in docker-compose.yml:

  - "${HTTP_PORT:-80}:80"
  - "${HTTPS_PORT:-443}:443"


  - "8088:80"
  - "444:443"

This did let docker-compose up -d run successfully and I got "Up (healthy)" in the state column for nginx upon running docker-compose ps.

However, actually visiting the domain name specified in .env only shows the "Welcome to Nginx" page.

3. What have you tried to fix the issue?
Not sure about how to go ahead from here.

4. Upload any test forms or screenshots below.


I'm assuming your SSL_TYPE in your .env file is set to letsencrypt? If so, you can't run on non 80/443 ports.

Stop the other container you have for now, revert the change you made in Central, get it working with LetsEncrypt, and see if you run the other container on a different port.

1 Like

Thanks for the answer!

I forgot to mention that the two containers would be tied to different domain names. I was hoping that there was a way for me to configure the nginx container that is a part of Central to let it use 80/443 for this domain name without interfering with the other container and its domain name.

The other container runs on while Central would run on Would this still not be possible?