Need a link to download :

We are hardly working to install ODKAggregate on a Ubuntu server 64bits.
Please someone can help us to get the link to download this old version of ODK Aggregate :

1 Like

You should be able to download previous versions via github here. I dont see an actual .run script for v1.4.11, but there's at least the source tarball or zip file you could build and install. Or if you really need an installer there is one for a v1.4.12 installer

Thank. We dont't have experience to do that but we are start compiling the source code... we have to use the 1.4.11 because of another depending sofware. May be someone can share ?

These installers were certainly around back-in-the-day from, but it looks like not all were re-posted when everything moved over to github. Perhaps if you ask nicely the ODK gods will put the 1.4.11 installer back up for you... (@yanokwa?)

Personally, I'd recommend either building from the ODK aggregate source on github, or running an installer obtained from the primary source: ODK. Installing something obtained from an (unknown?) 3rd party always carries some risk.

We do have all the old binaries, but we didn't upload them to GitHub because it wasn't clear that people want (or should) have old versions.

@Karim_Derra You can find a copy of the old binary at And you can find a list of the available binaries at

Can you tell me a bit more about why you need to use 1.4.11? Won't 1.5.0 or 1.6.0 work just as well?

1 Like

Thanks a lot @yanokwa. We are installing OpenHDS 1.6 application on a linux server which required tomcat 6 and java 7. OpenHDS app. call ODK collect to fill the forms in the field. Then, ODK Aggregate have to be install and connect to the dbs. We tried the new versions but it does not work; tomcat 6 is not supported.

1 Like

That's a pretty good reason. Thanks for clarifying! I'll get those binaries up later tonight.

This will be good. Thanks @yanokwa.

As promised, the old versions are now on GitHub!

Good. I am I am downloading it. Thnaks @yanokwa.

For posterity, 1.4.11 installers are here

Thanks you. @Xiphware

Its works now. Thank a lot @yanokwa

Thank you @yanokwa, this is really helpful when you are upgrading to the latest version incrementally