Need help in setting ODK Application Designer v2.0

(1) I'd like to get more debugging information on the npm command. Try
this:

npm -d install -g grunt-cli
You should see all the GET requests that I had in my original screen shot,
and a few more lines for each as it reports progress/status of the GET and
install.

(2) If that seems to go OK and has all the GET requests in my screen shot,
try copying the ApplicationDesigner directory to your local disk drive
(e.g., C:\AppDesigner ). And running grunt from there. It may be that
there is a problem running grunt from a directory that is under a roaming
profile.

··· On Tue, Sep 2, 2014 at 12:31 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear I downloaded the latest version of Application designer from
http://opendatakit.org/downloads/download-info/odk-applicationdeveloper-v2-0-alpha-1-zip/

npm install goes same as mentioned in your pic. My result is also attached.

Still when i open in chrome with developer mode, it does not display any
thing and no directory is listed.

On Tue, Sep 2, 2014 at 11:49 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Thank a million dear for such a detailed help. I will try and come back
to you.

Thank you again

On Tue, Sep 2, 2014 at 11:39 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

Ok.

Please verify that you have the latest ODK ApplicationDesigner download.
I updated this, and the simpledemo zip, late last week, so you might not
have the very latest.

Then download and install fsum.exe ( http://www.slavasoft.com/fsum/ )
and type:

fsum -sha256 "ODK ApplicationDesigner v2.0 rev 122 full.zip"

(or whatever your downloaded filename is for the zip file), then you
should see:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:18:28
;

4779d02f8f1f13c8a05987c0d260cc8d5ecfd882be9880a1c4bb9a4fd0dc57eb
?SHA256
ODK ApplicationDesigner v2.0 rev 122 full(1).zip*
and the big number 4779... should match -- if not, then you have a
different version of the zip file than is on the site.

If you are trying to follow the getting started guide, then the fsum
-sha265 output for the simpledemo zip file is:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:30:13
;

b86c2803310f6506852489bd693840d396ecfd8cf781a10f8eaf35eab3e09144
?SHA256
ODK ApplicationDesigner v2.0 rev 122 simpledemo(2).zip*


Assuming you have the most current versions of these, and have unzipped
it...

In a cmd window, type:

npm install -g grunt-cli

to confirm the install of grunt. You should see output similar to that
shown on the npm_install_ok.png (attached).

If you get anything that is not an "npm http 200..." then that is a
problem.

If that is all correct, then,

(1) Run the grunt command in the unzipped ApplicationDesigner directory
( the one containing the Gruntfile.js )

(2) open Chrome

(3) go to its Menu / Tools / Developer Tools

(4) Make sure the Chrome developer console is showing in the bottom of
your Chrome window or is in a seperate window.

Now change the URL in the Chrome browser to

localhost:8000

This should display directory contents. E.g., see attached
localhost_8000.png image.

On Tue, Sep 2, 2014 at 11:12 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear,

I get the same

TCP 127.0.0.1:8000 http://127.0.0.1:8000/
QADEER:0 LISTENING [node.exe]

On Tue, Sep 2, 2014 at 11:00 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can be
quite long, especially if you have many browser windows open. If necessary,
you can send this through 'more' to paginate the output ( netstat -ab |
more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]

The line below this line will tell you what executable is running on
port 8000. In this case, when you have a successful grunt start-up, you
would see [node.exe]

What do you see?

If you don't see any entry for port 8000, try running grunt and in
another command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various
modules, then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

It appears likely that there is another application using port
8000 on

your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome browser
from

accessing it.

I am still in the process of updating the documentation on the
site for

the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week),
I can

work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the
Google

Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from
it, send

an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in
the

Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Attached are two screen shots of what my npm -d install -g grunt-cli
command generates.

··· On Tue, Sep 2, 2014 at 1:20 PM, Mitch Sundt wrote:

(1) I'd like to get more debugging information on the npm command. Try
this:

npm -d install -g grunt-cli
You should see all the GET requests that I had in my original screen shot,
and a few more lines for each as it reports progress/status of the GET and
install.

(2) If that seems to go OK and has all the GET requests in my screen shot,
try copying the ApplicationDesigner directory to your local disk drive
(e.g., C:\AppDesigner ). And running grunt from there. It may be that
there is a problem running grunt from a directory that is under a roaming
profile.

On Tue, Sep 2, 2014 at 12:31 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear I downloaded the latest version of Application designer from
http://opendatakit.org/downloads/download-info/odk-applicationdeveloper-v2-0-alpha-1-zip/

npm install goes same as mentioned in your pic. My result is also
attached.

Still when i open in chrome with developer mode, it does not display any
thing and no directory is listed.

On Tue, Sep 2, 2014 at 11:49 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Thank a million dear for such a detailed help. I will try and come back
to you.

Thank you again

On Tue, Sep 2, 2014 at 11:39 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

Ok.

Please verify that you have the latest ODK ApplicationDesigner
download. I updated this, and the simpledemo zip, late last week, so you
might not have the very latest.

Then download and install fsum.exe ( http://www.slavasoft.com/fsum/ )
and type:

fsum -sha256 "ODK ApplicationDesigner v2.0 rev 122 full.zip"

(or whatever your downloaded filename is for the zip file), then you
should see:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:18:28
;

4779d02f8f1f13c8a05987c0d260cc8d5ecfd882be9880a1c4bb9a4fd0dc57eb
?SHA256
ODK ApplicationDesigner v2.0 rev 122 full(1).zip*
and the big number 4779... should match -- if not, then you have a
different version of the zip file than is on the site.

If you are trying to follow the getting started guide, then the fsum
-sha265 output for the simpledemo zip file is:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:30:13
;

b86c2803310f6506852489bd693840d396ecfd8cf781a10f8eaf35eab3e09144
?SHA256
ODK ApplicationDesigner v2.0 rev 122 simpledemo(2).zip*


Assuming you have the most current versions of these, and have unzipped
it...

In a cmd window, type:

npm install -g grunt-cli

to confirm the install of grunt. You should see output similar to that
shown on the npm_install_ok.png (attached).

If you get anything that is not an "npm http 200..." then that is a
problem.

If that is all correct, then,

(1) Run the grunt command in the unzipped ApplicationDesigner directory
( the one containing the Gruntfile.js )

(2) open Chrome

(3) go to its Menu / Tools / Developer Tools

(4) Make sure the Chrome developer console is showing in the bottom of
your Chrome window or is in a seperate window.

Now change the URL in the Chrome browser to

localhost:8000

This should display directory contents. E.g., see attached
localhost_8000.png image.

On Tue, Sep 2, 2014 at 11:12 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear,

I get the same

TCP 127.0.0.1:8000 http://127.0.0.1:8000/
QADEER:0 LISTENING [node.exe]

On Tue, Sep 2, 2014 at 11:00 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can be
quite long, especially if you have many browser windows open. If necessary,
you can send this through 'more' to paginate the output ( netstat -ab |
more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]

The line below this line will tell you what executable is running on
port 8000. In this case, when you have a successful grunt start-up, you
would see [node.exe]

What do you see?

If you don't see any entry for port 8000, try running grunt and in
another command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost",
base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various
modules, then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

It appears likely that there is another application using port
8000 on

your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome browser
from

accessing it.

I am still in the process of updating the documentation on the
site for

the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week),
I can

work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the
Google

Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from
it, send

an email to opendatakit-developers+unsubscribe@googlegroups.com
.

For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic
in the

Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an email
to

opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to opendatakit-developers+unsubscribe@googlegroups.com
.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in
the Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Dear Mitch,

Sorry for bothering you that much. I have read line by line and I have got
all the GET requests mentioned by you plus some other GET requests.
Complete list is given below. One main thing which is different between us
is line number three npm@1.4.23 and npm@1.3.24.

Secondly I put the appDesigner in C drive directly, but still same result
(with antivirus off/on). Please help.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\appDesigner_rev122_full>npm -d install -g grunt-cli
npm info it worked if it ends with ok
npm info using npm@1.4.23
npm info using node@v0.10.31
npm info trying registry request attempt 1 at 21:39:25
npm http GET https://registry.npmjs.org/grunt-cli
https://registry.npmjs.org/grunt-cli

npm http 304 https://registry.npmjs.org/grunt-cli
npm info install grunt-cli@0.1.13 into
C:\Users\qadeer.hussnain\AppData\Roaming
npm
npm info installOne grunt-cli@0.1.13
npm info preuninstall grunt-cli@0.1.13
npm info uninstall grunt-cli@0.1.13
npm info postuninstall grunt-cli@0.1.13
npm info preinstall grunt-cli@0.1.13
npm info trying registry request attempt 1 at 21:39:28
npm http GET https://registry.npmjs.org/findup-sync
https://registry.npmjs.org/findup-sync

npm info trying registry request attempt 1 at 21:39:28
npm http GET https://registry.npmjs.org/nopt
https://registry.npmjs.org/nopt

npm info trying registry request attempt 1 at 21:39:28
npm http GET https://registry.npmjs.org/resolve
https://registry.npmjs.org/resolve

npm http 304 https://registry.npmjs.org/findup-sync
npm http 304 https://registry.npmjs.org/nopt
npm http 304 https://registry.npmjs.org/resolve
npm info install findup-sync@0.1.3 into
C:\Users\qadeer.hussnain\AppData\Roaming
\npm\node_modules\grunt-cli
npm info install resolve@0.3.1 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
\node_modules\grunt-cli
npm info install nopt@1.0.10 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm\n
ode_modules\grunt-cli
npm info installOne findup-sync@0.1.3
npm info installOne resolve@0.3.1
npm info installOne nopt@1.0.10
npm info preinstall findup-sync@0.1.3
npm info preinstall nopt@1.0.10
npm info trying registry request attempt 1 at 21:39:29
npm http GET https://registry.npmjs.org/abbrev
https://registry.npmjs.org/abbrev

npm info trying registry request attempt 1 at 21:39:29
npm http GET https://registry.npmjs.org/lodash
https://registry.npmjs.org/lodash

npm info preinstall resolve@0.3.1
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\resolve
npm info linkStuff resolve@0.3.1
npm info trying registry request attempt 1 at 21:39:29
npm http GET https://registry.npmjs.org/glob
https://registry.npmjs.org/glob

npm info install resolve@0.3.1
npm info postinstall resolve@0.3.1
npm http 304 https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/abbrev
npm http 304 https://registry.npmjs.org/glob
npm info install lodash@2.4.1 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
node_modules\grunt-cli\node_modules\findup-sync
npm info install glob@3.2.11 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm\n
ode_modules\grunt-cli\node_modules\findup-sync
npm info installOne lodash@2.4.1
npm info installOne glob@3.2.11
npm info install abbrev@1.0.5 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
node_modules\grunt-cli\node_modules\nopt
npm info installOne abbrev@1.0.5
npm info preinstall abbrev@1.0.5
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\nopt\node_modules\abbrev
npm info linkStuff abbrev@1.0.5
npm info install abbrev@1.0.5
npm info postinstall abbrev@1.0.5
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\nopt
npm info linkStuff nopt@1.0.10
npm info install nopt@1.0.10
npm info postinstall nopt@1.0.10
npm info preinstall glob@3.2.11
npm info trying registry request attempt 1 at 21:39:31
npm http GET https://registry.npmjs.org/inherits
https://registry.npmjs.org/inherits

npm info trying registry request attempt 1 at 21:39:31
npm http GET https://registry.npmjs.org/minimatch
https://registry.npmjs.org/minimatch

npm info preinstall lodash@2.4.1
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\lodash
npm info linkStuff lodash@2.4.1
npm info install lodash@2.4.1
npm info postinstall lodash@2.4.1
npm http 304 https://registry.npmjs.org/inherits
npm http 304 https://registry.npmjs.org/minimatch
npm info install minimatch@0.3.0 into
C:\Users\qadeer.hussnain\AppData\Roaming\n
pm\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob
npm info install inherits@2.0.1 into
C:\Users\qadeer.hussnain\AppData\Roaming\np
m\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob
npm info installOne minimatch@0.3.0
npm info installOne inherits@2.0.1
npm info preinstall inherits@2.0.1
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob\node_modules\inherits
npm info linkStuff inherits@2.0.1
npm info install inherits@2.0.1
npm info postinstall inherits@2.0.1
npm info preinstall minimatch@0.3.0
npm info trying registry request attempt 1 at 21:39:32
npm http GET https://registry.npmjs.org/lru-cache
https://registry.npmjs.org/lru-cache

npm info trying registry request attempt 1 at 21:39:32
npm http GET https://registry.npmjs.org/sigmund
https://registry.npmjs.org/sigmund

npm http 304 https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/lru-cache
npm info install sigmund@1.0.0 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob\node_modules
minimatch
npm info install lru-cache@2.5.0 into
C:\Users\qadeer.hussnain\AppData\Roaming\n
pm\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob\node_module
s\minimatch
npm info installOne sigmund@1.0.0
npm info installOne lru-cache@2.5.0
npm info preinstall sigmund@1.0.0
npm info preinstall lru-cache@2.5.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob\node_modules\minimatch\node_module
s\sigmund
npm info linkStuff sigmund@1.0.0
npm info install sigmund@1.0.0
npm info postinstall sigmund@1.0.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob\node_modules\minimatch\node_module
s\lru-cache
npm info linkStuff lru-cache@2.5.0
npm info install lru-cache@2.5.0
npm info postinstall lru-cache@2.5.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob\node_modules\minimatch
npm info linkStuff minimatch@0.3.0
npm info install minimatch@0.3.0
npm info postinstall minimatch@0.3.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob
npm info linkStuff glob@3.2.11
npm info install glob@3.2.11
npm info postinstall glob@3.2.11
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync
npm info linkStuff findup-sync@0.1.3
npm info install findup-sync@0.1.3
npm info postinstall findup-sync@0.1.3
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li
npm info linkStuff grunt-cli@0.1.13
C:\Users\qadeer.hussnain\AppData\Roaming\npm\grunt ->
C:\Users\qadeer.hussnain\A
ppData\Roaming\npm\node_modules\grunt-cli\bin\grunt
npm info install grunt-cli@0.1.13
npm info postinstall grunt-cli@0.1.13
grunt-cli@0.1.13
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt
-cli
├── resolve@0.3.1
├── nopt@1.0.10 (abbrev@1.0.5)
└── findup-sync@0.1.3 (lodash@2.4.1, glob@3.2.11)
npm info ok

C:\appDesigner_rev122_full>

··· On Wed, Sep 3, 2014 at 5:20 AM, Mitch Sundt wrote:

Attached are two screen shots of what my npm -d install -g grunt-cli
command generates.

On Tue, Sep 2, 2014 at 1:20 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

(1) I'd like to get more debugging information on the npm command. Try
this:

*npm -d install -g grunt-cli *
You should see all the GET requests that I had in my original screen
shot, and a few more lines for each as it reports progress/status of the
GET and install.

(2) If that seems to go OK and has all the GET requests in my screen
shot, try copying the ApplicationDesigner directory to your local disk
drive (e.g., C:\AppDesigner ). And running grunt from there. It may be
that there is a problem running grunt from a directory that is under a
roaming profile.

On Tue, Sep 2, 2014 at 12:31 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear I downloaded the latest version of Application designer from
http://opendatakit.org/downloads/download-info/odk-applicationdeveloper-v2-0-alpha-1-zip/

npm install goes same as mentioned in your pic. My result is also
attached.

Still when i open in chrome with developer mode, it does not display any
thing and no directory is listed.

On Tue, Sep 2, 2014 at 11:49 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Thank a million dear for such a detailed help. I will try and come back
to you.

Thank you again

On Tue, Sep 2, 2014 at 11:39 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

Ok.

Please verify that you have the latest ODK ApplicationDesigner
download. I updated this, and the simpledemo zip, late last week, so you
might not have the very latest.

Then download and install fsum.exe ( http://www.slavasoft.com/fsum/
) and type:

fsum -sha256 "ODK ApplicationDesigner v2.0 rev 122 full.zip"

(or whatever your downloaded filename is for the zip file), then you
should see:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:18:28
;

4779d02f8f1f13c8a05987c0d260cc8d5ecfd882be9880a1c4bb9a4fd0dc57eb
?SHA256
ODK ApplicationDesigner v2.0 rev 122 full(1).zip*
and the big number 4779... should match -- if not, then you have a
different version of the zip file than is on the site.

If you are trying to follow the getting started guide, then the fsum
-sha265 output for the simpledemo zip file is:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:30:13
;

b86c2803310f6506852489bd693840d396ecfd8cf781a10f8eaf35eab3e09144
?SHA256
ODK ApplicationDesigner v2.0 rev 122 simpledemo(2).zip*


Assuming you have the most current versions of these, and have
unzipped it...

In a cmd window, type:

npm install -g grunt-cli

to confirm the install of grunt. You should see output similar to
that shown on the npm_install_ok.png (attached).

If you get anything that is not an "npm http 200..." then that is a
problem.

If that is all correct, then,

(1) Run the grunt command in the unzipped ApplicationDesigner
directory ( the one containing the Gruntfile.js )

(2) open Chrome

(3) go to its Menu / Tools / Developer Tools

(4) Make sure the Chrome developer console is showing in the bottom of
your Chrome window or is in a seperate window.

Now change the URL in the Chrome browser to

localhost:8000

This should display directory contents. E.g., see attached
localhost_8000.png image.

On Tue, Sep 2, 2014 at 11:12 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear,

I get the same

TCP 127.0.0.1:8000 http://127.0.0.1:8000/
QADEER:0 LISTENING [node.exe]

On Tue, Sep 2, 2014 at 11:00 PM, Mitch Sundt <mitchellsundt@gmail.com wrote:

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can be
quite long, especially if you have many browser windows open. If necessary,
you can send this through 'more' to paginate the output ( netstat -ab |
more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]

The line below this line will tell you what executable is running on
port 8000. In this case, when you have a successful grunt start-up, you
would see [node.exe]

What do you see?

If you don't see any entry for port 8000, try running grunt and in
another command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost",
base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various
modules, then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

It appears likely that there is another application using port
8000 on

your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome browser
from

accessing it.

I am still in the process of updating the documentation on the
site for

the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next
week), I can

work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the
Google

Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from
it, send

an email to
opendatakit-developers+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic
in the

Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an email
to

opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in
the Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Another thing to try is to set an explicit open access for port 8000 and
35729 in your firewall. This should be automatically done, but perhaps
your security settings are very constrained.

Open Control Panel

Open Windows Firewall

Click Advanced Settings

------setting an outbound rule-----
Click Outbound Rules

Right-click, New Rule...

Choose Port, Next

Choose All remote ports, Next

Choose Allow the connection, Next

Choose all profiles, Next

Name "Port 8000 and 35729 opened for nodejs", Next

Select this rule in the list of outbound rules,

Right-click Properties

Choose the Protocols and Ports tab

Local Port: select Specific Port

Enter 8000, 35729

Click Apply

Choose the Scope tab

Remote IP Address - choose "These IP Addresses"

Choose Add...

Select "This IP Address or subnet..." (the default selection)

Enter 127.0.0.1

OK (closing the IP Address pop-up)

Click Apply

Click OK to close the outbound rule.

----setting an inbound rule-------
Click on "Inbound Rules"

Right-click, New Rule...

Choose port, Next

Choose Specific local ports

Enter 8000, 35729

Click Next

Choose Allow the connection

Choose all profiles, Next

Name: "Port 8000 and 35729 for nodejs server"

Click OK.

Select this rule in the list of inbound rules

Right-click, Properties

Choose the "Scope" tab

Remote IP Address: choose "These IP Addresses"

Choose Add...

Choose "This IP address or subnet..."

Enter 127.0.0.1

Click OK (to close the IP Address pop-up)

Click OK (to close the inbound rule dialog)

··· --------------------

Now try running grunt.

Does this change anything?

On Wed, Sep 3, 2014 at 3:29 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear Mitch,

Sorry for bothering you that much. I have read line by line and I have got
all the GET requests mentioned by you plus some other GET requests.
Complete list is given below. One main thing which is different between us
is line number three npm@1.4.23 and npm@1.3.24.

Secondly I put the appDesigner in C drive directly, but still same result
(with antivirus off/on). Please help.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\appDesigner_rev122_full>npm -d install -g grunt-cli
npm info it worked if it ends with ok
npm info using npm@1.4.23
npm info using node@v0.10.31
npm info trying registry request attempt 1 at 21:39:25
npm http GET https://registry.npmjs.org/grunt-cli
https://registry.npmjs.org/grunt-cli

npm http 304 https://registry.npmjs.org/grunt-cli
npm info install grunt-cli@0.1.13 into
C:\Users\qadeer.hussnain\AppData\Roaming
npm
npm info installOne grunt-cli@0.1.13
npm info preuninstall grunt-cli@0.1.13
npm info uninstall grunt-cli@0.1.13
npm info postuninstall grunt-cli@0.1.13
npm info preinstall grunt-cli@0.1.13
npm info trying registry request attempt 1 at 21:39:28
npm http GET https://registry.npmjs.org/findup-sync
https://registry.npmjs.org/findup-sync

npm info trying registry request attempt 1 at 21:39:28
npm http GET https://registry.npmjs.org/nopt
https://registry.npmjs.org/nopt

npm info trying registry request attempt 1 at 21:39:28
npm http GET https://registry.npmjs.org/resolve
https://registry.npmjs.org/resolve

npm http 304 https://registry.npmjs.org/findup-sync
npm http 304 https://registry.npmjs.org/nopt
npm http 304 https://registry.npmjs.org/resolve
npm info install findup-sync@0.1.3 into
C:\Users\qadeer.hussnain\AppData\Roaming
\npm\node_modules\grunt-cli
npm info install resolve@0.3.1 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
\node_modules\grunt-cli
npm info install nopt@1.0.10 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm\n
ode_modules\grunt-cli
npm info installOne findup-sync@0.1.3
npm info installOne resolve@0.3.1
npm info installOne nopt@1.0.10
npm info preinstall findup-sync@0.1.3
npm info preinstall nopt@1.0.10
npm info trying registry request attempt 1 at 21:39:29
npm http GET https://registry.npmjs.org/abbrev
https://registry.npmjs.org/abbrev

npm info trying registry request attempt 1 at 21:39:29
npm http GET https://registry.npmjs.org/lodash
https://registry.npmjs.org/lodash

npm info preinstall resolve@0.3.1
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\resolve
npm info linkStuff resolve@0.3.1
npm info trying registry request attempt 1 at 21:39:29
npm http GET https://registry.npmjs.org/glob
https://registry.npmjs.org/glob

npm info install resolve@0.3.1
npm info postinstall resolve@0.3.1
npm http 304 https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/abbrev
npm http 304 https://registry.npmjs.org/glob
npm info install lodash@2.4.1 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
node_modules\grunt-cli\node_modules\findup-sync
npm info install glob@3.2.11 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm\n
ode_modules\grunt-cli\node_modules\findup-sync
npm info installOne lodash@2.4.1
npm info installOne glob@3.2.11
npm info install abbrev@1.0.5 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
node_modules\grunt-cli\node_modules\nopt
npm info installOne abbrev@1.0.5
npm info preinstall abbrev@1.0.5
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\nopt\node_modules\abbrev
npm info linkStuff abbrev@1.0.5
npm info install abbrev@1.0.5
npm info postinstall abbrev@1.0.5
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\nopt
npm info linkStuff nopt@1.0.10
npm info install nopt@1.0.10
npm info postinstall nopt@1.0.10
npm info preinstall glob@3.2.11
npm info trying registry request attempt 1 at 21:39:31
npm http GET https://registry.npmjs.org/inherits
https://registry.npmjs.org/inherits

npm info trying registry request attempt 1 at 21:39:31
npm http GET https://registry.npmjs.org/minimatch
https://registry.npmjs.org/minimatch

npm info preinstall lodash@2.4.1
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\lodash
npm info linkStuff lodash@2.4.1
npm info install lodash@2.4.1
npm info postinstall lodash@2.4.1
npm http 304 https://registry.npmjs.org/inherits
npm http 304 https://registry.npmjs.org/minimatch
npm info install minimatch@0.3.0 into
C:\Users\qadeer.hussnain\AppData\Roaming\n
pm\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob
npm info install inherits@2.0.1 into
C:\Users\qadeer.hussnain\AppData\Roaming\np
m\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob
npm info installOne minimatch@0.3.0
npm info installOne inherits@2.0.1
npm info preinstall inherits@2.0.1
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob\node_modules\inherits
npm info linkStuff inherits@2.0.1
npm info install inherits@2.0.1
npm info postinstall inherits@2.0.1
npm info preinstall minimatch@0.3.0
npm info trying registry request attempt 1 at 21:39:32
npm http GET https://registry.npmjs.org/lru-cache
https://registry.npmjs.org/lru-cache

npm info trying registry request attempt 1 at 21:39:32
npm http GET https://registry.npmjs.org/sigmund
https://registry.npmjs.org/sigmund

npm http 304 https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/lru-cache
npm info install sigmund@1.0.0 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm

\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob\node_modules
minimatch
npm info install lru-cache@2.5.0 into
C:\Users\qadeer.hussnain\AppData\Roaming\n

pm\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob\node_module
s\minimatch
npm info installOne sigmund@1.0.0
npm info installOne lru-cache@2.5.0
npm info preinstall sigmund@1.0.0
npm info preinstall lru-cache@2.5.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c

li\node_modules\findup-sync\node_modules\glob\node_modules\minimatch\node_module
s\sigmund
npm info linkStuff sigmund@1.0.0
npm info install sigmund@1.0.0
npm info postinstall sigmund@1.0.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c

li\node_modules\findup-sync\node_modules\glob\node_modules\minimatch\node_module
s\lru-cache
npm info linkStuff lru-cache@2.5.0
npm info install lru-cache@2.5.0
npm info postinstall lru-cache@2.5.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob\node_modules\minimatch
npm info linkStuff minimatch@0.3.0
npm info install minimatch@0.3.0
npm info postinstall minimatch@0.3.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob
npm info linkStuff glob@3.2.11
npm info install glob@3.2.11
npm info postinstall glob@3.2.11
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync
npm info linkStuff findup-sync@0.1.3
npm info install findup-sync@0.1.3
npm info postinstall findup-sync@0.1.3
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li
npm info linkStuff grunt-cli@0.1.13
C:\Users\qadeer.hussnain\AppData\Roaming\npm\grunt ->
C:\Users\qadeer.hussnain\A
ppData\Roaming\npm\node_modules\grunt-cli\bin\grunt
npm info install grunt-cli@0.1.13
npm info postinstall grunt-cli@0.1.13
grunt-cli@0.1.13
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt
-cli
├── resolve@0.3.1
├── nopt@1.0.10 (abbrev@1.0.5)
└── findup-sync@0.1.3 (lodash@2.4.1, glob@3.2.11)
npm info ok

C:\appDesigner_rev122_full>

On Wed, Sep 3, 2014 at 5:20 AM, Mitch Sundt mitchellsundt@gmail.com wrote:

Attached are two screen shots of what my npm -d install -g grunt-cli
command generates.

On Tue, Sep 2, 2014 at 1:20 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

(1) I'd like to get more debugging information on the npm command. Try
this:

*npm -d install -g grunt-cli *
You should see all the GET requests that I had in my original screen
shot, and a few more lines for each as it reports progress/status of the
GET and install.

(2) If that seems to go OK and has all the GET requests in my screen
shot, try copying the ApplicationDesigner directory to your local disk
drive (e.g., C:\AppDesigner ). And running grunt from there. It may be
that there is a problem running grunt from a directory that is under a
roaming profile.

On Tue, Sep 2, 2014 at 12:31 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear I downloaded the latest version of Application designer from
http://opendatakit.org/downloads/download-info/odk-applicationdeveloper-v2-0-alpha-1-zip/

npm install goes same as mentioned in your pic. My result is also
attached.

Still when i open in chrome with developer mode, it does not display
any thing and no directory is listed.

On Tue, Sep 2, 2014 at 11:49 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Thank a million dear for such a detailed help. I will try and come
back to you.

Thank you again

On Tue, Sep 2, 2014 at 11:39 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

Ok.

Please verify that you have the latest ODK ApplicationDesigner
download. I updated this, and the simpledemo zip, late last week, so you
might not have the very latest.

Then download and install fsum.exe ( http://www.slavasoft.com/fsum/
) and type:

fsum -sha256 "ODK ApplicationDesigner v2.0 rev 122 full.zip"

(or whatever your downloaded filename is for the zip file), then you
should see:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:18:28
;

4779d02f8f1f13c8a05987c0d260cc8d5ecfd882be9880a1c4bb9a4fd0dc57eb
?SHA256
ODK ApplicationDesigner v2.0 rev 122 full(1).zip*
and the big number 4779... should match -- if not, then you have a
different version of the zip file than is on the site.

If you are trying to follow the getting started guide, then the fsum
-sha265 output for the simpledemo zip file is:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:30:13
;

b86c2803310f6506852489bd693840d396ecfd8cf781a10f8eaf35eab3e09144
?SHA256
ODK ApplicationDesigner v2.0 rev 122 simpledemo(2).zip*


Assuming you have the most current versions of these, and have
unzipped it...

In a cmd window, type:

npm install -g grunt-cli

to confirm the install of grunt. You should see output similar to
that shown on the npm_install_ok.png (attached).

If you get anything that is not an "npm http 200..." then that is a
problem.

If that is all correct, then,

(1) Run the grunt command in the unzipped ApplicationDesigner
directory ( the one containing the Gruntfile.js )

(2) open Chrome

(3) go to its Menu / Tools / Developer Tools

(4) Make sure the Chrome developer console is showing in the bottom
of your Chrome window or is in a seperate window.

Now change the URL in the Chrome browser to

localhost:8000

This should display directory contents. E.g., see attached
localhost_8000.png image.

On Tue, Sep 2, 2014 at 11:12 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear,

I get the same

TCP 127.0.0.1:8000 http://127.0.0.1:8000/
QADEER:0 LISTENING [node.exe]

On Tue, Sep 2, 2014 at 11:00 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can be
quite long, especially if you have many browser windows open. If necessary,
you can send this through 'more' to paginate the output ( netstat -ab |
more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]

The line below this line will tell you what executable is running
on port 8000. In this case, when you have a successful grunt start-up, you
would see [node.exe]

What do you see?

If you don't see any entry for port 8000, try running grunt and in
another command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost",
base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various
modules, then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

It appears likely that there is another application using port
8000 on

your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome
browser from

accessing it.

I am still in the process of updating the documentation on the
site for

the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next
week), I can

work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the
Google

Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from
it, send

an email to
opendatakit-developers+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic
in the

Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an
email to

opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in
the Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to opendatakit-developers+unsubscribe@googlegroups.com
.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in
the Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

And another thing to try -- place the following file (test.html) in the
directory containing the Gruntfile.js

Run grunt, and, in the chrome browser, try to open localhost:8000/test.html

It should open and show:

test.html (541 Bytes)

··· =============== Dead Simple Test Page

If you can see this, at least nodejs is vending pages.

If it does display, this would indicate that the problem is in the content
of the index.html file.

Mitch

On Thu, Sep 4, 2014 at 9:00 AM, Mitch Sundt mitchellsundt@gmail.com wrote:

Another thing to try is to set an explicit open access for port 8000 and
35729 in your firewall. This should be automatically done, but perhaps
your security settings are very constrained.

Open Control Panel

Open Windows Firewall

Click Advanced Settings

------setting an outbound rule-----
Click Outbound Rules

Right-click, New Rule...

Choose Port, Next

Choose All remote ports, Next

Choose Allow the connection, Next

Choose all profiles, Next

Name "Port 8000 and 35729 opened for nodejs", Next

Select this rule in the list of outbound rules,

Right-click Properties

Choose the Protocols and Ports tab

Local Port: select Specific Port

Enter 8000, 35729

Click Apply

Choose the Scope tab

Remote IP Address - choose "These IP Addresses"

Choose Add...

Select "This IP Address or subnet..." (the default selection)

Enter 127.0.0.1

OK (closing the IP Address pop-up)

Click Apply

Click OK to close the outbound rule.

----setting an inbound rule-------
Click on "Inbound Rules"

Right-click, New Rule...

Choose port, Next

Choose Specific local ports

Enter 8000, 35729

Click Next

Choose Allow the connection

Choose all profiles, Next

Name: "Port 8000 and 35729 for nodejs server"

Click OK.

Select this rule in the list of inbound rules

Right-click, Properties

Choose the "Scope" tab

Remote IP Address: choose "These IP Addresses"

Choose Add...

Choose "This IP address or subnet..."

Enter 127.0.0.1

Click OK (to close the IP Address pop-up)

Click OK (to close the inbound rule dialog)


Now try running grunt.

Does this change anything?

On Wed, Sep 3, 2014 at 3:29 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear Mitch,

Sorry for bothering you that much. I have read line by line and I have
got all the GET requests mentioned by you plus some other GET requests.
Complete list is given below. One main thing which is different between us
is line number three npm@1.4.23 and npm@1.3.24.

Secondly I put the appDesigner in C drive directly, but still same result
(with antivirus off/on). Please help.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\appDesigner_rev122_full>npm -d install -g grunt-cli
npm info it worked if it ends with ok
npm info using npm@1.4.23
npm info using node@v0.10.31
npm info trying registry request attempt 1 at 21:39:25
npm http GET https://registry.npmjs.org/grunt-cli
https://registry.npmjs.org/grunt-cli

npm http 304 https://registry.npmjs.org/grunt-cli
npm info install grunt-cli@0.1.13 into
C:\Users\qadeer.hussnain\AppData\Roaming
npm
npm info installOne grunt-cli@0.1.13
npm info preuninstall grunt-cli@0.1.13
npm info uninstall grunt-cli@0.1.13
npm info postuninstall grunt-cli@0.1.13
npm info preinstall grunt-cli@0.1.13
npm info trying registry request attempt 1 at 21:39:28
npm http GET https://registry.npmjs.org/findup-sync
https://registry.npmjs.org/findup-sync

npm info trying registry request attempt 1 at 21:39:28
npm http GET https://registry.npmjs.org/nopt
https://registry.npmjs.org/nopt

npm info trying registry request attempt 1 at 21:39:28
npm http GET https://registry.npmjs.org/resolve
https://registry.npmjs.org/resolve

npm http 304 https://registry.npmjs.org/findup-sync
npm http 304 https://registry.npmjs.org/nopt
npm http 304 https://registry.npmjs.org/resolve
npm info install findup-sync@0.1.3 into
C:\Users\qadeer.hussnain\AppData\Roaming
\npm\node_modules\grunt-cli
npm info install resolve@0.3.1 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
\node_modules\grunt-cli
npm info install nopt@1.0.10 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm\n
ode_modules\grunt-cli
npm info installOne findup-sync@0.1.3
npm info installOne resolve@0.3.1
npm info installOne nopt@1.0.10
npm info preinstall findup-sync@0.1.3
npm info preinstall nopt@1.0.10
npm info trying registry request attempt 1 at 21:39:29
npm http GET https://registry.npmjs.org/abbrev
https://registry.npmjs.org/abbrev

npm info trying registry request attempt 1 at 21:39:29
npm http GET https://registry.npmjs.org/lodash
https://registry.npmjs.org/lodash

npm info preinstall resolve@0.3.1
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\resolve
npm info linkStuff resolve@0.3.1
npm info trying registry request attempt 1 at 21:39:29
npm http GET https://registry.npmjs.org/glob
https://registry.npmjs.org/glob

npm info install resolve@0.3.1
npm info postinstall resolve@0.3.1
npm http 304 https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/abbrev
npm http 304 https://registry.npmjs.org/glob
npm info install lodash@2.4.1 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
node_modules\grunt-cli\node_modules\findup-sync
npm info install glob@3.2.11 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm\n
ode_modules\grunt-cli\node_modules\findup-sync
npm info installOne lodash@2.4.1
npm info installOne glob@3.2.11
npm info install abbrev@1.0.5 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm
node_modules\grunt-cli\node_modules\nopt
npm info installOne abbrev@1.0.5
npm info preinstall abbrev@1.0.5
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\nopt\node_modules\abbrev
npm info linkStuff abbrev@1.0.5
npm info install abbrev@1.0.5
npm info postinstall abbrev@1.0.5
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\nopt
npm info linkStuff nopt@1.0.10
npm info install nopt@1.0.10
npm info postinstall nopt@1.0.10
npm info preinstall glob@3.2.11
npm info trying registry request attempt 1 at 21:39:31
npm http GET https://registry.npmjs.org/inherits
https://registry.npmjs.org/inherits

npm info trying registry request attempt 1 at 21:39:31
npm http GET https://registry.npmjs.org/minimatch
https://registry.npmjs.org/minimatch

npm info preinstall lodash@2.4.1
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\lodash
npm info linkStuff lodash@2.4.1
npm info install lodash@2.4.1
npm info postinstall lodash@2.4.1
npm http 304 https://registry.npmjs.org/inherits
npm http 304 https://registry.npmjs.org/minimatch
npm info install minimatch@0.3.0 into
C:\Users\qadeer.hussnain\AppData\Roaming\n
pm\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob
npm info install inherits@2.0.1 into
C:\Users\qadeer.hussnain\AppData\Roaming\np
m\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob
npm info installOne minimatch@0.3.0
npm info installOne inherits@2.0.1
npm info preinstall inherits@2.0.1
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob\node_modules\inherits
npm info linkStuff inherits@2.0.1
npm info install inherits@2.0.1
npm info postinstall inherits@2.0.1
npm info preinstall minimatch@0.3.0
npm info trying registry request attempt 1 at 21:39:32
npm http GET https://registry.npmjs.org/lru-cache
https://registry.npmjs.org/lru-cache

npm info trying registry request attempt 1 at 21:39:32
npm http GET https://registry.npmjs.org/sigmund
https://registry.npmjs.org/sigmund

npm http 304 https://registry.npmjs.org/sigmund
npm http 304 https://registry.npmjs.org/lru-cache
npm info install sigmund@1.0.0 into
C:\Users\qadeer.hussnain\AppData\Roaming\npm

\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob\node_modules
minimatch
npm info install lru-cache@2.5.0 into
C:\Users\qadeer.hussnain\AppData\Roaming\n

pm\node_modules\grunt-cli\node_modules\findup-sync\node_modules\glob\node_module
s\minimatch
npm info installOne sigmund@1.0.0
npm info installOne lru-cache@2.5.0
npm info preinstall sigmund@1.0.0
npm info preinstall lru-cache@2.5.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c

li\node_modules\findup-sync\node_modules\glob\node_modules\minimatch\node_module
s\sigmund
npm info linkStuff sigmund@1.0.0
npm info install sigmund@1.0.0
npm info postinstall sigmund@1.0.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c

li\node_modules\findup-sync\node_modules\glob\node_modules\minimatch\node_module
s\lru-cache
npm info linkStuff lru-cache@2.5.0
npm info install lru-cache@2.5.0
npm info postinstall lru-cache@2.5.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob\node_modules\minimatch
npm info linkStuff minimatch@0.3.0
npm info install minimatch@0.3.0
npm info postinstall minimatch@0.3.0
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync\node_modules\glob
npm info linkStuff glob@3.2.11
npm info install glob@3.2.11
npm info postinstall glob@3.2.11
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li\node_modules\findup-sync
npm info linkStuff findup-sync@0.1.3
npm info install findup-sync@0.1.3
npm info postinstall findup-sync@0.1.3
npm info build
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt-c
li
npm info linkStuff grunt-cli@0.1.13
C:\Users\qadeer.hussnain\AppData\Roaming\npm\grunt ->
C:\Users\qadeer.hussnain\A
ppData\Roaming\npm\node_modules\grunt-cli\bin\grunt
npm info install grunt-cli@0.1.13
npm info postinstall grunt-cli@0.1.13
grunt-cli@0.1.13
C:\Users\qadeer.hussnain\AppData\Roaming\npm\node_modules\grunt
-cli
├── resolve@0.3.1
├── nopt@1.0.10 (abbrev@1.0.5)
└── findup-sync@0.1.3 (lodash@2.4.1, glob@3.2.11)
npm info ok

C:\appDesigner_rev122_full>

On Wed, Sep 3, 2014 at 5:20 AM, Mitch Sundt mitchellsundt@gmail.com wrote:

Attached are two screen shots of what my npm -d install -g grunt-cli
command generates.

On Tue, Sep 2, 2014 at 1:20 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

(1) I'd like to get more debugging information on the npm command. Try
this:

*npm -d install -g grunt-cli *
You should see all the GET requests that I had in my original screen
shot, and a few more lines for each as it reports progress/status of the
GET and install.

(2) If that seems to go OK and has all the GET requests in my screen
shot, try copying the ApplicationDesigner directory to your local disk
drive (e.g., C:\AppDesigner ). And running grunt from there. It may be
that there is a problem running grunt from a directory that is under a
roaming profile.

On Tue, Sep 2, 2014 at 12:31 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear I downloaded the latest version of Application designer from
http://opendatakit.org/downloads/download-info/odk-applicationdeveloper-v2-0-alpha-1-zip/

npm install goes same as mentioned in your pic. My result is also
attached.

Still when i open in chrome with developer mode, it does not display
any thing and no directory is listed.

On Tue, Sep 2, 2014 at 11:49 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Thank a million dear for such a detailed help. I will try and come
back to you.

Thank you again

On Tue, Sep 2, 2014 at 11:39 PM, Mitch Sundt <mitchellsundt@gmail.com wrote:

Ok.

Please verify that you have the latest ODK ApplicationDesigner
download. I updated this, and the simpledemo zip, late last week, so you
might not have the very latest.

Then download and install fsum.exe ( http://www.slavasoft.com/fsum/
) and type:

fsum -sha256 "ODK ApplicationDesigner v2.0 rev 122 full.zip"

(or whatever your downloaded filename is for the zip file), then you
should see:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:18:28
;

4779d02f8f1f13c8a05987c0d260cc8d5ecfd882be9880a1c4bb9a4fd0dc57eb
?SHA256
ODK ApplicationDesigner v2.0 rev 122 full(1).zip*
and the big number 4779... should match -- if not, then you have a
different version of the zip file than is on the site.

If you are trying to follow the getting started guide, then the fsum
-sha265 output for the simpledemo zip file is:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:30:13
;

b86c2803310f6506852489bd693840d396ecfd8cf781a10f8eaf35eab3e09144
?SHA256
ODK ApplicationDesigner v2.0 rev 122 simpledemo(2).zip*


Assuming you have the most current versions of these, and have
unzipped it...

In a cmd window, type:

npm install -g grunt-cli

to confirm the install of grunt. You should see output similar to
that shown on the npm_install_ok.png (attached).

If you get anything that is not an "npm http 200..." then that is a
problem.

If that is all correct, then,

(1) Run the grunt command in the unzipped ApplicationDesigner
directory ( the one containing the Gruntfile.js )

(2) open Chrome

(3) go to its Menu / Tools / Developer Tools

(4) Make sure the Chrome developer console is showing in the bottom
of your Chrome window or is in a seperate window.

Now change the URL in the Chrome browser to

localhost:8000

This should display directory contents. E.g., see attached
localhost_8000.png image.

On Tue, Sep 2, 2014 at 11:12 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear,

I get the same

TCP 127.0.0.1:8000 http://127.0.0.1:8000/
QADEER:0 LISTENING [node.exe]

On Tue, Sep 2, 2014 at 11:00 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can
be quite long, especially if you have many browser windows open. If
necessary, you can send this through 'more' to paginate the output (
netstat -ab | more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]

The line below this line will tell you what executable is running
on port 8000. In this case, when you have a successful grunt start-up, you
would see [node.exe]

What do you see?

If you don't see any entry for port 8000, try running grunt and in
another command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost",
base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various
modules, then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no
files]Options:

protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

It appears likely that there is another application using
port 8000 on

your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome
browser from

accessing it.

I am still in the process of updating the documentation on
the site for

the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next
week), I can

work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the
Google

Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails
from it, send

an email to
opendatakit-developers+unsubscribe@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a
topic in the

Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an
email to

opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the
Google Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in
the Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email
to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in
the Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

I am sorry dear Mitch for creating so much hassle for you.

I have done the step but even test.html is not running. In spite of opening ports explicitly, still behavior is same.

I feel I will start this process on some other computer. May be that can resolve.

Deepest Regards

Syed,

This command will ask Grunt to do less and let us focus the file vending
task. What is your output when you run it? If you navigate to
localhost:8000 do you get the same spinning forever result?

grunt --verbose connect:livereload:keepalive

My output looks like this:

opendatakit.survey-js (development) $ grunt --verbose
connect:livereload:keepalive
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
^C

Execution Time (2014-09-04 19:54:12 UTC)
loading tasks 307ms 0%
connect:livereload:keepalive 104.8s
▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇
100%
Total 105.1s

··· On Thu, Sep 4, 2014 at 12:56 PM, wrote:

I am sorry dear Mitch for creating so much hassle for you.

I have done the step but even test.html is not running. In spite of
opening ports explicitly, still behavior is same.

I feel I will start this process on some other computer. May be that can
resolve.

Deepest Regards

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Two more things:

(1) try Sam's suggestion on the test.html page too, if the index.html page
doesn't load.

(2) try disabling indexing on this directory. To do that:

stop Grunt
open a file browser,
select the directory containing the Gruntfile.js file
right-click Properties
click on Advanced
Uncheck the "Allow files in this folder to have contents indexed in
addition to file properties"
Click OK
Choose to apply this change to this directory and all sub-directories.

Now, try running Grunt again, and see if you can open the test.html file.

··· ---------------- We are very puzzled by what is breaking and would like to try a few more things if you can continue working on this.

However, it does make sense for you to begin setting up a different
computer so you can get past this issue and on to using the 2.0 tools.

Mitch

On Thu, Sep 4, 2014 at 1:00 PM, Sam Sudar sudar.sam@gmail.com wrote:

Syed,

This command will ask Grunt to do less and let us focus the file vending
task. What is your output when you run it? If you navigate to
localhost:8000 do you get the same spinning forever result?

grunt --verbose connect:livereload:keepalive

My output looks like this:

opendatakit.survey-js (development) $ grunt --verbose
connect:livereload:keepalive
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
^C

Execution Time (2014-09-04 19:54:12 UTC)
loading tasks 307ms 0%
connect:livereload:keepalive 104.8s
▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇
100%
Total 105.1s

On Thu, Sep 4, 2014 at 12:56 PM, plannerqadeer@gmail.com wrote:

I am sorry dear Mitch for creating so much hassle for you.

I have done the step but even test.html is not running. In spite of
opening ports explicitly, still behavior is same.

I feel I will start this process on some other computer. May be that can
resolve.

Deepest Regards

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Another thing to try is this command, which will cause the server to output
what it's up to. A representative portion of the output from my run is
included below:

grunt --verbose connect:livereload:keepalive --debug

$ grunt --verbose connect:livereload:keepalive --debug
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose, --debug=1

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
[D] Task source:
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/tasks/connect.js
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
[D] server GET /index.html 304 - - 10 ms
[D] server GET /app/framework/libs/jquery.1.10.2.js 304 - - 3 ms
[D] server GET /devEnv/css/animate.css 304 - - 3 ms
etc etc

··· On Thu, Sep 4, 2014 at 3:14 PM, Mitch Sundt wrote:

Two more things:

(1) try Sam's suggestion on the test.html page too, if the index.html page
doesn't load.

(2) try disabling indexing on this directory. To do that:

stop Grunt
open a file browser,
select the directory containing the Gruntfile.js file
right-click Properties
click on Advanced
Uncheck the "Allow files in this folder to have contents indexed in
addition to file properties"
Click OK
Choose to apply this change to this directory and all sub-directories.

Now, try running Grunt again, and see if you can open the test.html file.


We are very puzzled by what is breaking and would like to try a few more
things if you can continue working on this.

However, it does make sense for you to begin setting up a different
computer so you can get past this issue and on to using the 2.0 tools.

Mitch

On Thu, Sep 4, 2014 at 1:00 PM, Sam Sudar sudar.sam@gmail.com wrote:

Syed,

This command will ask Grunt to do less and let us focus the file vending
task. What is your output when you run it? If you navigate to
localhost:8000 do you get the same spinning forever result?

grunt --verbose connect:livereload:keepalive

My output looks like this:

opendatakit.survey-js (development) $ grunt --verbose
connect:livereload:keepalive
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
^C

Execution Time (2014-09-04 19:54:12 UTC)
loading tasks 307ms 0%
connect:livereload:keepalive 104.8s
▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇
100%
Total 105.1s

On Thu, Sep 4, 2014 at 12:56 PM, plannerqadeer@gmail.com wrote:

I am sorry dear Mitch for creating so much hassle for you.

I have done the step but even test.html is not running. In spite of
opening ports explicitly, still behavior is same.

I feel I will start this process on some other computer. May be that can
resolve.

Deepest Regards

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Worked Finally.....

I run the command grunt --verbose connect:livereload:keepalive and Opened
Chrome at localhost:8000/index.html and it loaded.

Thank a lot to all the friends, specially Mitch and Sam.

I will update you on further developments.

··· On Fri, Sep 5, 2014 at 1:50 AM, Sam Sudar wrote:

Another thing to try is this command, which will cause the server to
output what it's up to. A representative portion of the output from my run
is included below:

grunt --verbose connect:livereload:keepalive --debug

$ grunt --verbose connect:livereload:keepalive --debug
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose, --debug=1

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
[D] Task source:
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/tasks/connect.js
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
[D] server GET /index.html 304 - - 10 ms
[D] server GET /app/framework/libs/jquery.1.10.2.js 304 - - 3 ms
[D] server GET /devEnv/css/animate.css 304 - - 3 ms
etc etc

On Thu, Sep 4, 2014 at 3:14 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

Two more things:

(1) try Sam's suggestion on the test.html page too, if the index.html
page doesn't load.

(2) try disabling indexing on this directory. To do that:

stop Grunt
open a file browser,
select the directory containing the Gruntfile.js file
right-click Properties
click on Advanced
Uncheck the "Allow files in this folder to have contents indexed in
addition to file properties"
Click OK
Choose to apply this change to this directory and all sub-directories.

Now, try running Grunt again, and see if you can open the test.html file.


We are very puzzled by what is breaking and would like to try a few more
things if you can continue working on this.

However, it does make sense for you to begin setting up a different
computer so you can get past this issue and on to using the 2.0 tools.

Mitch

On Thu, Sep 4, 2014 at 1:00 PM, Sam Sudar sudar.sam@gmail.com wrote:

Syed,

This command will ask Grunt to do less and let us focus the file vending
task. What is your output when you run it? If you navigate to
localhost:8000 do you get the same spinning forever result?

grunt --verbose connect:livereload:keepalive

My output looks like this:

opendatakit.survey-js (development) $ grunt --verbose
connect:livereload:keepalive
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
^C

Execution Time (2014-09-04 19:54:12 UTC)
loading tasks 307ms 0%
connect:livereload:keepalive 104.8s
▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇
100%
Total 105.1s

On Thu, Sep 4, 2014 at 12:56 PM, plannerqadeer@gmail.com wrote:

I am sorry dear Mitch for creating so much hassle for you.

I have done the step but even test.html is not running. In spite of
opening ports explicitly, still behavior is same.

I feel I will start this process on some other computer. May be that
can resolve.

Deepest Regards

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I'm glad to hear it worked, sorry for the struggles. This means the watch
task isn't running and that the page won't refresh automatically after you
save a file. You'll have to refresh manually.

··· On Fri, Sep 5, 2014 at 12:17 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Worked Finally.....

I run the command grunt --verbose connect:livereload:keepalive and Opened
Chrome at localhost:8000/index.html and it loaded.

Thank a lot to all the friends, specially Mitch and Sam.

I will update you on further developments.

On Fri, Sep 5, 2014 at 1:50 AM, Sam Sudar sudar.sam@gmail.com wrote:

Another thing to try is this command, which will cause the server to
output what it's up to. A representative portion of the output from my run
is included below:

grunt --verbose connect:livereload:keepalive --debug

$ grunt --verbose connect:livereload:keepalive --debug
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose, --debug=1

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
[D] Task source:
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/tasks/connect.js
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
[D] server GET /index.html 304 - - 10 ms
[D] server GET /app/framework/libs/jquery.1.10.2.js 304 - - 3 ms
[D] server GET /devEnv/css/animate.css 304 - - 3 ms
etc etc

On Thu, Sep 4, 2014 at 3:14 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

Two more things:

(1) try Sam's suggestion on the test.html page too, if the index.html
page doesn't load.

(2) try disabling indexing on this directory. To do that:

stop Grunt
open a file browser,
select the directory containing the Gruntfile.js file
right-click Properties
click on Advanced
Uncheck the "Allow files in this folder to have contents indexed in
addition to file properties"
Click OK
Choose to apply this change to this directory and all sub-directories.

Now, try running Grunt again, and see if you can open the test.html file.


We are very puzzled by what is breaking and would like to try a few more
things if you can continue working on this.

However, it does make sense for you to begin setting up a different
computer so you can get past this issue and on to using the 2.0 tools.

Mitch

On Thu, Sep 4, 2014 at 1:00 PM, Sam Sudar sudar.sam@gmail.com wrote:

Syed,

This command will ask Grunt to do less and let us focus the file
vending task. What is your output when you run it? If you navigate to
localhost:8000 do you get the same spinning forever result?

grunt --verbose connect:livereload:keepalive

My output looks like this:

opendatakit.survey-js (development) $ grunt --verbose
connect:livereload:keepalive
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
^C

Execution Time (2014-09-04 19:54:12 UTC)
loading tasks 307ms 0%
connect:livereload:keepalive 104.8s
▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇
100%
Total 105.1s

On Thu, Sep 4, 2014 at 12:56 PM, plannerqadeer@gmail.com wrote:

I am sorry dear Mitch for creating so much hassle for you.

I have done the step but even test.html is not running. In spite of
opening ports explicitly, still behavior is same.

I feel I will start this process on some other computer. May be that
can resolve.

Deepest Regards

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Searching for similar issues, I found this marginally-related post:
http://expertsoverflow.com/questions/25439380/live-reload-not-working-with-ember-cli

Perhaps if you uninstall node and uninstall npm, then re-install both, you
would regain the livereload capability. Live-reload is optional but very
very nice to have, as otherwise you need to remember to refresh your
browser whenever you regenerate your forms or modify any HTML or javascript
code.

You would need to search for instructions on uninstalling on Windows
systems.

--------excerpt from that post---------

Finally got live-reload working. I had to do some rigorous stuff though
which does unfort not explain what the problem was. I resolved the issue by
completely removing node and npm and then reinstalling
http://thechangelog.com/install-node-js-with-homebrew-on-os-x/ it by
running brew install node

@wenincode pointed me to a link to uninstall node
http://stackoverflow.com/questions/11177954/how-do-i-completely-uninstall-node-js-and-reinstall-from-beginning-mac-os-x/11178106#11178106
and a link to uninstall npm
https://www.npmjs.org/doc/misc/removing-npm.html

··· ===========

Mitch

On Fri, Sep 5, 2014 at 6:54 AM, Sam Sudar sudar.sam@gmail.com wrote:

I'm glad to hear it worked, sorry for the struggles. This means the watch
task isn't running and that the page won't refresh automatically after you
save a file. You'll have to refresh manually.

On Fri, Sep 5, 2014 at 12:17 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Worked Finally.....

I run the command grunt --verbose connect:livereload:keepalive and
Opened Chrome at localhost:8000/index.html and it loaded.

Thank a lot to all the friends, specially Mitch and Sam.

I will update you on further developments.

On Fri, Sep 5, 2014 at 1:50 AM, Sam Sudar sudar.sam@gmail.com wrote:

Another thing to try is this command, which will cause the server to
output what it's up to. A representative portion of the output from my run
is included below:

grunt --verbose connect:livereload:keepalive --debug

$ grunt --verbose connect:livereload:keepalive --debug
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose, --debug=1

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
[D] Task source:
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/tasks/connect.js
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
[D] server GET /index.html 304 - - 10 ms
[D] server GET /app/framework/libs/jquery.1.10.2.js 304 - - 3 ms
[D] server GET /devEnv/css/animate.css 304 - - 3 ms
etc etc

On Thu, Sep 4, 2014 at 3:14 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

Two more things:

(1) try Sam's suggestion on the test.html page too, if the index.html
page doesn't load.

(2) try disabling indexing on this directory. To do that:

stop Grunt
open a file browser,
select the directory containing the Gruntfile.js file
right-click Properties
click on Advanced
Uncheck the "Allow files in this folder to have contents indexed in
addition to file properties"
Click OK
Choose to apply this change to this directory and all sub-directories.

Now, try running Grunt again, and see if you can open the test.html
file.


We are very puzzled by what is breaking and would like to try a few
more things if you can continue working on this.

However, it does make sense for you to begin setting up a different
computer so you can get past this issue and on to using the 2.0 tools.

Mitch

On Thu, Sep 4, 2014 at 1:00 PM, Sam Sudar sudar.sam@gmail.com wrote:

Syed,

This command will ask Grunt to do less and let us focus the file
vending task. What is your output when you run it? If you navigate to
localhost:8000 do you get the same spinning forever result?

grunt --verbose connect:livereload:keepalive

My output looks like this:

opendatakit.survey-js (development) $ grunt --verbose
connect:livereload:keepalive
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
^C

Execution Time (2014-09-04 19:54:12 UTC)
loading tasks 307ms 0%
connect:livereload:keepalive 104.8s
▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇
100%
Total 105.1s

On Thu, Sep 4, 2014 at 12:56 PM, plannerqadeer@gmail.com wrote:

I am sorry dear Mitch for creating so much hassle for you.

I have done the step but even test.html is not running. In spite of
opening ports explicitly, still behavior is same.

I feel I will start this process on some other computer. May be that
can resolve.

Deepest Regards

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

FYI: I have updated the documentation here:
http://opendatakit.org/use/2_0_tools/odk-application-designer-2-0-rev122/#Launching_the_Application_Designer

to reflect this work-around, and created an issue for tracking how often
people have this problem.

··· On Fri, Sep 5, 2014 at 9:00 AM, Mitch Sundt wrote:

Searching for similar issues, I found this marginally-related post:
http://expertsoverflow.com/questions/25439380/live-reload-not-working-with-ember-cli

Perhaps if you uninstall node and uninstall npm, then re-install both, you
would regain the livereload capability. Live-reload is optional but very
very nice to have, as otherwise you need to remember to refresh your
browser whenever you regenerate your forms or modify any HTML or javascript
code.

You would need to search for instructions on uninstalling on Windows
systems.

--------excerpt from that post---------

Finally got live-reload working. I had to do some rigorous stuff though
which does unfort not explain what the problem was. I resolved the issue by
completely removing node and npm and then reinstalling
http://thechangelog.com/install-node-js-with-homebrew-on-os-x/ it by
running brew install node

@wenincode pointed me to a link to uninstall node
http://stackoverflow.com/questions/11177954/how-do-i-completely-uninstall-node-js-and-reinstall-from-beginning-mac-os-x/11178106#11178106
and a link to uninstall npm
https://www.npmjs.org/doc/misc/removing-npm.html

Mitch

On Fri, Sep 5, 2014 at 6:54 AM, Sam Sudar sudar.sam@gmail.com wrote:

I'm glad to hear it worked, sorry for the struggles. This means the watch
task isn't running and that the page won't refresh automatically after you
save a file. You'll have to refresh manually.

On Fri, Sep 5, 2014 at 12:17 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Worked Finally.....

I run the command grunt --verbose connect:livereload:keepalive and
Opened Chrome at localhost:8000/index.html and it loaded.

Thank a lot to all the friends, specially Mitch and Sam.

I will update you on further developments.

On Fri, Sep 5, 2014 at 1:50 AM, Sam Sudar sudar.sam@gmail.com wrote:

Another thing to try is this command, which will cause the server to
output what it's up to. A representative portion of the output from my run
is included below:

grunt --verbose connect:livereload:keepalive --debug

$ grunt --verbose connect:livereload:keepalive --debug
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose, --debug=1

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
[D] Task source:
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/tasks/connect.js
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
[D] server GET /index.html 304 - - 10 ms
[D] server GET /app/framework/libs/jquery.1.10.2.js 304 - - 3 ms
[D] server GET /devEnv/css/animate.css 304 - - 3 ms
etc etc

On Thu, Sep 4, 2014 at 3:14 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

Two more things:

(1) try Sam's suggestion on the test.html page too, if the index.html
page doesn't load.

(2) try disabling indexing on this directory. To do that:

stop Grunt
open a file browser,
select the directory containing the Gruntfile.js file
right-click Properties
click on Advanced
Uncheck the "Allow files in this folder to have contents indexed in
addition to file properties"
Click OK
Choose to apply this change to this directory and all sub-directories.

Now, try running Grunt again, and see if you can open the test.html
file.


We are very puzzled by what is breaking and would like to try a few
more things if you can continue working on this.

However, it does make sense for you to begin setting up a different
computer so you can get past this issue and on to using the 2.0 tools.

Mitch

On Thu, Sep 4, 2014 at 1:00 PM, Sam Sudar sudar.sam@gmail.com wrote:

Syed,

This command will ask Grunt to do less and let us focus the file
vending task. What is your output when you run it? If you navigate to
localhost:8000 do you get the same spinning forever result?

grunt --verbose connect:livereload:keepalive

My output looks like this:

opendatakit.survey-js (development) $ grunt --verbose
connect:livereload:keepalive
sudars@android-8b035dd04f66244a
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-connect/package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-contrib-watch/package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-open/package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected non-Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Parsing
/Users/sudars/Dropbox/Gaetano/code/opendatakit.survey-js/node_modules/grunt-exec/package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adbpush-scan, adbpush-survey,
    adbpush-survey-beta3-opendatakit-surveydemo, adbpush-survey-demo-beta2,
    adbpush-survey-demo-beta3, adbpush-survey-demo-bmg05152014, adbpush-tables,
    adbpush-tables-app, adbpush-tables-demo-JGI, adbpush-tables-demo-alpha2,
    addtable, default, server

Running tasks: connect:livereload:keepalive

Running "connect:livereload:keepalive" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=null, keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined
Waiting forever...
Started connect web server on http://localhost:8000
^C

Execution Time (2014-09-04 19:54:12 UTC)
loading tasks 307ms 0%
connect:livereload:keepalive 104.8s
▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇
100%
Total 105.1s

On Thu, Sep 4, 2014 at 12:56 PM, plannerqadeer@gmail.com wrote:

I am sorry dear Mitch for creating so much hassle for you.

I have done the step but even test.html is not running. In spite of
opening ports explicitly, still behavior is same.

I feel I will start this process on some other computer. May be that
can resolve.

Deepest Regards

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to opendatakit-developers+unsubscribe@googlegroups.com
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com