Need help in setting ODK Application Designer v2.0

Dear,

I am trying to establish ODK Applciation designer. I have followed the instructions given here http://opendatakit.org/use/2_0_tools/odk-application-designer-2-0-rev122/#Getting_Started and installed the required tools.

When I try to launch the application by opening cmd and run grunt. Its saying Running "open:server" task but does not open Chrome to show Preview Tab.

Please help.

image

What happens if you open Chrome yourself and open the page (
http://localhost:8000/index.html ) manually?

··· On Thu, Aug 28, 2014 at 12:56 AM, wrote:

Dear,

I am trying to establish ODK Applciation designer. I have followed the
instructions given here
http://opendatakit.org/use/2_0_tools/odk-application-designer-2-0-rev122/#Getting_Started
and installed the required tools.

When I try to launch the application by opening cmd and run grunt. Its
saying Running "open:server" task but does not open Chrome to show
Preview Tab.

Please help.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

I need some help please!!!

for some reason I used to make it worked out and now it is not working properly. it say "please wait.." and it never let me see ODK survey framework page in the preview. I have it installed and reinstalled everything and it does not work any way. I used before like one week ago and worked perfect but now it is not loading those. I can browse the file on file browser tab, I can only load the ODK tables graph page on the preview and the ODK tables API test Page. I am enclosing a screenshot.

Thanks for your assistance

Dear Mitch,

It just keeps on waiting for localhost and nothing opens....

If you could open up the developer tools in Chrome and send the output from
the console that would be helpful. Directions for accessing the console
can be found at https://developer.chrome.com/devtools#console.

Clarice

··· On Tue, Feb 2, 2016 at 10:51 PM, wrote:

I need some help please!!!

for some reason I used to make it worked out and now it is not working
properly. it say "please wait.." and it never let me see ODK survey
framework page in the preview. I have it installed and reinstalled
everything and it does not work any way. I used before like one week ago
and worked perfect but now it is not loading those. I can browse the file
on file browser tab, I can only load the ODK tables graph page on the
preview and the ODK tables API test Page. I am enclosing a screenshot.

Thanks for your assistance

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

The Chrome browser does not normally wait forever.

It eventually says "This webpage is not available"

Do you see that?

··· On Fri, Aug 29, 2014 at 3:18 AM, wrote:

Dear Mitch,

It just keeps on waiting for localhost and nothing opens....

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

here you go, I do not know what is the output but I am sending you a screen
shot plus some codes that I copiedd

jquery.1.10.2.js:6569 The specified value "!" does not conform to the
required format. The format is "#rrggbb" where rr, gg, bb are two-digit
hexadecimal numbers.
XRegExp-All-3.0.0-pre-2014-12-24.js:86 Uncaught TypeError:
RegExp.prototype.sticky getter called on non-RegExp object
XLSXConverter2.js:184 Uncaught ReferenceError: XRegExp is not defined
http://localhost:8000/themeGenerator/lib/images/ui-bg_highlight-soft_100_eeeeee_1x100.png
Failed to load resource: the server responded with a status of 404 (Not
Found)
http://localhost:8000/themeGenerator/lib/images/ui-bg_glass_100_f6f6f6_1x400.png
Failed to load resource: the server responded with a status of 404 (Not
Found)
http://localhost:8000/themeGenerator/lib/images/ui-icons_ef8c08_256x240.png
Failed to load resource: the server responded with a status of 404 (Not
Found)
http://localhost:8000/themeGenerator/lib/images/ui-bg_glass_65_ffffff_1x400.png
Failed to load resource: the server responded with a status of 404 (Not
Found)
shim.js:150 I/main.require.jquery.loaded establish mobileinit action
shim.js:150 I/main.require.jquery.loaded establish mobileinit action
http://localhost:8000/favicon.ico Failed to load resource: the server
responded with a status of 404 (Not Found)
5shim.js:148 E/main.require.framework.errback: define modules:
XRegExpwindow.shim.window.shim.log @ shim.js:148
5shim.js:148 E/main.require.framework.errback: define modules:
XRegExpwindow.shim.window.shim.log @ shim.js:148

Regards

··· On Wed, Feb 3, 2016 at 1:18 PM, clarice larson wrote:

If you could open up the developer tools in Chrome and send the output
from the console that would be helpful. Directions for accessing the
console can be found at https://developer.chrome.com/devtools#console.

Clarice

On Tue, Feb 2, 2016 at 10:51 PM, folivaresh@gmail.com wrote:

I need some help please!!!

for some reason I used to make it worked out and now it is not working
properly. it say "please wait.." and it never let me see ODK survey
framework page in the preview. I have it installed and reinstalled
everything and it does not work any way. I used before like one week ago
and worked perfect but now it is not loading those. I can browse the file
on file browser tab, I can only load the ODK tables graph page on the
preview and the ODK tables API test Page. I am enclosing a screenshot.

Thanks for your assistance

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Felipe Olivares
1 (775) 410-8795
+503 7940-8254

No it doesnot give this error and just keep on revolving. I am using
Windows 7. Should I try to wait for 10-15 minutes?

··· On 8/29/14, Mitch Sundt wrote: > The Chrome browser does not normally wait forever. > > It eventually says "This webpage is not available" > > Do you see that? > > > > > On Fri, Aug 29, 2014 at 3:18 AM, wrote: > >> Dear Mitch, >> >> It just keeps on waiting for localhost and nothing opens.... >> >> -- >> You received this message because you are subscribed to the Google Groups >> "ODK Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to opendatakit-developers+unsubscribe@googlegroups.com. >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitchellsundt@gmail.com > > -- > You received this message because you are subscribed to a topic in the > Google Groups "ODK Developers" group. > To unsubscribe from this topic, visit > https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe. > To unsubscribe from this group and all its topics, send an email to > opendatakit-developers+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/d/optout. >

Thank you for the data. One error that I see right away is that
XRegExp-All-3.0.0-pre-2014-12-24.js is not in the expected location. This
file should be in the xlsxconverter directory of where you unzipped ODK
ApplicationDesigner v2.0 rev 126 full.zip. The XLSXConverter2.js should
also be in this directory. I deleted the XRegExp-All-3.0.0-pre-2014-12-24.js
file from my directory to reproduce the error. I certainly got the error
you sent, but this error did not prevent my Preview pane from working as
expected.

Would it be possible for you to copy all of the output from the Chrome
console to a file and send that? Also, can you verify the checksum of the
downloaded ODK ApplicationDesigner v2.0 rev 126 full.zip file (presumably
this is the version that you are using)? You can find the correct value at
https://opendatakit.org/wp-content/uploads/sha256_signatures.txt. Finally,
are you using a Mac or a PC?

Clarice

··· On Wed, Feb 3, 2016 at 12:31 PM, Felipe Olivares wrote:

here you go, I do not know what is the output but I am sending you a
screen shot plus some codes that I copiedd

jquery.1.10.2.js:6569 The specified value "!" does not conform to the
required format. The format is "#rrggbb" where rr, gg, bb are two-digit
hexadecimal numbers.
XRegExp-All-3.0.0-pre-2014-12-24.js:86 Uncaught TypeError:
RegExp.prototype.sticky getter called on non-RegExp object
XLSXConverter2.js:184 Uncaught ReferenceError: XRegExp is not defined

http://localhost:8000/themeGenerator/lib/images/ui-bg_highlight-soft_100_eeeeee_1x100.png
Failed to load resource: the server responded with a status of 404 (Not
Found)

http://localhost:8000/themeGenerator/lib/images/ui-bg_glass_100_f6f6f6_1x400.png
Failed to load resource: the server responded with a status of 404 (Not
Found)
http://localhost:8000/themeGenerator/lib/images/ui-icons_ef8c08_256x240.png
Failed to load resource: the server responded with a status of 404 (Not
Found)

http://localhost:8000/themeGenerator/lib/images/ui-bg_glass_65_ffffff_1x400.png
Failed to load resource: the server responded with a status of 404 (Not
Found)
shim.js:150 I/main.require.jquery.loaded establish mobileinit action
shim.js:150 I/main.require.jquery.loaded establish mobileinit action
http://localhost:8000/favicon.ico Failed to load resource: the server
responded with a status of 404 (Not Found)
5shim.js:148 E/main.require.framework.errback: define modules:
XRegExpwindow.shim.window.shim.log @ shim.js:148
5shim.js:148 E/main.require.framework.errback: define modules:
XRegExpwindow.shim.window.shim.log @ shim.js:148

Regards

On Wed, Feb 3, 2016 at 1:18 PM, clarice larson clarlars@gmail.com wrote:

If you could open up the developer tools in Chrome and send the output
from the console that would be helpful. Directions for accessing the
console can be found at https://developer.chrome.com/devtools#console.

Clarice

On Tue, Feb 2, 2016 at 10:51 PM, folivaresh@gmail.com wrote:

I need some help please!!!

for some reason I used to make it worked out and now it is not working
properly. it say "please wait.." and it never let me see ODK survey
framework page in the preview. I have it installed and reinstalled
everything and it does not work any way. I used before like one week ago
and worked perfect but now it is not loading those. I can browse the file
on file browser tab, I can only load the ODK tables graph page on the
preview and the ODK tables API test Page. I am enclosing a screenshot.

Thanks for your assistance

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Felipe Olivares
1 (775) 410-8795
+503 7940-8254

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

It appears likely that there is another application using port 8000 on your
computer, or perhaps you have anti-virus software that is preventing the
grunt tool from opening that port and/or the Chrome browser from accessing
it.

I am still in the process of updating the documentation on the site for the
pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week), I can work
with you to uncover what is happening on your system.

··· On Fri, Aug 29, 2014 at 10:57 AM, wrote:

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various modules, then I
see:

Running "server" task

Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".", directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefinedStarted connect web server on http://localhost:8000
http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

··· On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt wrote:

It appears likely that there is another application using port 8000 on
your computer, or perhaps you have anti-virus software that is preventing
the grunt tool from opening that port and/or the Chrome browser from
accessing it.

I am still in the process of updating the documentation on the site for
the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week), I can
work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thanks for the help I check the sha256 and it is ok it is the same I
compare it. I am using Win8 in a Note Gateway NE56R31u. As I told you
before it used to worked fine at the begining but somehow it does not work
properly any more.

I will make a file of the output in Chrome soon. Thanks

··· On Thu, Feb 4, 2016 at 2:15 PM, clarice larson wrote:

Thank you for the data. One error that I see right away is that
XRegExp-All-3.0.0-pre-2014-12-24.js is not in the expected location. This
file should be in the xlsxconverter directory of where you unzipped ODK
ApplicationDesigner v2.0 rev 126 full.zip. The XLSXConverter2.js should
also be in this directory. I deleted the XRegExp-All-3.0.0-pre-2014-12-24.js
file from my directory to reproduce the error. I certainly got the error
you sent, but this error did not prevent my Preview pane from working as
expected.

Would it be possible for you to copy all of the output from the Chrome
console to a file and send that? Also, can you verify the checksum of the
downloaded ODK ApplicationDesigner v2.0 rev 126 full.zip file (presumably
this is the version that you are using)? You can find the correct value at
https://opendatakit.org/wp-content/uploads/sha256_signatures.txt.
Finally, are you using a Mac or a PC?

Clarice

On Wed, Feb 3, 2016 at 12:31 PM, Felipe Olivares folivaresh@gmail.com wrote:

here you go, I do not know what is the output but I am sending you a
screen shot plus some codes that I copiedd

jquery.1.10.2.js:6569 The specified value "!" does not conform to the
required format. The format is "#rrggbb" where rr, gg, bb are two-digit
hexadecimal numbers.
XRegExp-All-3.0.0-pre-2014-12-24.js:86 Uncaught TypeError:
RegExp.prototype.sticky getter called on non-RegExp object
XLSXConverter2.js:184 Uncaught ReferenceError: XRegExp is not defined

http://localhost:8000/themeGenerator/lib/images/ui-bg_highlight-soft_100_eeeeee_1x100.png
Failed to load resource: the server responded with a status of 404 (Not
Found)

http://localhost:8000/themeGenerator/lib/images/ui-bg_glass_100_f6f6f6_1x400.png
Failed to load resource: the server responded with a status of 404 (Not
Found)

http://localhost:8000/themeGenerator/lib/images/ui-icons_ef8c08_256x240.png
Failed to load resource: the server responded with a status of 404 (Not
Found)

http://localhost:8000/themeGenerator/lib/images/ui-bg_glass_65_ffffff_1x400.png
Failed to load resource: the server responded with a status of 404 (Not
Found)
shim.js:150 I/main.require.jquery.loaded establish mobileinit action
shim.js:150 I/main.require.jquery.loaded establish mobileinit action
http://localhost:8000/favicon.ico Failed to load resource: the server
responded with a status of 404 (Not Found)
5shim.js:148 E/main.require.framework.errback: define modules:
XRegExpwindow.shim.window.shim.log @ shim.js:148
5shim.js:148 E/main.require.framework.errback: define modules:
XRegExpwindow.shim.window.shim.log @ shim.js:148

Regards

On Wed, Feb 3, 2016 at 1:18 PM, clarice larson clarlars@gmail.com wrote:

If you could open up the developer tools in Chrome and send the output
from the console that would be helpful. Directions for accessing the
console can be found at https://developer.chrome.com/devtools#console.

Clarice

On Tue, Feb 2, 2016 at 10:51 PM, folivaresh@gmail.com wrote:

I need some help please!!!

for some reason I used to make it worked out and now it is not working
properly. it say "please wait.." and it never let me see ODK survey
framework page in the preview. I have it installed and reinstalled
everything and it does not work any way. I used before like one week ago
and worked perfect but now it is not loading those. I can browse the file
on file browser tab, I can only load the ODK tables graph page on the
preview and the ODK tables API test Page. I am enclosing a screenshot.

Thanks for your assistance

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Felipe Olivares
1 (775) 410-8795
+503 7940-8254

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Felipe Olivares
1 (775) 410-8795
+503 7940-8254

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables, adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

··· On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various modules, then
I see:

Running "server" task

Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".", directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on http://localhost:8000
http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

It appears likely that there is another application using port 8000 on
your computer, or perhaps you have anti-virus software that is preventing
the grunt tool from opening that port and/or the Chrome browser from
accessing it.

I am still in the process of updating the documentation on the site for
the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week), I can
work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

··· On 9/2/14, Syed Muhammad Qadeer wrote: > It says the following: > > > Microsoft Windows [Version 6.1.7601] > Copyright (c) 2009 Microsoft Corporation. All rights reserved. > > D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigner>grunt > --verbos > Initializing > Command-line options: --verbose > > Reading "Gruntfile.js" Gruntfile...OK > > Registering Gruntfile tasks. > > Registering "grunt-contrib-connect" local Npm module tasks. > Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-contrib-connect\package.json...OK > Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-contrib-connect\package.json...OK > Loading "connect.js" tasks...OK > + connect > > Registering "grunt-contrib-watch" local Npm module tasks. > Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-contrib-watch\package.json...OK > Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-contrib-watch\package.json...OK > Loading "watch.js" tasks...OK > + watch > > Registering "grunt-open" local Npm module tasks. > Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-open\package.json...OK > Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-open\package.json...OK > Loading "open.js" tasks...OK > + open > > Registering "grunt-exec" local Npm module tasks. > Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-exec\package.json...OK > Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-exec\package.json...OK > Loading "exec.js" tasks...OK > + exec > detected Windows environment > Initializing config...OK > > Registering "grunt-exec" local Npm module tasks. > Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-exec\package.json...OK > Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0 > Alpha-1\applicationDesigne > r\node_modules\grunt-exec\package.json...OK > Loading "exec.js" tasks...OK > + exec > Loading "Gruntfile.js" tasks...OK > + adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush, > adbpush-collect, adb > push-survey, adbpush-survey-demo-beta2, adbpush-tables, adbpush-tables-app, > adbp > ush-tables-demo-alpha2, addtable, default, server > > No tasks specified, running default tasks. > Running tasks: default > > Running "default" task > > Running "server" task > > Running "connect:livereload" (connect) task > Verifying property connect.livereload exists in config...OK > File: [no files] > Options: protocol="http", port=8000, hostname="localhost", base=".", > directory=n > ull, keepalive=false, debug=false, livereload=false, open=false, > middleware=unde > fined > Started connect web server on http://localhost:8000 > > Running "open" task > > Running "open:server" (open) task > Verifying property open.server exists in config...OK > File: [no files] > Options: (none) > > > > > > On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt wrote: > >> What happens if you start grunt with a --verbose flag: >> >> >> grunt --verbose >> >> When I do this, I see a number of lines registering various modules, then >> I see: >> >> >> Running "server" task >> >> >> >> >> >> >> *Running "connect:livereload" (connect) taskVerifying property >> connect.livereload exists in config...OKFile: [no files]Options: >> protocol="http", port=8000, hostname="localhost", base=".", >> directory=null, >> keepalive=false, debug=false, livereload=false, open=false, >> middleware=undefined Started connect web server on http://localhost:8000 >> * >> Running "open" task >> >> Running "open:server" (open) task >> Verifying property open.server exists in config...OK >> File: [no files] >> Options: (none) >> >> Running "watch" task >> Waiting...Verifying property watch exists in config...OK >> Verifying property watch.livereload.files exists in config...OK >> Verifying property watch.test.files exists in config...OK >> >> >> *Live reload server started on port: 35729Watching >> app\framework\formDef.json for changes.* >> ... >> >> What does your system report? >> >> >> >> On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt wrote: >> >>> It appears likely that there is another application using port 8000 on >>> your computer, or perhaps you have anti-virus software that is >>> preventing >>> the grunt tool from opening that port and/or the Chrome browser from >>> accessing it. >>> >>> I am still in the process of updating the documentation on the site for >>> the pending 2.0 tools release. >>> >>> Once I have the generic documentation updated (i.e., next week), I can >>> work with you to uncover what is happening on your system. >>> >>> >>> >>> On Fri, Aug 29, 2014 at 10:57 AM, wrote: >>> >>>> -- >>>> You received this message because you are subscribed to the Google >>>> Groups "ODK Developers" group. >>>> To unsubscribe from this group and stop receiving emails from it, send >>>> an email to opendatakit-developers+unsubscribe@googlegroups.com. >>>> For more options, visit https://groups.google.com/d/optout. >>>> >>> >>> >>> >>> -- >>> Mitch Sundt >>> Software Engineer >>> University of Washington >>> mitchellsundt@gmail.com >>> >> >> >> >> -- >> Mitch Sundt >> Software Engineer >> University of Washington >> mitchellsundt@gmail.com >> >> -- >> You received this message because you are subscribed to a topic in the >> Google Groups "ODK Developers" group. >> To unsubscribe from this topic, visit >> https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe >> . >> To unsubscribe from this group and all its topics, send an email to >> opendatakit-developers+unsubscribe@googlegroups.com. >> For more options, visit https://groups.google.com/d/optout. >> >

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can be quite
long, especially if you have many browser windows open. If necessary, you
can send this through 'more' to paginate the output ( netstat -ab | more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]
··· -------------- The line below this line will tell you what executable is running on port 8000. In this case, when you have a successful grunt start-up, you would see *[node.exe]*

What do you see?

If you don't see any entry for port 8000, try running grunt and in another
command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various modules,
then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

It appears likely that there is another application using port 8000 on
your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome browser from
accessing it.

I am still in the process of updating the documentation on the site for
the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week), I can
work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Dear,

I get the same

TCP 127.0.0.1:8000 http://127.0.0.1:8000/
QADEER:0 LISTENING[node.exe]

··· On Tue, Sep 2, 2014 at 11:00 PM, Mitch Sundt wrote:

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can be quite
long, especially if you have many browser windows open. If necessary, you
can send this through 'more' to paginate the output ( netstat -ab | more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]

The line below this line will tell you what executable is running on port
8000. In this case, when you have a successful grunt start-up, you would
see [node.exe]

What do you see?

If you don't see any entry for port 8000, try running grunt and in another
command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various modules,
then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt <mitchellsundt@gmail.com wrote:

It appears likely that there is another application using port 8000 on
your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome browser from
accessing it.

I am still in the process of updating the documentation on the site
for

the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week), I can
work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send

an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Ok.

Please verify that you have the latest ODK ApplicationDesigner download. I
updated this, and the simpledemo zip, late last week, so you might not have
the very latest.

Then download and install fsum.exe ( http://www.slavasoft.com/fsum/ ) and
type:

fsum -sha256 "ODK ApplicationDesigner v2.0 rev 122 full.zip"

(or whatever your downloaded filename is for the zip file), then you should
see:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <www.slavasoft.com

;
; Generated on 09/02/14 at 11:18:28
;

4779d02f8f1f13c8a05987c0d260cc8d5ecfd882be9880a1c4bb9a4fd0dc57eb
?SHA256
ODK ApplicationDesigner v2.0 rev 122 full(1).zip*
and the big number 4779... should match -- if not, then you have a
different version of the zip file than is on the site.

If you are trying to follow the getting started guide, then the fsum
-sha265 output for the simpledemo zip file is:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <www.slavasoft.com

;
; Generated on 09/02/14 at 11:30:13
;

b86c2803310f6506852489bd693840d396ecfd8cf781a10f8eaf35eab3e09144
?SHA256
ODK ApplicationDesigner v2.0 rev 122 simpledemo(2).zip*

··· ------------------- Assuming you have the most current versions of these, and have unzipped it...

In a cmd window, type:

npm install -g grunt-cli

to confirm the install of grunt. You should see output similar to that
shown on the npm_install_ok.png (attached).

If you get anything that is not an "npm http 200..." then that is a problem.

If that is all correct, then,

(1) Run the grunt command in the unzipped ApplicationDesigner directory (
the one containing the Gruntfile.js )

(2) open Chrome

(3) go to its Menu / Tools / Developer Tools

(4) Make sure the Chrome developer console is showing in the bottom of your
Chrome window or is in a seperate window.

Now change the URL in the Chrome browser to

localhost:8000

This should display directory contents. E.g., see attached
localhost_8000.png image.

On Tue, Sep 2, 2014 at 11:12 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear,

I get the same

TCP 127.0.0.1:8000 http://127.0.0.1:8000/
QADEER:0 LISTENING [node.exe]

On Tue, Sep 2, 2014 at 11:00 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can be quite
long, especially if you have many browser windows open. If necessary, you
can send this through 'more' to paginate the output ( netstat -ab | more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]

The line below this line will tell you what executable is running on port
8000. In this case, when you have a successful grunt start-up, you would
see [node.exe]

What do you see?

If you don't see any entry for port 8000, try running grunt and in
another command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various modules,
then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

It appears likely that there is another application using port 8000
on

your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome browser from
accessing it.

I am still in the process of updating the documentation on the site
for

the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week), I
can

work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send

an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thank a million dear for such a detailed help. I will try and come back to
you.

Thank you again

··· On Tue, Sep 2, 2014 at 11:39 PM, Mitch Sundt wrote:

Ok.

Please verify that you have the latest ODK ApplicationDesigner download. I
updated this, and the simpledemo zip, late last week, so you might not have
the very latest.

Then download and install fsum.exe ( http://www.slavasoft.com/fsum/ )
and type:

fsum -sha256 "ODK ApplicationDesigner v2.0 rev 122 full.zip"

(or whatever your downloaded filename is for the zip file), then you
should see:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:18:28
;

4779d02f8f1f13c8a05987c0d260cc8d5ecfd882be9880a1c4bb9a4fd0dc57eb
?SHA256
ODK ApplicationDesigner v2.0 rev 122 full(1).zip*
and the big number 4779... should match -- if not, then you have a
different version of the zip file than is on the site.

If you are trying to follow the getting started guide, then the fsum
-sha265 output for the simpledemo zip file is:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:30:13
;

b86c2803310f6506852489bd693840d396ecfd8cf781a10f8eaf35eab3e09144
?SHA256
ODK ApplicationDesigner v2.0 rev 122 simpledemo(2).zip*


Assuming you have the most current versions of these, and have unzipped
it...

In a cmd window, type:

npm install -g grunt-cli

to confirm the install of grunt. You should see output similar to that
shown on the npm_install_ok.png (attached).

If you get anything that is not an "npm http 200..." then that is a
problem.

If that is all correct, then,

(1) Run the grunt command in the unzipped ApplicationDesigner directory (
the one containing the Gruntfile.js )

(2) open Chrome

(3) go to its Menu / Tools / Developer Tools

(4) Make sure the Chrome developer console is showing in the bottom of
your Chrome window or is in a seperate window.

Now change the URL in the Chrome browser to

localhost:8000

This should display directory contents. E.g., see attached
localhost_8000.png image.

On Tue, Sep 2, 2014 at 11:12 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear,

I get the same

TCP 127.0.0.1:8000 http://127.0.0.1:8000/
QADEER:0 LISTENING [node.exe]

On Tue, Sep 2, 2014 at 11:00 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can be
quite long, especially if you have many browser windows open. If necessary,
you can send this through 'more' to paginate the output ( netstat -ab |
more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]

The line below this line will tell you what executable is running on
port 8000. In this case, when you have a successful grunt start-up, you
would see [node.exe]

What do you see?

If you don't see any entry for port 8000, try running grunt and in
another command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various modules,
then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

It appears likely that there is another application using port 8000
on

your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome browser from
accessing it.

I am still in the process of updating the documentation on the site
for

the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week), I
can

work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send

an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in
the

Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Dear I downloaded the latest version of Application designer from

npm install goes same as mentioned in your pic. My result is also attached.

Still when i open in chrome with developer mode, it does not display any
thing and no directory is listed.

image

··· On Tue, Sep 2, 2014 at 11:49 PM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Thank a million dear for such a detailed help. I will try and come back to
you.

Thank you again

On Tue, Sep 2, 2014 at 11:39 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

Ok.

Please verify that you have the latest ODK ApplicationDesigner download.
I updated this, and the simpledemo zip, late last week, so you might not
have the very latest.

Then download and install fsum.exe ( http://www.slavasoft.com/fsum/ )
and type:

fsum -sha256 "ODK ApplicationDesigner v2.0 rev 122 full.zip"

(or whatever your downloaded filename is for the zip file), then you
should see:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:18:28
;

4779d02f8f1f13c8a05987c0d260cc8d5ecfd882be9880a1c4bb9a4fd0dc57eb
?SHA256
ODK ApplicationDesigner v2.0 rev 122 full(1).zip*
and the big number 4779... should match -- if not, then you have a
different version of the zip file than is on the site.

If you are trying to follow the getting started guide, then the fsum
-sha265 output for the simpledemo zip file is:

SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337
Implemented using SlavaSoft QuickHash Library <www.slavasoft.com>
Copyright (C) SlavaSoft Inc. 1999-2007. All rights reserved.

; SlavaSoft Optimizing Checksum Utility - fsum 2.52.00337 <
www.slavasoft.com>
;
; Generated on 09/02/14 at 11:30:13
;

b86c2803310f6506852489bd693840d396ecfd8cf781a10f8eaf35eab3e09144
?SHA256
ODK ApplicationDesigner v2.0 rev 122 simpledemo(2).zip*


Assuming you have the most current versions of these, and have unzipped
it...

In a cmd window, type:

npm install -g grunt-cli

to confirm the install of grunt. You should see output similar to that
shown on the npm_install_ok.png (attached).

If you get anything that is not an "npm http 200..." then that is a
problem.

If that is all correct, then,

(1) Run the grunt command in the unzipped ApplicationDesigner directory (
the one containing the Gruntfile.js )

(2) open Chrome

(3) go to its Menu / Tools / Developer Tools

(4) Make sure the Chrome developer console is showing in the bottom of
your Chrome window or is in a seperate window.

Now change the URL in the Chrome browser to

localhost:8000

This should display directory contents. E.g., see attached
localhost_8000.png image.

On Tue, Sep 2, 2014 at 11:12 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

Dear,

I get the same

TCP 127.0.0.1:8000 http://127.0.0.1:8000/
QADEER:0 LISTENING [node.exe]

On Tue, Sep 2, 2014 at 11:00 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

OK.

*Ctrl-C *the grunt command to stop it.

Type:

netstat -ab

This will spew a list of all in-use ports on your system. It can be
quite long, especially if you have many browser windows open. If necessary,
you can send this through 'more' to paginate the output ( netstat -ab |
more )

Look for the line for TCP 127.0.0.1:8000. i.e.,

TCP 127.0.0.1:7438 SPRITE:0 LISTENING
WcesComm
[svchost.exe]

  • TCP 127.0.0.1:8000 http://127.0.0.1:8000
    SPRITE:0 LISTENING[node.exe]* TCP 127.0.0.1:8700
    SPRITE:0 LISTENING
    [javaw.exe]

The line below this line will tell you what executable is running on
port 8000. In this case, when you have a successful grunt start-up, you
would see [node.exe]

What do you see?

If you don't see any entry for port 8000, try running grunt and in
another command window, type this command. What do you see?

On Tue, Sep 2, 2014 at 10:35 AM, Syed Muhammad Qadeer < plannerqadeer@gmail.com> wrote:

All things seems fine but It does NOT says

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK
Live reload server started on port: 35729
Watching app\framework\formDef.json for changes.

On 9/2/14, Syed Muhammad Qadeer plannerqadeer@gmail.com wrote:

It says the following:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigner>grunt
--verbos
Initializing
Command-line options: --verbose

Reading "Gruntfile.js" Gruntfile...OK

Registering Gruntfile tasks.

Registering "grunt-contrib-connect" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-connect\package.json...OK
Loading "connect.js" tasks...OK

  • connect

Registering "grunt-contrib-watch" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-contrib-watch\package.json...OK
Loading "watch.js" tasks...OK

  • watch

Registering "grunt-open" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-open\package.json...OK
Loading "open.js" tasks...OK

  • open

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    detected Windows environment
    Initializing config...OK

Registering "grunt-exec" local Npm module tasks.
Reading D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Parsing D:\ODK\2.0 Tools\ODK ApplicationDesigner v2.0
Alpha-1\applicationDesigne
r\node_modules\grunt-exec\package.json...OK
Loading "exec.js" tasks...OK

  • exec
    Loading "Gruntfile.js" tasks...OK
  • adbpull, adbpull-csv, adbpull-db, adbpull-debug, adbpush,
    adbpush-collect, adb
    push-survey, adbpush-survey-demo-beta2, adbpush-tables,
    adbpush-tables-app,
    adbp
    ush-tables-demo-alpha2, addtable, default, server

No tasks specified, running default tasks.
Running tasks: default

Running "default" task

Running "server" task

Running "connect:livereload" (connect) task
Verifying property connect.livereload exists in config...OK
File: [no files]
Options: protocol="http", port=8000, hostname="localhost", base=".",
directory=n
ull, keepalive=false, debug=false, livereload=false, open=false,
middleware=unde
fined
Started connect web server on http://localhost:8000

Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

On Tue, Sep 2, 2014 at 9:59 PM, Mitch Sundt <mitchellsundt@gmail.com wrote:

What happens if you start grunt with a --verbose flag:

grunt --verbose

When I do this, I see a number of lines registering various
modules, then

I see:

Running "server" task

*Running "connect:livereload" (connect) taskVerifying property
connect.livereload exists in config...OKFile: [no files]Options:
protocol="http", port=8000, hostname="localhost", base=".",
directory=null,
keepalive=false, debug=false, livereload=false, open=false,
middleware=undefined Started connect web server on
http://localhost:8000

http://localhost:8000*
Running "open" task

Running "open:server" (open) task
Verifying property open.server exists in config...OK
File: [no files]
Options: (none)

Running "watch" task
Waiting...Verifying property watch exists in config...OK
Verifying property watch.livereload.files exists in config...OK
Verifying property watch.test.files exists in config...OK

Live reload server started on port: 35729Watching
app\framework\formDef.json for changes.

...

What does your system report?

On Fri, Aug 29, 2014 at 12:04 PM, Mitch Sundt < mitchellsundt@gmail.com> wrote:

It appears likely that there is another application using port
8000 on

your computer, or perhaps you have anti-virus software that is
preventing
the grunt tool from opening that port and/or the Chrome browser
from

accessing it.

I am still in the process of updating the documentation on the
site for

the pending 2.0 tools release.

Once I have the generic documentation updated (i.e., next week), I
can

work with you to uncover what is happening on your system.

On Fri, Aug 29, 2014 at 10:57 AM, plannerqadeer@gmail.com wrote:

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send

an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in
the

Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit

https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe

.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to a topic in the
Google Groups "ODK Developers" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit-developers/p0FHv_oE9gY/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.