New enketo form error with version 2.5.3

1. What is the issue? Please be detailed.
We upgrade the odk server to version 2.5.3 this morning. Everything works normally, except for Enketo: creating a new form generates an error message:

Forbidden. This server is not linked with Enketo.

But if I want to modify an previous form, Enketo works fine. It's a problem only to create a new form.

2. What steps can we take to reproduce this issue?

Test with the last prod version?

3. What have you tried to fix the issue?

I've searched into docker logs for posgres, service, nginx, enketo, but I don't found anything.

4. Upload any test forms or screenshots below.

generating enketo configuration..
starting pm2/enketo..
pm2 launched in no-daemon mode (you can add DEBUG="*" env variable to get more messages)
2022-10-21T13:34:45: PM2 log: Launching in no daemon mode
2022-10-21T13:34:45: PM2 log: [PM2] Starting /srv/src/enketo_express/app.js in fork_mode (1 instance)
2022-10-21T13:34:45: PM2 log: App [enketo:0] starting in -fork mode-
2022-10-21T13:34:45: PM2 log: App [enketo:0] online
2022-10-21T13:34:45: PM2 log: [PM2] Done.
2022-10-21T13:34:45: PM2 log: ┌─────┬───────────┬─────────────┬─────────┬─────────┬──────────┬────────┬──────┬───────────┬──────────┬──────────┬──────────┬──────────┐
│ id  │ name      │ namespace   │ version │ mode    │ pid      │ uptime │ ↺    │ status    │ cpu      │ mem      │ user     │ watching │
│ 0   │ enketo    │ default     │ 4.1.2   │ fork    │ 25       │ 0s     │ 0    │ online    │ 0%       │ 35.8mb   │ root     │ disabled │
2022-10-21T13:34:45: PM2 log: [--no-daemon] Continue to stream logs
2022-10-21T13:34:45: PM2 log: [--no-daemon] Exit on target PM2 exit pid=14
13:34:47 0|enketo  | Worker 1 ready for duty at port 8005! (environment: production)
13:34:47 0|enketo  | Worker 3 ready for duty at port 8005! (environment: production)
13:34:47 0|enketo  | Worker 2 ready for duty at port 8005! (environment: production)
13:34:47 0|enketo  | Worker 4 ready for duty at port 8005! (environment: production)


No response for the moment...

I retry and I've a 403 error in nginx logs:

POST /-/transform/xform/QpoNGVhkmT46kOZSm8oAfvB2uklcJhV HTTP/1.1" 403 87 "

The same call in modification has a code 200

POST /-/transform/xform/02klbG1Hz3JDPvcqxZMbe5YEVbmNfBJ HTTP/1.1" 200 3674 "

In modification, the address as the term "edit", not in creation. I've test to add edit in the first link, but it don't works (I've tested to add some parts of the second address, it don't works).

I've recreate the cache, but without result.

I'm assuming you meant v1.5.3 not v2.5.3?

Did you make any changes to the Central config or Enketo config besides .env? Are you installed on a machine with public Internet access or something that's firewalled and/or proxied?

Yes, it's the version #1.5.3 (sorry).

I've no change anything, except in .env: I've changed the dns (DOMAIN) and the certificate mode (SSL_TYPE=customssl).

Enketo works fine when I edit an existing submission, not when I want to create a new submission.

The server is protected by a firewall of my enterprise, which limits the access to 80 and 443 ports.

I've upgraded from version 1.3.

We have found the solution: we must reload the forms before create new submissions with enketo after this upgrade.

I'm glad you found a solution, but this is not expected behavior. My guess is that your firewall or network is preventing normal operation. What happens if you temporarily disable the firewall?

We don't have an active firewall into the server, and the connection run in the private network. We have any limitations managed by the router, but they only block the ssh, not other ports. I don't manage the router, I don't know if it can generate the pb.

We can update the submissions with enketo, but no create a new with theses olds forms. Strange, no?

How do you do that please ?

We worked around the problem by recreating the forms, and the problem doesn't seem to have recurred with this summer's update.



So it means you downloaded and re-uploaded a version ?