Nginx says unhealthy, odk installation on ubuntu 20.04 and 22.04

1. What is the issue? Please be detailed.
Installed ODK using step by step you provided, installation was successful but after that this message appears

2. What steps can we take to reproduce this issue?
.env file

3. What have you tried to fix the issue?
I've tried to change localhost to local but it remains the same
I commented line says: SSL_TYPE it prints healthy on nginx when you run:
docker-compose ps
but obviously that does not resolve our issuse.

any helpful suggestions would be appreciated.

In general, you'll need a fully qualified domain and a proper SSL certificate to run Central.

What happens if you go to localhost on that machine's web browser? Does Central load?

Hey @Omar_A ,

I hope you are doing well. To set up ODK Central you need either a public domain or you need to take a public IP from your internet service provider. After that you need to update these details accordingly.
Have a look on these posts.

  1. Install Central on Ubuntu 20.4 on AWS EC2 instance - #11 by yanokwa
  2. Is it possible to install and run ODK Central server on a local machine? - #10 by Ronald_Munjoma


Hi @Omar_A,

Letsencrypt will not work until you provide it a proper domain name (not even public IP). And central/nginx will not work until it gets a letsencrypt certificate. I learnt it the hard way! :slight_smile:


1 Like