No Images being pushed to aggregate sandbox via odk briefcase 1.14

What is the problem?
using ODK Briefcase 1.14 i pulled a data from a production server running aggregate 1.71 and MYSQL 5.7 to be later pushed to a sandbox server running the VM image 2.00 for testing, the data was pushed however the form did contain a few images which were not loaded and currently displays as a blank space.

What ODK tool and version are you using?
ODK 1.71

What steps can we take to reproduce the problem?
I am under the impression that this may be the resultant cause of using to different database engines ? i am not sure

What you have you tried to fix the problem?
the images were verified downloaded

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

image **

@Dominic_Sundar In the briefcase storage folder, do you see the images that were pulled? That is, is the problem that the images were never pulled or is the problem that they were pulled, but they weren't pushed.

the images were pulled, verified they are in the storage folder but it seems they are not being pushed...

@mmarciniak90 Is this something you can help reproduce?

I was trying to reproduce the issue somehow with using odk sandbox demo server and pushing submissions with media there but I didn't succeed. I do not have any other sandbox server that I could try with. @Dominic_Sundar could you provide more details about the issue? What kind of files those images are jpg/png etc. Maybe you could attach zipped form and submissions with media files so we could use them. I am also not sure if using different database engines matters but @ggalmazor might know more. Did you try to click on those files, is the preview available? It would at least answer if media was not pushed at all or if the miniature is not visible somehow. What about pulling them back in another folder, were they visible in your storage directory?

1 Like

@kkrawczyk123 @yanokwa
i tried uploading to using form name "Resurvey_CMC", upload was successful and images loaded as they should. this got me thinking that the only difference between the two servers are there network addresses, my sandbox was running with network card in bridge mode so i changed it to NAT and restart the server and just like that the images where their.

not sure i can explain this one as to why this occurred, anyone want to take a wack at it ?

@ggalmazor Does this Bridge/NAT problem make sense to you? If it doesn't at a glance, no worries, but I figure you might know.

This is something we should investigate. I'll open an issue to not forget about it.