Not able to download forms

What is the problem? Please be detailed.
I have installed new ODK Aggregate server 2.0 having downloaded it from the website. After following instructions and using the cloud server DigitalOcean,com based on the instructions, I, then, have successfully uploaded a form to this server. But when I attempted to download the form via ODK Collect, I got this error:
Download Results
{form name} = failed to connect to url/ip address (port 443) from /ip address (port 38156) after 30000ms: isConnected failed: ECONNREFUSED (Connection refused)

What ODK tool and version are you using? And on what device and operating system version?
I just downloaded the latest ODK Collect from android play store. v1.19.0

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Welcome to the forum, @Chinx! When you get a chance, please introduce yourself here. I'd also encourage you to add a real picture as your avatar because it helps build community!

The error message about the port 38156 suggests that you are doing something unusual because no where in the instructions at do we use that port. Did you deviate from the instructions? If so, how?

Thanks Yan.

I actually missed to perform the step where the documentation instructs setting up https.

Will introduce myself per your suggestion.

1 Like

Hi, @Chinx!

Thanks for using Aggregate v2.0 on DigitalOcean. We want to have the smoothest possible process, so feel free to post any comment about the installation process, performance of your Droplet, any issue you encounter. All feedback is welcome :wink:


Como resolviste el problema? Tengo la maquina virtual V2.0.3 y me da el mismo poblema

Hola @Joaquin_Linares. @Chinx tenía un problema de configuración de SSL. En el caso de la VM, no está preparada para configurar SSL de una manera sencilla, por lo que tendrás que hacerlo tú configurando los certificados y Tomcat a mano, o añadiendo un proxy inverso por delante de Aggregate que proporcione SSL para la VM.

1 Like

Gracias @ggalmazor, después configure la vm con el comando aggregate-config --fqdn --http-port 80 --https-port 8443 --net-mode bridge

Las instrucciones para la la instancia en la nube (Digital Ocean) son distintas a las de la VM.

Por favor, podrías abrir un nuevo hilo explicando bien lo que has hecho y lo que no te funciona bien para que entendamos bien el problema?


I am facing similar issue in ODK collect

failed to connect to url/ip address (port 443) after 30000ms: isConnected failed: ECONNREFUSED (Connection refused). I implemented ODK aggregate in google cloud.

Could you please help me out with this error.

@yanokwa I'm having the same issue. Aggregate installed on Azure, with the instructions per the ODK documentation.I'm able to navigate to the formslist both through the ODK Collect app as well as on a browser on my mobile phone.

Once a form is selected for download, i get the foll error under Doownload Results

FormName(Version::xx ID XXXX) - failed to connect to url/ip (port 443) from / ip (port 48927) after 3000ms: isConnected failed: ECONNREFUSED (Connection refused)

Good morning @Vanubhav
The problem is with the url to which you direct when you download the file .. the ssl the problem, when you redirect the page to download it does not carry https but rather http for it, the server certificates must be connected and loaded.

Check that the dns of type are in the dns of your domain
CAA and is redirecting to the certificate. in my case the certificate


Thanks! there was an issue when setting up the ssl certificate, and I actually reverted to a new VM - second time setting it up worked. I'm unsure what I did differently, but the issue is resolved - thanks for the help!