Not able to open odk central after installation

1. What is the issue? Please be detailed.
I am new to docker. (if anyone can guide how to install central old way without docker i will be obliged.)
i have installed odk central as per docs given on ubuntu server, without any issue.

assigned fqdn and direct ip, (do i need to add fqdn in hosts file also ?).
disbaled ufw
Still not able to reach the central web.

I want to try installing my own ssl , but do not know how can i do the same in docker environment.

Is it possible to install central without docker ? it will be easier to debug the issue.
2. What steps can we take to reproduce this issue?
I really don't know as there is no error ,except it just does not show me any webpage and redirects me to https page.

3. What have you tried to fix the issue?
Read the forum but could not get relavant guidance.

4. Upload any forms or screenshots you can share publicly below.

It's possible to check the docker logs with commands such as
docker-compose logs service and docker-compose logs mail
to see if there are any hints as to what is wrong. You can do also do this by providing the container ID to the command.

You mention "direct ip" - do you have a fully qualified domain name? Central requires a fully qualified domain name. See this post for more details on that:

1 Like

thanks for the help.
i set it up on cloud it worked smooth. may be some internal firewall issues
thanks alot.

1 Like