Not able to run aggregate (appStartWar)

I've setup aggregate code in IntelliJ.
When I'm running appStartWar task I get following error.

org.springframework.beans.factory.BeanDefinitionStoreException: IOException parsing XML document from class path resource [odk-settings.xml]; nested exception is class path resource [odk-settings.xml] cannot be opened because it does not exist

Can someone please hep on this?

Hi sushil,
I am facing the same issues. I've google this issue but couldn't find the solution.

Hi! Sorry about that... I'll try to reproduce the error and get back to you if I find something

Hi again! First things first, I've checked that you can start everything from the command line. Please, try to reproduce these steps with a fresh copy of the source code:

  1. Copy to a file
  2. Edit the file src/main/resources/ to set your database settings
  3. execute ./gradlew appStartWar

You should see Aggregate running after some time. If any error pops up, please copy it here and we'll try to figure it out.

While you do this, I'll see if there is any problem with IntelliJ.


I've followed the steps on wiki and I've completed all 3 steps mentioned by you.
I made following change

> <context-param>

In above param-value, I changed classpath to classpath*
This change worked and that error is gone.

But I'm getting new error now. Please see the error below.

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'hierarchicalRoleRelationships' defined in ServletContext resource [/WEB-INF/applicationContext-security.xml]: Cannot resolve reference to bean 'datastore' while setting bean property 'datastore'; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No bean named 'datastore' available


Hi @Sushil_Kadu! You shouldn't have to make that change in order to get it working...

Can you confirm that you have installed git-lfs before cloning the repo? (also @Ritesh_Bhagat, please confirm the same thing).

Also, @Sushil_Kadu, can you copy here the full output from gradle for the appStartWar task, please?

In the meantime, I've successfully managed to import the project in an IntelliJ Community edition... We need to dig a little bit more into your development environment. Can you tell me which JVM are you running? Is it OpenJDK, Oracle, or any other?

@ggalmazor I did not use git-lfs before cloning the code.
Following are my java version details. I'm using Oracle JDK

java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

I did not use git-lfs before cloning the code.

This is required to clone the project. Please, follow the steps from this guide and try again. You will have to clone the project again.

I used git-lfs and cloned the new repo.
Please see attached file for the logs.error.txt (9.7 KB)

Alright, can you confirm that the setting warMode inside has the value complete, please? If not, change it, run gradlew clean, and try again, please.

I was not looking to host this on Google App Engine so I used "installer", please see below.


I want to host it locally using postgres

@ggalmazor complete worked, I'm seeing the screen.
How can I repay you for this help :slightly_smiling_face:
Been stuck on this since yesterday, spent around 28 hours.

Thank you so very much!


Awesome @Sushil_Kadu! I'm glad that we worked it out :slight_smile:


No need to repay, but we'd love to have you contributing code! is a good place to start.

Also, when you get a chance, please introduce yourself here to the rest of the community.

ohh yaa, would love to contribute!
Thank you!

I'll add my introduction to the page you mentioned.

1 Like