Not all geometries in the ODK briefcase export

1. What is the problem? Be very detailed.
When I export files in geojson format via ODK Briefcase, a few geometries are always missing. I've had this problem for many years. I then also generate a shape file from the csv file via QGIS (sometimes geometries are missing, but there are significantly more than via ODK Briefcase).

My survey staff must always put at least 4 points in odk in the map application. I once thought that it would be because of this. But that was probably not the solution.

I wanted to ask if the problem is known and if anyone else has the problem?

2. What app or server are you using and on what device and operating system? Include version numbers.
Odk collect beta version
No Server
3. What you have you tried to fix the problem?

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Out of interest, do some of the submissions have whitespace before the ; in the geometry?

I will check this tomorrow

It seems that there are really spaces on semicolons.

I can finally isolate the problem. Thank-you

Someone know if the problem will solved in the next time for ODKBriefcase?

This root cause was just fixed in Collect. No ETA on when we can patch this in Briefcase. If this is an urgent issue for you, perhaps hire someone in the marketplace to send in a fix?

1 Like

Thanks a lot
Maybe the problem is not in briefcase and your corrections in collect has fixed the problem.


It's true that the problem is not in Briefcase, but if any of your devices are running an old version of Collect, they will generate the flawed traces which will break Briefcase.