Nothing available to display on Fill Blank Form page

Hello all!

I have ODK Collect v1.24.0 installed on my Google Pixel 2 Android(version 10) phone.
When I click on Get Blank Form I can see all the forms stored on my server (I have tried both aggregate and google drive).
If I click to download a particular form and it tells me this has been successful.

But then when I got to "Fill Blank Form" it tells me "Nothing available to display. Try getting and filling out a blank form"
I have tried the process on another device and I can get it to work fine.

I have gone to Admin Settings and reset the application, I have cleared the stored data for this app from the settings within my phone and I have also uninstalled and reinstalled the app. To no avail :slight_smile:

Has anyone encountered this and do you have any ideas on how to resolve?

I'm not sure I've ever had it working on this phone (have only had it a couple of months), but did have it working on another phone. My suspicion is that when I transferred phones something funny has happened. But I'm not tech savvy enough to figure it out

Any support would be greatly appreciated!

Thanks
Dave

@seadowg just mentioned having this problem on Android 10 on the developer Slack so it's almost certainly related to Android version. We'll try to investigate in the next few days!

Thanks! I'll keep an eye on developments :slight_smile:

Seems to be reproducible on any Android 10 device as long as we use the Play Store/release build. The problem doesn't show up in the debug builds we use day to day for development and testing. I've created an issue on Github for this.

1 Like

This has been fixed in Collect v1.24.1. The release should be rolling out on all devices now.

1 Like

Wow, quick work all. Thanks a lot!

1 Like