Null geometry when exporting GeoJSON from Briefcase

@ggalmazor. Thanks for your work so far.

Unfortunately I got the problem, that when I export my test-data with Briefcase as GeoJSON, the geometry-field is null. CSV works fine though.

I think you can check it by yourself, here is my data:

It would be great to use it in my fieldwork! I simply love to use open source.. :slight_smile:

Hi, @bastoGrande!

The sandbox server resets every Saturday and I was on leave for the last two weeks. Could you push the form again, please? This week I can check this and try to debug it.


Right now I'm not home and can't test if it's reproducible (don't know how to use briefcase on my manjaro-linux), but on uploaded again a form (BriefcaseDemo) to the sandbox server. Hope this helps..

Hi, @bastoGrande!

I've just tried to pull & export with Briefcase v1.14 your form from the sandbox server and I got a valid GeoJSON. Can you tell us what you've tried so far, and how it fails?

This is the GeoJSON I got:


You can verify at that it's a valid GeoJSON document.

sorry for the extremly late reply!

Well I don't know why it didn't work the first time, but now it seems alright.. might be a strange set of circumstances... :confused:

anyway, thanks for your effort!

1 Like