ODK Aggregate install stuck on Mac launching upload tool

Installing ODK Aggregate in a Mac, gets stuck (each time) at the point where the configuration is done and it needs to launch the upload tool (3-10 minutes); i suspect it has to do with Java; though i updated as required

error running osascript
execution error: exception in thread main java lang

would realy like to get it going
i hope there is a fix, some tip to correct it?


It sounds like you are using Java 9. Please uninstall and try with Java 8. We have an update coming soon that will add support for Java 9.

thanks Yaw, my mac book runs Java 8 Update 161 on OS X 10.10.5
could it be an incompatibility or some issue that Java 8 has with Google
Chrome browser?


On your command line, run the following command: /usr/libexec/java_home -V

What output do you get?

Matching Java Virtual Machines (2):

1.6.0_65-b14-468, x86_64: "Java SE 6"


1.6.0_65-b14-468, i386: "Java SE 6"



macbooks-MacBook-Pro-2:~ macbookpro15$

Does that look like i am still on Java version 6?
thx in advance,

Java 6 is quite outdated (the last public update was in 2013). Please install Java 8 and try the install again.

Thanks Yaw
the thing is i download Java 8 and install, then it says 'successfully
installed', i did this several times but in fact it does not replace
version 6, i see now. Any tip why this doesnt happen?


Uninstall Java 6 using https://docs.oracle.com/javase/8/docs/technotes/guides/install/mac_jdk.html#A1096903 and then https://www.java.com/en/download/help/mac_uninstall_java.xml. Then reboot and install Java 8.

Dear Yaw

there are a couple of these Sudo commands,
sudo rm -fr /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin
sudo rm -fr /Library/PreferencePanes/JavaControlPanel.prefPane
sudo rm -fr ~/Library/Application\ Support/Java

do i enter these separately or all at once (or does that not matter?)

As a tried it it returns - rather ominously,

macbooks-MacBook-Pro-2:~ pascal$ sudo rm -fr /Library/Internet

WARNING: Improper use of the sudo command could lead to data loss

or the deletion of important system files. Please double-check your

typing when using sudo. Type "man sudo" for more information.

To proceed, enter your password, or type Ctrl-C to abort.


Is that safe to proceed, and would that be the admin pass word to enter?,
thanks so much for helping out with this


Hello @Pascal_Verhoeven ,
Did you try this , In your Environment variables replace java 6 folder with java 8 . It may give some problem . I know this is a basic thing but just check it once .

Thanks and regards,


Yes, it's safe to proceed.

Enter the commands separately. You will be asked for the admin password on the first command, and the rest should proceed without needing the password.

Hi, tried few times entered the 1st commend, asks for password, but it
seems i cant get my password typed in the prompt. Unfortunately!
maybe i should try a windows machine :slight_smile: