ODK Aggregate Installation error on Mac Sierra

What is the problem? Please be detailed.

Hi I am trying to install ODK aggregate on my Mac, I am new to Mac OS, Post Installation, when I try to launch the tool it throws following message

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/cli/ParseException
at java.base/java.lang.Class.forName0(Native Method)
at java.base/java.lang.Class.forName(Class.java:375)
at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:56)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.cli.ParseException
at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:563)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
... 3 more (1)
What ODK tool and version are you using? And on what device and operating system version?

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

I cant answer your question pe se, but to be perfectly honest you are probably far better of installing ODK Aggregate on a Linux box (either virtual or bare-metal) by following one of several well-documented recipes, than trying to strong-arm it into Mac OS X - especially if you are new to Mac OS X! eg:


Just my $0.02...

My guess is that you have Java 1.9 which was just released. Try uninstalling Java 1.9 and installing Java 1.8 and see if that works.

Based on this previous post ODK Aggregate installer failure on macOS, I bet it'll work!

I've filed this issue at https://github.com/opendatakit/aggregate/issues/113 so we can fix it in the next release.

1 Like

Hi @Narendra_Shandilya!

I'm looking into this and other similar errors reported by other users. Could you confirm that you were trying to upload Aggregate to Google App Engine?

If not, could you describe with a little more detail what was going on? What did you try to run post installation, etc.?


1 Like

Hi, i'm running into this same issue while trying to update an Aggregate server from V1.4.9 to V1.4.10.

Running MacOS High Sierra V10.13.4

I've uninstalled JAVA and installed version 1.8.0_172 and still got the same error.

To reproduce error:

  1. Download: ODKAggregate-1.4.10 Production-osx-installer
  2. Select: Google App Engine installation
  3. Enter instance name, username, application ID
  4. Complete setup wizard
  5. Launch installation script
  6. Error

Also got the same error while manually opening uploadAggregateToAppEngine

@richardnguyen5 The problem you are running into is that the old versions of the Aggregate installer require old versions of Java. Your options are:

  • Find another computer (or make a VM) with Java 7 (Windows, Ubuntu, Mac)
    • The OS doesn't matter. You can run the installer on any platform.
  • Uninstall all Javas and install Java 7 on your Mac.
    • I'm not sure how old of a Java Sierra will run, but it's worth a try.
  • Go straight from Aggregate 1.4.9 to the latest Aggregate v1.6.x
  • Install a new Aggregate server and migrate your data over with Briefcase
    • You'll lose username/password, publishers, etc. Otherwise, it's safe, but a little slow.

Thanks Yaw. Java was the issue, and using another Windows computer running Java 8 worked.

1 Like