ODK Aggregate Keeps Refreshing

Hi,
Kindly, anyone who has been faced with the problem of Aggregate Server
refreshing continuously after log in without displaying the
components/items on the Aggregate web page. If you have a solution on how
to solve this and regain access to data through the web or briefcase,
please help.
Thank you.

Hi Phelix,

What, if anything, was done to the machine before this problem started
happening?

Try a different browser. Look at the logs for hints of what is wrong.
If you are on App Engine, have you made sure you have enough quota. If
you are on a local machine, try a reboot.

Yaw

··· On Mon, Dec 5, 2016 at 7:45 PM, Phelix Jangu wrote: > Hi, > Kindly, anyone who has been faced with the problem of Aggregate Server > refreshing continuously after log in without displaying the components/items > on the Aggregate web page. If you have a solution on how to solve this and > regain access to data through the web or briefcase, please help. > Thank you. > > -- > -- > Post: opendatakit@googlegroups.com > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > Options: http://groups.google.com/group/opendatakit?hl=en > > --- > You received this message because you are subscribed to the Google Groups > "ODK Community" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to opendatakit+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/d/optout.

This is a known symptom of a data corruption problem in the form
definitions.

See https://github.com/opendatakit/opendatakit/wiki/Aggregate-AppEngine-Troubleshooting#repairing-the-form-definition-table

··· On Sat, Dec 10, 2016 at 9:12 AM, Yaw Anokwa wrote:

Hi Phelix,

What, if anything, was done to the machine before this problem started
happening?

Try a different browser. Look at the logs for hints of what is wrong.
If you are on App Engine, have you made sure you have enough quota. If
you are on a local machine, try a reboot.

Yaw

On Mon, Dec 5, 2016 at 7:45 PM, Phelix Jangu phelixjangu@gmail.com wrote:

Hi,
Kindly, anyone who has been faced with the problem of Aggregate Server
refreshing continuously after log in without displaying the
components/items
on the Aggregate web page. If you have a solution on how to solve this
and
regain access to data through the web or briefcase, please help.
Thank you.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Dear Yaw,

My Aggregate keeps refreshing. I have so many forms running under this server and data collection is under process. I need help in resolving this issue. the domain is tbsap-mapping.appspot.com. I tried to follow the instructions and seems so complicated for me and worried about losing data. I have already sent you and Mitch a invite to look into my project and sent the invite to your nafundi email.

Thanks in advance,
Imran

One thing I tried to do, I have deleted the table using GCL, which I uploaded, at last, the form id was "chart_review". I noticed that same form was uploaded twice and probably that was the reason. Still, the problem has not been resolved and I seeking all of your kind help in resolving this issue.

Hi IMRN,

are you within a survey execution and submession sent to the server successfuly.

if yes,
make sure that you can use ODKBreficase so you can pull your data.

before you get the problem what happen ?

Best Regards

Hi Nader,

Even it's not allowing me to log to ODK briefcase using my URL and login credentials.

Please let me know if you have any suggestion.

Best regards,
Imran

Hi IMRN,

i will try to help,
i am not good more than you.

Lets start from would you tell me what happen before this problem?

Best Regards

Hi Nader,

I just uploaded a new for to this server and I think by mistake I click twice to the upload button, and that was the starting of this issue. Since then this server keeps refreshing.

Best regards
Imran

Dear Nader,

Would you like to have a look into my Google cloud console, I can send you access.

Thanks,
Imran

Hi IMRN,

sure but not now,

please give me a little time,

and i want from the name of your aggregate instance (Required)

Best Regards

Hi Nader,

Do you mean the first part of the url? if so, it is tbsap-mapping.

Thanks,
Imran

no,
when you install aggregate to google app engine

Hi Nader,

I got your point. To be honest, I do not remember or did not taken a note of it. However, there are few chances: TBSAP mapping, TBSAP_mapping, TBSAP Mapping, TBSAP_Mapping or Aggregate.

Thanks,
Imran

Is there any chance that, I can retrieve this instance name from Google console?

Hi IMRAN,

ok

Best Rgards

1 Like

Hi folks. I wanted to jump in here and provide a very clear warning...

Deleting anything from App Engine's data store is very dangerous. You can lose all your data and corrupt your install.

Before any of this proceeds, there must be backups of all forms and all data. Then, the person who is doing these changes should have previous experience following the instructions at https://github.com/opendatakit/opendatakit/wiki/Aggregate-AppEngine-Troubleshooting.

@A.N.M_AL-IMRAN you have many forms and a live data collection campaign. I do have access to your server, but I did not receive a notification or your email that you had given me access and so did not know you were having problems. Do you have complete backups of your forms and data? Are you aware that these changes we are discussing could further corrupt your data store?

@Nader Do you have previous experience fixing these kinds of problems on App Engine installs?

3 Likes

+1 ... as a former IT operations person, please please please never experiment on a "live" or "production" system. Always make a full backup first, and if possible, test your changes on a non-production system first, creating good documentation, with a plan to "roll back" your work to the state it was in before -- just in case any problems come up!

Be careful out there!

2 Likes

Hi Downey,

You are right.

all what i am going to do is simulating IMRAN issues,

i did create a project in google app engine and i will upload aggregate.

no experiment on a “live” data.

Best Regards

2 Likes

Cool. Let us know if you are able to reproduce the problem on your test instance! :nerd_face:

1 Like