ODK Aggregate - Move several .war files to another server

1. What is the problem? Be very detailed.
I need to move several .war files from one server to another server.
How to do it. I searched the forum but did not find any info if there are any documentation or discussion please just point it.
ODK Aggregate is installed and working.

2. What app or server are you using and on what device and operating system? Include version numbers.
Tomcat8 running on Ubuntu 18.04

3. What you have you tried to fix the problem?
I tried to move the war files but it's not working. I also try to open the .war files but did not found any config or properties file.

4. What steps can we take to reproduce the problem?
Just tried to move the war files and then open and configure the .war files.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Welcome on the ODK forum @tomanix13, don't hesitate to Introduce yourself here!

You can do that way, you need first to backup and restore your database on the new database server if needed, change the settings in the war file in /WEB-INF/lib/ODKAggregate-settings.jar :

  • jdbc properties for database connection the tomcat server in pg_hba.conf
  • security.properties (for serve hostname and port)
1 Like

Hi, thanks.
I had already restored the DB. I will try to update the settings.

thanks

Hi,

Here's what I did:

  • The ODK Aggregate is installed and running on the new server;
  • copied another .war file 'newsite.war' from the old to the new server;
  • restored the newsite DB (postgres) in the new server;
  • changed the following files in /WEB-INF/lib/ODKAggregate-settings.jar
    jdbc.properties and security.properties with the accesses
  • deploy, copying, the .war file to tomcat
  • the app is listed in tomcat web admin
    but when I try to access returns 404 – Not Found

in catalina.log there is this entry:
" org.springframework.beans.factory.BeanDefinitionStoreException: IOException parsing XML document from class path resource [odk-settings.xml]; nested exception is java.io.FileNotFoundException: class path resource [odk-settings.xml] cannot be opened because it does not exist
"

what am I missing ?

thanks,