ODK Aggregate on Remote Laptop

Hi,

I have the ODK Aggregate running correctly on tomcat6 when my RaspberryPi is connected to my monitor with an HDMI. It runs when I have the ethernet cable connected from the raspberry pi to a router. I am trying to get ODK Aggregate come up with its same ip address on my laptop. I have connected the pi to the router through one ethernet cable and the router to my laptop through another ethernet cable. The ip address ODK Aggregate does not load. Any ideas on what I could be doing wrong?

Thanks,
Ali Nazjoo
University of Michigan

First, I assume you are not using 127.0.0.1 to refer to the PI -- that is
the address equivalent to "localhost" -- which is netspeak for "myself". It
should be some value other than that.

There are two issues:
(1) does the raspberryPI have a firewall that is preventing access to the
Tomcat server from other machines? This is typically configured using
'iptables' http://www.bartbania.com/index.php/iptables-security-part-ii/

(2) Less likely: is the router configured for NAT, and did you connect your
other equipment on the upstream side of the router? See
http://opendatakit.org/use/aggregate/tomcat-install/#Configure_for_Network_Access

Mitch

··· On Mon, Nov 25, 2013 at 5:27 PM, wrote:

Hi,

I have the ODK Aggregate running correctly on tomcat6 when my RaspberryPi
is connected to my monitor with an HDMI. It runs when I have the ethernet
cable connected from the raspberry pi to a router. I am trying to get ODK
Aggregate come up with its same ip address on my laptop. I have connected
the pi to the router through one ethernet cable and the router to my laptop
through another ethernet cable. The ip address ODK Aggregate does not load.
Any ideas on what I could be doing wrong?

Thanks,
Ali Nazjoo
University of Michigan

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

First, I assume you are not using 127.0.0.1 to refer to the PI -- that is the address equivalent to "localhost" -- which is netspeak for "myself". It should be some value other than that.

There are two issues:

(1) does the raspberryPI have a firewall that is preventing access to the Tomcat server from other machines? This is typically configured using 'iptables' http://www.bartbania.com/index.php/iptables-security-part-ii/

(2) Less likely: is the router configured for NAT, and did you connect your other equipment on the upstream side of the router? See http://opendatakit.org/use/aggregate/tomcat-install/#Configure_for_Network_Access

Mitch

Hi,

I have the ODK Aggregate running correctly on tomcat6 when my RaspberryPi is connected to my monitor with an HDMI. It runs when I have the ethernet cable connected from the raspberry pi to a router. I am trying to get ODK Aggregate come up with its same ip address on my laptop. I have connected the pi to the router through one ethernet cable and the router to my laptop through another ethernet cable. The ip address ODK Aggregate does not load. Any ideas on what I could be doing wrong?

Thanks,

Ali Nazjoo

University of Michigan

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

Hi,
My IP Address is 192.168.1.2 for the Pi through a router. ODK Aggregate appears when I connect the Pi through HDMI to a TV with the same IP Address, but when I connect to my laptop through ssh only the Tomcat "It Works" page comes up with the ip address. When I try going to the ODK Aggregate page, an ODK Aggregate redirect page comes up, but ODK Aggregate does not fully load.

-Ali

··· On Tuesday, November 26, 2013 10:21:09 AM UTC-5, Mitch Sundt wrote: > On Mon, Nov 25, 2013 at 5:27 PM, wrote:

I am confused by your 2nd sentence.

From the laptop, you should be able to open a browser, enter
http://192.168.1.2/ and get the Tomcat 'it works' screen -- there shouldn't
be any SSH involved.

If you specified this same IP address (192.168.1.2) during the ODK
Aggregate install, navigating to http://192.168.1.2/ODKAggregate should
also display the redirect page and then display ODK Aggregate's main
screen. The failure during the redirect indicates either that you did not
successfully configure the database (e.g.,, MySQL requires that you
manually install the MySQL Connector/J in the Tomcat libs directory) or
that you specified some other IP address or hostname in the installer, and
the redirect is failing because that address doesn't exist. Look at your
Tomcat logs for errors. If you do not see a database error, then it is
likely that the IP address is wrong; you will need to re-run the installer
to re-generate the ODK Aggregate WAR file, and install the updated WAR onto
your PI.

Mitch

··· On Sun, Dec 1, 2013 at 8:36 AM, wrote:

On Tuesday, November 26, 2013 10:21:09 AM UTC-5, Mitch Sundt wrote:

First, I assume you are not using 127.0.0.1 to refer to the PI -- that
is the address equivalent to "localhost" -- which is netspeak for "myself".
It should be some value other than that.

There are two issues:

(1) does the raspberryPI have a firewall that is preventing access to
the Tomcat server from other machines? This is typically configured using
'iptables' http://www.bartbania.com/index.php/iptables-security-part-ii/

(2) Less likely: is the router configured for NAT, and did you connect
your other equipment on the upstream side of the router? See
http://opendatakit.org/use/aggregate/tomcat-install/#Configure_for_Network_Access

Mitch

On Mon, Nov 25, 2013 at 5:27 PM, asna...@umich.edu wrote:

Hi,

I have the ODK Aggregate running correctly on tomcat6 when my
RaspberryPi is connected to my monitor with an HDMI. It runs when I have
the ethernet cable connected from the raspberry pi to a router. I am trying
to get ODK Aggregate come up with its same ip address on my laptop. I have
connected the pi to the router through one ethernet cable and the router to
my laptop through another ethernet cable. The ip address ODK Aggregate does
not load. Any ideas on what I could be doing wrong?

Thanks,

Ali Nazjoo

University of Michigan

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

Hi,
My IP Address is 192.168.1.2 for the Pi through a router. ODK Aggregate
appears when I connect the Pi through HDMI to a TV with the same IP
Address, but when I connect to my laptop through ssh only the Tomcat "It
Works" page comes up with the ip address. When I try going to the ODK
Aggregate page, an ODK Aggregate redirect page comes up, but ODK Aggregate
does not fully load.

-Ali

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

I am confused by your 2nd sentence.

From the laptop, you should be able to open a browser, enter http://192.168.1.2/ and get the Tomcat 'it works' screen -- there shouldn't be any SSH involved.

If you specified this same IP address (192.168.1.2) during the ODK Aggregate install, navigating to http://192.168.1.2/ODKAggregate should also display the redirect page and then display ODK Aggregate's main screen. The failure during the redirect indicates either that you did not successfully configure the database (e.g.,, MySQL requires that you manually install the MySQL Connector/J in the Tomcat libs directory) or that you specified some other IP address or hostname in the installer, and the redirect is failing because that address doesn't exist. Look at your Tomcat logs for errors. If you do not see a database error, then it is likely that the IP address is wrong; you will need to re-run the installer to re-generate the ODK Aggregate WAR file, and install the updated WAR onto your PI.

Mitch

First, I assume you are not using 127.0.0.1 to refer to the PI -- that is the address equivalent to "localhost" -- which is netspeak for "myself". It should be some value other than that.

There are two issues:

(1) does the raspberryPI have a firewall that is preventing access to the Tomcat server from other machines? This is typically configured using 'iptables' http://www.bartbania.com/index.php/iptables-security-part-ii/

(2) Less likely: is the router configured for NAT, and did you connect your other equipment on the upstream side of the router? See http://opendatakit.org/use/aggregate/tomcat-install/#Configure_for_Network_Access

Mitch

Hi,

I have the ODK Aggregate running correctly on tomcat6 when my RaspberryPi is connected to my monitor with an HDMI. It runs when I have the ethernet cable connected from the raspberry pi to a router. I am trying to get ODK Aggregate come up with its same ip address on my laptop. I have connected the pi to the router through one ethernet cable and the router to my laptop through another ethernet cable. The ip address ODK Aggregate does not load. Any ideas on what I could be doing wrong?

Thanks,

Ali Nazjoo

University of Michigan

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--

Mitch Sundt

Software Engineer

University of Washington

mitche...@gmail.com

Hi,

My IP Address is 192.168.1.2 for the Pi through a router. ODK Aggregate appears when I connect the Pi through HDMI to a TV with the same IP Address, but when I connect to my laptop through ssh only the Tomcat "It Works" page comes up with the ip address. When I try going to the ODK Aggregate page, an ODK Aggregate redirect page comes up, but ODK Aggregate does not fully load.

-Ali

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

Hi Mitch,
Then, when I go to the tomcat manager app I can see that ODK Aggregate has started on tomcat (attached image).
When I go to 192.168.1.2/ODKAggregate the redirect page comes up, but the form page does not load.
I don't think it is a database problem because I have transferred the MYSQL Connector J's .jar file into the Pi’s /usr/share/tomcat6/lib/
ODK Aggregate loads up through startx when connected to a monitor but not on my remote laptop.
Is there any way you can help me out?

Thanks,
Ali Nazjoo

··· On Monday, December 2, 2013 2:11:46 PM UTC-5, Mitch Sundt wrote: > On Sun, Dec 1, 2013 at 8:36 AM, wrote: > On Tuesday, November 26, 2013 10:21:09 AM UTC-5, Mitch Sundt wrote: > > On Mon, Nov 25, 2013 at 5:27 PM, wrote: From my laptop I am able to get the tomcat "it works" page up with 192.168.1.2

Hmmm. The screen shot shows that you have the Tomcat server set up on port
8080.

The URL you should be using is

http://192.168.1.2:8080/ODKAggregate

And if the page is trying to redirect to port 80 (no port specified on the
URL), then that is a problem. During the install process, on the screen
asking for the IP address, there is a field to specify the port number. Be
sure that is port 8080, or, if you have set up the iptables to route port
80 to port 8080, you can specify port 80 during the install. Also note that
you need to set the firewall (I assume it is iptables) to allow port 8080
(or whatever) to be accessed by an external device.

Some Linux installations have a brain-dead firewall wrapper app that
(re)configures iptables to deny access. Be sure your iptables configuration
is not being overwritten or superseded by something like that.

Mitch

Mitch

··· On Wed, Dec 11, 2013 at 11:56 AM, wrote:

On Monday, December 2, 2013 2:11:46 PM UTC-5, Mitch Sundt wrote:

I am confused by your 2nd sentence.

From the laptop, you should be able to open a browser, enter
http://192.168.1.2/ and get the Tomcat 'it works' screen -- there
shouldn't be any SSH involved.

If you specified this same IP address (192.168.1.2) during the ODK
Aggregate install, navigating to http://192.168.1.2/ODKAggregate should
also display the redirect page and then display ODK Aggregate's main
screen. The failure during the redirect indicates either that you did not
successfully configure the database (e.g.,, MySQL requires that you
manually install the MySQL Connector/J in the Tomcat libs directory) or
that you specified some other IP address or hostname in the installer, and
the redirect is failing because that address doesn't exist. Look at your
Tomcat logs for errors. If you do not see a database error, then it is
likely that the IP address is wrong; you will need to re-run the installer
to re-generate the ODK Aggregate WAR file, and install the updated WAR onto
your PI.

Mitch

On Sun, Dec 1, 2013 at 8:36 AM, asna...@umich.edu wrote:

On Tuesday, November 26, 2013 10:21:09 AM UTC-5, Mitch Sundt wrote:

First, I assume you are not using 127.0.0.1 to refer to the PI -- that
is the address equivalent to "localhost" -- which is netspeak for "myself".
It should be some value other than that.

There are two issues:

(1) does the raspberryPI have a firewall that is preventing access to
the Tomcat server from other machines? This is typically configured using
'iptables' http://www.bartbania.com/index.php/iptables-security-part-ii/

(2) Less likely: is the router configured for NAT, and did you connect
your other equipment on the upstream side of the router? See
http://opendatakit.org/use/aggregate/tomcat-install/#Configure_for_Network_Access

Mitch

On Mon, Nov 25, 2013 at 5:27 PM, asna...@umich.edu wrote:

Hi,

I have the ODK Aggregate running correctly on tomcat6 when my
RaspberryPi is connected to my monitor with an HDMI. It runs when I have
the ethernet cable connected from the raspberry pi to a router. I am trying
to get ODK Aggregate come up with its same ip address on my laptop. I have
connected the pi to the router through one ethernet cable and the router to
my laptop through another ethernet cable. The ip address ODK Aggregate does
not load. Any ideas on what I could be doing wrong?

Thanks,

Ali Nazjoo

University of Michigan

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--

Mitch Sundt

Software Engineer

University of Washington

mitche...@gmail.com

Hi,

My IP Address is 192.168.1.2 for the Pi through a router. ODK Aggregate
appears when I connect the Pi through HDMI to a TV with the same IP
Address, but when I connect to my laptop through ssh only the Tomcat "It
Works" page comes up with the ip address. When I try going to the ODK
Aggregate page, an ODK Aggregate redirect page comes up, but ODK Aggregate
does not fully load.

-Ali

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

Hi Mitch,
From my laptop I am able to get the tomcat "it works" page up with
192.168.1.2
Then, when I go to the tomcat manager app I can see that ODK Aggregate has
started on tomcat (attached image).
When I go to 192.168.1.2/ODKAggregate the redirect page comes up, but the
form page does not load.
I don't think it is a database problem because I have transferred the
MYSQL Connector J's .jar file into the Pi’s /usr/share/tomcat6/lib/
ODK Aggregate loads up through startx when connected to a monitor but not
on my remote laptop.
Is there any way you can help me out?

Thanks,
Ali Nazjoo

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Hmmm. The screen shot shows that you have the Tomcat server set up on port 8080.

The URL you should be using is

http://192.168.1.2:8080/ODKAggregate

And if the page is trying to redirect to port 80 (no port specified on the URL), then that is a problem. During the install process, on the screen asking for the IP address, there is a field to specify the port number. Be sure that is port 8080, or, if you have set up the iptables to route port 80 to port 8080, you can specify port 80 during the install. Also note that you need to set the firewall (I assume it is iptables) to allow port 8080 (or whatever) to be accessed by an external device.

Some Linux installations have a brain-dead firewall wrapper app that (re)configures iptables to deny access. Be sure your iptables configuration is not being overwritten or superseded by something like that.

Mitch

Mitch

I am confused by your 2nd sentence.

From the laptop, you should be able to open a browser, enter http://192.168.1.2/ and get the Tomcat 'it works' screen -- there shouldn't be any SSH involved.

If you specified this same IP address (192.168.1.2) during the ODK Aggregate install, navigating to http://192.168.1.2/ODKAggregate should also display the redirect page and then display ODK Aggregate's main screen. The failure during the redirect indicates either that you did not successfully configure the database (e.g.,, MySQL requires that you manually install the MySQL Connector/J in the Tomcat libs directory) or that you specified some other IP address or hostname in the installer, and the redirect is failing because that address doesn't exist. Look at your Tomcat logs for errors. If you do not see a database error, then it is likely that the IP address is wrong; you will need to re-run the installer to re-generate the ODK Aggregate WAR file, and install the updated WAR onto your PI.

Mitch

First, I assume you are not using 127.0.0.1 to refer to the PI -- that is the address equivalent to "localhost" -- which is netspeak for "myself". It should be some value other than that.

There are two issues:

(1) does the raspberryPI have a firewall that is preventing access to the Tomcat server from other machines? This is typically configured using 'iptables' http://www.bartbania.com/index.php/iptables-security-part-ii/

(2) Less likely: is the router configured for NAT, and did you connect your other equipment on the upstream side of the router? See http://opendatakit.org/use/aggregate/tomcat-install/#Configure_for_Network_Access

Mitch

Hi,

I have the ODK Aggregate running correctly on tomcat6 when my RaspberryPi is connected to my monitor with an HDMI. It runs when I have the ethernet cable connected from the raspberry pi to a router. I am trying to get ODK Aggregate come up with its same ip address on my laptop. I have connected the pi to the router through one ethernet cable and the router to my laptop through another ethernet cable. The ip address ODK Aggregate does not load. Any ideas on what I could be doing wrong?

Thanks,

Ali Nazjoo

University of Michigan

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--

Mitch Sundt

Software Engineer

University of Washington

mitche...@gmail.com

Hi,

My IP Address is 192.168.1.2 for the Pi through a router. ODK Aggregate appears when I connect the Pi through HDMI to a TV with the same IP Address, but when I connect to my laptop through ssh only the Tomcat "It Works" page comes up with the ip address. When I try going to the ODK Aggregate page, an ODK Aggregate redirect page comes up, but ODK Aggregate does not fully load.

-Ali

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--

Mitch Sundt

Software Engineer

University of Washington

mitche...@gmail.com

Hi Mitch,

Then, when I go to the tomcat manager app I can see that ODK Aggregate has started on tomcat (attached image).

When I go to 192.168.1.2/ODKAggregate the redirect page comes up, but the form page does not load.

I don't think it is a database problem because I have transferred the MYSQL Connector J's .jar file into the Pi’s /usr/share/tomcat6/lib/

ODK Aggregate loads up through startx when connected to a monitor but not on my remote laptop.

Is there any way you can help me out?

Thanks,

Ali Nazjoo

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

Hi,
How do I set the firewall (iptables) to allow port 8080 to be accessed by my laptop?
Thanks,
Ali

··· On Wednesday, December 11, 2013 7:30:55 PM UTC-5, Mitch Sundt wrote: > On Wed, Dec 11, 2013 at 11:56 AM, wrote: > On Monday, December 2, 2013 2:11:46 PM UTC-5, Mitch Sundt wrote: > > On Sun, Dec 1, 2013 at 8:36 AM, wrote: > > On Tuesday, November 26, 2013 10:21:09 AM UTC-5, Mitch Sundt wrote: > > > On Mon, Nov 25, 2013 at 5:27 PM, wrote: > From my laptop I am able to get the tomcat "it works" page up with 192.168.1.2

Ali,

Explaining how to configure IP tables is probably outside the scope of
this list. Try http://www.bartbania.com/index.php/iptables-security-part-ii/
or https://help.ubuntu.com/community/IptablesHowTo.

To allow all incoming traffic on eth0's port 8080, the command will be
something like...
-A INPUT -i eth0 -p tcp -m tcp –dport 8080 -j ACCEPT

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Fri, Dec 13, 2013 at 12:56 PM, asnazjoo@umich.edu wrote:

On Wednesday, December 11, 2013 7:30:55 PM UTC-5, Mitch Sundt wrote:

Hmmm. The screen shot shows that you have the Tomcat server set up on port 8080.

The URL you should be using is

http://192.168.1.2:8080/ODKAggregate

And if the page is trying to redirect to port 80 (no port specified on the URL), then that is a problem. During the install process, on the screen asking for the IP address, there is a field to specify the port number. Be sure that is port 8080, or, if you have set up the iptables to route port 80 to port 8080, you can specify port 80 during the install. Also note that you need to set the firewall (I assume it is iptables) to allow port 8080 (or whatever) to be accessed by an external device.

Some Linux installations have a brain-dead firewall wrapper app that (re)configures iptables to deny access. Be sure your iptables configuration is not being overwritten or superseded by something like that.

Mitch

Mitch

On Wed, Dec 11, 2013 at 11:56 AM, asna...@umich.edu wrote:

On Monday, December 2, 2013 2:11:46 PM UTC-5, Mitch Sundt wrote:

I am confused by your 2nd sentence.

From the laptop, you should be able to open a browser, enter http://192.168.1.2/ and get the Tomcat 'it works' screen -- there shouldn't be any SSH involved.

If you specified this same IP address (192.168.1.2) during the ODK Aggregate install, navigating to http://192.168.1.2/ODKAggregate should also display the redirect page and then display ODK Aggregate's main screen. The failure during the redirect indicates either that you did not successfully configure the database (e.g.,, MySQL requires that you manually install the MySQL Connector/J in the Tomcat libs directory) or that you specified some other IP address or hostname in the installer, and the redirect is failing because that address doesn't exist. Look at your Tomcat logs for errors. If you do not see a database error, then it is likely that the IP address is wrong; you will need to re-run the installer to re-generate the ODK Aggregate WAR file, and install the updated WAR onto your PI.

Mitch

On Sun, Dec 1, 2013 at 8:36 AM, asna...@umich.edu wrote:

On Tuesday, November 26, 2013 10:21:09 AM UTC-5, Mitch Sundt wrote:

First, I assume you are not using 127.0.0.1 to refer to the PI -- that is the address equivalent to "localhost" -- which is netspeak for "myself". It should be some value other than that.

There are two issues:

(1) does the raspberryPI have a firewall that is preventing access to the Tomcat server from other machines? This is typically configured using 'iptables' http://www.bartbania.com/index.php/iptables-security-part-ii/

(2) Less likely: is the router configured for NAT, and did you connect your other equipment on the upstream side of the router? See http://opendatakit.org/use/aggregate/tomcat-install/#Configure_for_Network_Access

Mitch

On Mon, Nov 25, 2013 at 5:27 PM, asna...@umich.edu wrote:

Hi,

I have the ODK Aggregate running correctly on tomcat6 when my RaspberryPi is connected to my monitor with an HDMI. It runs when I have the ethernet cable connected from the raspberry pi to a router. I am trying to get ODK Aggregate come up with its same ip address on my laptop. I have connected the pi to the router through one ethernet cable and the router to my laptop through another ethernet cable. The ip address ODK Aggregate does not load. Any ideas on what I could be doing wrong?

Thanks,

Ali Nazjoo

University of Michigan

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--

Mitch Sundt

Software Engineer

University of Washington

mitche...@gmail.com

Hi,

My IP Address is 192.168.1.2 for the Pi through a router. ODK Aggregate appears when I connect the Pi through HDMI to a TV with the same IP Address, but when I connect to my laptop through ssh only the Tomcat "It Works" page comes up with the ip address. When I try going to the ODK Aggregate page, an ODK Aggregate redirect page comes up, but ODK Aggregate does not fully load.

-Ali

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--

Mitch Sundt

Software Engineer

University of Washington

mitche...@gmail.com

Hi Mitch,

From my laptop I am able to get the tomcat "it works" page up with 192.168.1.2

Then, when I go to the tomcat manager app I can see that ODK Aggregate has started on tomcat (attached image).

When I go to 192.168.1.2/ODKAggregate the redirect page comes up, but the form page does not load.

I don't think it is a database problem because I have transferred the MYSQL Connector J's .jar file into the Pi’s /usr/share/tomcat6/lib/

ODK Aggregate loads up through startx when connected to a monitor but not on my remote laptop.

Is there any way you can help me out?

Thanks,

Ali Nazjoo

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

Hi,
How do I set the firewall (iptables) to allow port 8080 to be accessed by my laptop?
Thanks,
Ali

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.