ODK AGGREGATE - Server is configured for remote access, not connecting locally on different machine

1. What is the problem? Be very detailed.
I have installed ODK Aggregate on a laptop as local server (Ubuntu 18.04), running on Tomcat 9.
The IP/server added on Aggregate installer was my public ip, intending to enable remote access on forms and data uploads (ODK Collect).
It's running OK (Both Collect and Aggregate), when connecting with different IP's (remotely). But i'm having difficulties trying to access it locally, on another computer. When connected to my WiFi i can access Tomcat page (http://192.xxx.x.xxx:8080) normally.. but when i try to access http://192.xxx.x.xxx:8080/ODKAggregate the browser redirects to http://'public ip':8080/ODKAggregate (the one i added on Aggregate program), not being able to access the manager/admin locally.
ODK Collect also can't download/upload forms when connected to the same network than the server.
It looks like something simple but iḿ not finding answers. Someone?

2. What app or server are you using and on what device and operating system? Include version numbers.
Ubuntu Server 18.04 - With: Apache2, Tomcat 9
Aggregate 2.0

3. What you have you tried to fix the problem?

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

mas que todo el problema a de ser en configuraciones de red en tu computadora local si te funciona correctamente odk con la ip en odk collect para la dercarga y para el sumit del formulario el problema es con la forma de coneccion de tu maquina, pero entando en una tercera computadora que no sea el servidor y accesas al odk web debes de poder ingresar a la aplicacion si no es así detalla mejor tu problema. por que a de ser con las configuraciones de odk.

¿Has intentado montarla en un servidor como digital o AWS?

si quieres ayuda estamos a disposicion

Hi there
Yes I have tried to set an local server on an old machine (Macbook) with Ubuntu Server 18.04, it has been worked fine. The ODK is connected to a Database (POSTGRESQL10 and POSTGIS).
My idea is to set this server working and manage the data on other computers, via ssh, psql, PgAdmin and LibreOffice Base. It's working fine all of then except the connection at the local network on ODKAggregate via web browser, as I sad (itś been redirecting me to my Public Ip http://45.xxx.xxx.xxx:8080/ODKAggregate).
I think is something wrong with the configuration of my local network and TOMCAT/Aggregate. But I'm not been able to solve it, if some information more is needed to help please ask!

Now I have another question. After I have established some relations on Postgresql with the tables data came from ODK Collect not been able to send filled forms on ODK Collect.
Is there any restriction on altering tables (establishing relations)?