ODK Aggregate v2.0.3 - Extremely Slow

Dear everyone,

I need help.

I have installed ODK Aggregate v2.0.3 on centos 7.6.
For some few days, everything was working fine. But as people start to send data onto the aggregate using ODK Collect, sometimes the forms timeout during submission. Also when accessing the data using the aggregate too, it takes like forever to load.

Any help on how to make this work will be much appreciated.


Do your forms contain a lot of images?

No images at all. I only have a combination of date, strings, location and integer.

The more information you can provide about your setup, the more likely that someone will be able to give you useful ideas. How did you set up Aggregate? Did you directly follow the documentation steps or do you have something like an existing database that you're connecting to? What are the hardware specifications of the server that you are running on, especially RAM and CPU? Can you look at RAM and CPU usage when this happens? Is there anything special about your network setup such as a proxy?

Have you read through other timeout threads such as ODK timing out during data pull?

1 Like

@LN, I directly followed the documentation. However, after set up and uploading the forms, I imported a backup data from our previous installation.

Here are some of the server specs.
OS is CentOS Linux release 7.6.1810
Memory is 4GB
Swap is 2GB
CPU is 12 MHz
Storage is 33.99 GB

Is there anything I can do to any of these specs to have a faster Aggregate?


Please can anyone offer some help?


As @LN suggested, you need to look at your RAM and CPU while testing a few submissions to see if there are some hints. You should also look at your Tomcat and MySQL logs. If I had to guess, you are running out of RAM.

@yanokwa Thanks very much for your input. Really appreciate. My memory has been increased to 12GB. but the issue is still the same. Even in the night when nobody is using it. Checking using the top command, here is what I discovered. both mysql and tomcat could take up to 90% of CPU.

Find attached a screenshot.

With this, what do you suggest I do?

Thanks everyone for the support so far. I have done a new installation. but this time on Ubuntu and it is super fast now. However, what I've realized is that the forms I uploaded onto aggregate show on the aggregate even when I am not logged it.

Find attached a screenshot.

1 Like

Hello everyone,
The issue is resolved. I realized the permission for the anonymous user was set to Form Manager and Data Viewer. I unchecked it and everything works fine now.


Thanks for documenting how you've solved the issue, @Saviour_Dela.