ODK Aggregate VM 1.6 Unreacheable

What is the problem? Please be detailed.
I cannot reach my ODK Aggregate Server 1.6 in bridged mode using a static address from my browser.

What ODK tool and version are you using? And on what device and operating system version?
ODK Aggregate 1.6 VM.

What steps can we take to reproduce the problem?

Set the VM in bridged mode, run 'aggregate-config --fqdn --http-port 1234' command, substituting for the appropriate details.

What you have you tried to fix the problem?

Tried different addresses with and without the subnet mask.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Hi, @ChipoHankumbaMuleya!

I'm sorry you're having problems with the VM. Let's try to troubleshoot it!

  • When you changed the VM's network to bridged mode, did you restart the VM?

  • I'd need you to log into the VM. You should see a message like "If the above URL does not work, try connecting to these IP addresses instead". Could you copy here the list of IP addresses you get?

  • When you say you run aggregate-config --fqdn --http-port 1234, the value for the --fqdn argument should be one of the IPs from above or a DNS name that resolves to one of those IPs. Could you check that, please?

Hi @ggalmazor

• I shut down the VM for me to change the network to bridged mode
• I was able to reach ODK Aggregate using the "If the above URL does not work, try connecting to these IP addresses instead" but it then redirected to the IP Address I had set using the aggregate-config script which of course then failed.
• I did use an IP address from the block of inside addresses. The other address it suggested I use as an alternative was obviously a DHCP assigned address.

I was forced to do my own VM install from scratch, which is working.

Glad to hear you've found a working solution, @ChipoHankumbaMuleya!

Would you be willing to help us troubleshoot the issue with the VM? I know it doesn't affect you now, but it might affect someone else in the future and I'd like to prevent that future person from suffering :slight_smile:

Hi @yanokwa,

I am willing to help with troubleshooting. What should/can i do?


@ChipoHankumbaMuleya I think the issue from two weeks ago is that you used bridged networking on a port that is not 80 or 443. This is a bug that we discovered a few days back and has been filed at https://github.com/opendatakit/aggregate/issues/312.

As to your current issue, let's discuss it at ODK Aggregate Server NAT Mapping Failure.