ODK aggregate (VM) loads slow and incorrectly in web browser

What is the problem? Please be detailed.
I am running the ODK aggregate VM, and I am trying to upload a survey to it so I can download it on a tablet that will be used to collect survey data. I can access the server, sort of. It takes a very long time to load (2-3 minutes), and when the page loads it looks wrong. There is only the line of text at the top and some icons in the top left. See here: https://www.dropbox.com/s/hd64d3umrwg6p3k/Screenshot%202019-02-13%2014.18.18.png?dl=0
This is the same on both Chrome and Safari on a mac, and the chrome web browser on a (old) Nexus 7 tablet.

I run the ODK aggregate VM in bridged mode in Virtualbox, and everything is connected together using a TP link router which is not connected to the internet. The TP link router gives a static IP address to the VM, based on its mac address. I have run the aggregate-config command in the aggregate command line.

What ODK tool and version are you using? And on what device and operating system version?
ODK Aggregate VM 2.0.0
Safari 12.02 / Chrome 71.0.3578.98
macOS Mojave
Virtualbox 6.0

What steps can we take to reproduce the problem?
I think the problem is in my network setup, so it will be hard to replicate.

What you have you tried to fix the problem?
Restarting the VM/Router/computer several times, tried several alternative browsers.

Hi @Hofmanpaul!

Some things come to mind:

  • Can you check the resources (memory, cpus, etc.) you've assigned to the VM?
  • Did you restart the VM after setting it in bridge network and running aggregate-config?
  • Are you accessing Aggregate with the IP address it shows after booting up? Mine shows this:


According to that, I'd need to browse

Hi Guillermo,

Thanks for the hints!

I looked at the resources (see picture attached). It gets 1024 MB of memory and is allowed the full usage of one CPU core. I think that should be enough. These were the default settings of Virtualbox.

I restarted the VM after putting it in bridge mode and running aggregate-config.

This is what my screen looks like:

I then try to connect

Everything's looking fine.

Normally, the first time accessing Aggregate could be slow-ish, but the rest should go just fine with your VM settings. The next step would be to check Tomcat's log file at /var/logs/tomcat8/catalina.out. It would be great if you could attach it to this thread.

Some comments ago you mentioned some issues with your network setup. Maybe if you describe them we can sort this out.

Hi Guillermo,

Thanks for the quick reply! I'm not sure how to access this file. I'm using the Virtual Machine so I didn't really go through the nitty gritty of setting aggregate up.

About the network setup, I have the feeling that using the server/VM as I do, without an internet connection, is not really expected user behavior, so that could be causing some issues.

That makes total sense. You shouldn't have to if you're using the VM.

Now that you mention that, Aggregate does use some external JavaScript for Google maps. I'm wondering if that's the issue. If you are using Chrome, you can inspect the network interchange with the Chrome Dev tools (hit F12 maybe? otherwise, right-click and choose "inspect" and then browse the Network tab)

1 Like

Unfortunately I didn’t have time to troubleshoot this further. Going back to an earlier version of the VM ( got it working well without an internet connection. Thanks for the help!

1 Like