ODK briefcase and Java jar script command not working consistently

1. What is the problem? Be very detailed.
When media is updated but form remains the same, sometimes the form gets pushed and sometimes it fails. Usually after a version change it gets pushed with success for a few hours and then it fails again unless the form version is updated. Sometimes even if the form version is updated the push still fails.

2. What app or server are you using and on what device and operating system? Include version numbers. using ODK briefcase v1.16.3. Server is ODK Aggregatev2.0.2 on windows 10

3. What you have you tried to fix the problem?
tried pushing forms with the java jar command but it still shows the same behaviour

4. What steps can we take to reproduce the problem?
try pushing a form through briefcase or using the java jar command with csvs or media and then update the csvs and media and push it after about 2 hours
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
I get the following message when push fails:

form- Start pushing form and submissions
form- Forcing push of form
form- Sending form
form- Error sending form:
form- There are no submissions to send
form - Success with errors

Hi @safi!

Could you attach the ’briefcase.log’ file, please? It should be located where you launch briefcase from.

briefcase.txt (27.5 KB)

Here is the log file

Hi @safi!

The log file you've attached doesn't trace any errors. Could you use Briefcase until you get the error you're reporting and then attach the log file again, please?