ODK Briefcase pulls, but will not export

1. What is the problem? Be very detailed.

I am attempting to pull and then export my data from ODK Collect to CSV. I want to check the format of the output files before I begin collecting real data. I am able to copy the data from my Android device onto my computer, and I am able to successfully Pull using ODK Briefcase. However, when I attempt to export to CSV it appears to initiate on my click but then does not move past the progress bar glowing blue and the Last Export column still reads "Not exported yet." I am not getting any error messages.

2. What app or server are you using and on what device and operating system? Include version numbers.
I am using ODK Briefcase v1.17.2, on a Mac running OS X El Capitan (version 10.11.6).

3. What you have you tried to fix the problem?
I have searched this forum and outside this forum for hints but found nothing relevant. I've tried uninstalling and reinstalling Briefcase, I've tried clearing the relevant directories and re-doing the whole process. I've also tried taking a break for a day so that I am less annoyed :sweat_smile:

4. What steps can we take to reproduce the problem?
I am not sure! I am following the steps in the various ODK guides on exporting from Briefcase but can't garner additional information.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

briefcaselog.txt (2.5 KB)

Hi, @Michelle_Kline! I'm sorry you're having trouble with Briefcase.

Unfortunately, the log file you've attached doesn't shed any light into the situation. I think I would need to have access at least to the form(s) you're working with so that I try to recreate the same issue in my computer. Ideally, you could send me some submissions too, but I'm not sure if you're at the liberty of sharing them with me. You can send me the files to my email at ggalmazor@gmail.com

Hi, @Michelle_Kline! Just wanted to give you a heads up about something :slight_smile: I will be able to assist only until next Friday. Starting next week I'm switching to another job and won't be contributing to ODK for a while...

Hi Guillermo,

Thank you for letting me know - I sent the ODK directory from my device to you at the email address you provided, in a separate email.



I had the same issue with 1.17.4 but then I tried with 1.16.3 and export worked.


Please i have a similar problem, but this time. There's a form ID named "Version_4" and it was deleted from the device, so "Version_5" was downloaded. I have extracted the folder from the device.

Using the briefcase, it pulls but it can't export.

I opened "Version_5" in note++ just to the "Version_5" to "Version_4", but i still can't export the data.

Please any recommendation/help is appreciated.
Let me know the file(s) you need, and I will supply them.

The log file is attached here.

briefcase1.txt (42.2 KB)