ODK Briefcase v1.15 CLI errors

1. What is the problem? Be very detailed.
Exports with the new ODK Briefcase produce the error in the screenshot as well as either a "form not found" or "timeout" error.

2. What app or server are you using and on what device and operating system? Include version numbers.
Errors with all platforms (kobo, odk aggregate, ONA etc.)

3. What you have you tried to fix the problem?
I have tried to move the Briefcase to different locations to reduce the risk of interference from previously downloaded versions. I have also tried to test using the GUI but the GUI normally doesn't open.

4. What steps can we take to reproduce the problem?
Try to download data using ODK Briefcase version 1.15 and the command line interface, preferably from a kobo platform but it should be possible to replicate on other platforms as well.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
Please see attachment. Any useful ideas would be much appreciated.
Also for anyone using KOBO, how do you verify a form_id? When i download the URL only the form_title and the automatically generated id_string are included. has anyone successfully used the Briefcase v1.15 CLI with KOBO?


@noel What version of Windows are you running? And what version of java (Run java -version on the command line)

looks like version 8 release 201 unless I am reading it incorrectly. Is it possible that the age of our windows server means its losing compatibility? thanks for any info or direction to troubleshoot with!



Hi @Noel!

Briefcase uses Java's preference system to store information and metadata, and Java delegates on a platform specific implementation, which, in your case is failing.

There's a quick thing you could try by running Briefcase with the -c argument, which will clear all your saved preferences. You will lose your settings and saved server configurations, though.

If this doesn't work, you could try to check the files where Java stores the preferences (they're XML documents). The location in your system depends on your operating system and your Java release. Some sources point to HKEY_CURRENT_USER\Software\JavaSoft\Prefs but you might need to search elsewhere. You will find several preference files scattered through different directies inside.

I think this is a longstanding bug in Java. It was fixed in Java 9 and it should be backported to Java 1.8.0_202. You can track the issue at https://bugs.openjdk.java.net/browse/JDK-8139507.

Probably the safest and easiest fix is to upgrade to the latest Java 8 (8u211).

You can also manually add the keys to the registry using these instructions at https://stackoverflow.com/a/17552837/152938, but that editing registry keys is not for the faint of heart.

1 Like


I followed the suggested steps of upgrading to Java 8u211 and clearing the preferences and am now able to export from ODK Aggregate so thanks very much for this help already. The error message displays but the export looks to work just fine otherwise.

The GUI doesn't appear still but I suspect this may be because I have had multiple versions of ODK Briefcase on the same computer.

I think the main obstacle now is knowing which field to use as "form_id" when loading from Kobo. I would be very grateful if anyone knows if the id_string or form_title should work

best regards,


Glad the fix worked!

The UI will not appear if you are using the CLI commands. But if you run java -jar Briefcase.jar or double-click the jar the GUI should appear. If it doesn't attach the briefcase.log to a post and we can review it.

Which field to use with Kobo is probably best asked at https://www.kobotoolbox.org/#help, but my guess would be the id_string.